Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th November 2007, 17:06
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 149 Times in 130 Posts
Default .htaccess and Options All -Indexes

In one of my .htaccess file I have the following: Options All -Indexes

Now the problem is that when added to the .htaccess file the Options All -Indexes will throw a 500 error.
Quote:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
...
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
I tried adding the Options All -Indexes to the ISPconfig's Apache Directives, but this does not work.

Any suggestions on how to get the Options All -Indexes to work?
Without it the script will not work correct :/
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Sponsored Links
  #2  
Old 11th November 2007, 17:20
mattias mattias is offline
Junior Member
 
Join Date: Nov 2007
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

having same problem, getting that 500 error,
i hope someone know a solution ^.^
Reply With Quote
  #3  
Old 11th November 2007, 18:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Please have a look at the error log of the website to get a detailed error message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 11th November 2007, 18:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

@edge. Put the line in the apache directives field instead of a .htaccess file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 11th November 2007, 21:16
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 149 Times in 130 Posts
Default

Quote:
Originally Posted by till
@edge. Put the line in the apache directives field instead of a .htaccess file.
Thank you till, but as you can see I've tested this already in post1

I'm now not sure if it's a script error, or the Options All -Indexes

Problem that I'm having is like this:
PHP Code:
Workinghttp://www.domain.tld/thumbnail.php?file=logo.gif&size=medium
Not workinghttp://www.domain.tld/thumbnail.php?file=logo.gif&size=medium 
Note the & in working and & in not working.

Now I'm not 100% sure anymore if this is caused by the Options All -Indexes problem.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #6  
Old 12th November 2007, 03:03
mattias mattias is offline
Junior Member
 
Join Date: Nov 2007
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

in httpd.conf you need to set AllowOverride All to the directory of /var/www/*/web and /var/www/*/user/*/web, you can do this per user acc in with a whole set of directives, the default of ISPConfig seems to add so you can't set Options in .htaccess, among other things.

im by no means a security expert, so i don't know why it is like this.

i kept my httpd.conf as it was and set the configurations per acc instead
Reply With Quote
  #7  
Old 12th November 2007, 08:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
im by no means a security expert, so i don't know why it is like this.
If you set AllowOverride to all like you did, very customer is able to enable all functions in apache that he wants, even if he has not paid for them or if the functions contain security problems. Never enable AlloeOverride All on a server that is not just usd as personal home server without customers that you trust 100%.

AllowObverride All is not needed if you put the directives in the apache directives field.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 12th November 2007, 12:53
mattias mattias is offline
Junior Member
 
Join Date: Nov 2007
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

yeah, i've only done AllowOverride All on my user.
but how can i enable custom .htaccess things like "suPHP_ConfigPath" without AllowOverride All? I've been looking and looking, but can't find any answer...

edit: ok so, somehow i don't get error 500 anymore, and i use the defaults, and i decided to not let each user use their own php.ini and instead make a good global php.ini working with as much applications as possible...

Last edited by mattias; 13th November 2007 at 02:23.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange "client" [ ::1] causing "Directory Index Forbidden by Options Directive" Err bpmee Server Operation 19 17th June 2008 16:01
Apache won't start: "Too many files error"? bpmee Server Operation 4 31st July 2007 13:37
Beyrl and Ubuntu 7.04 Toriacht Desktop Operation 17 23rd June 2007 21:40
ISPConfig DDNS admin login fala Installation/Configuration 16 10th August 2006 17:19
Enable Indexes in a particular directory Crank Ninja Installation/Configuration 3 21st December 2005 01:20


All times are GMT +2. The time now is 22:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.