#1  
Old 24th January 2008, 05:18
rickygm rickygm is offline
Junior Member
 
Join Date: May 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default bluetooth and pin_helper

hello forum, I am trying to connect my cellular phone sony ericsson w880i with my centos 5, I have installed the packages

bluez-utils-3.7-2.el5.centos
bluez-libs-3.7-1
bluez-hcidump-1.32-1

when I restart the bluetooth he tells me that it doesn't recognize the password

Unknown option 'pin_helper' line 5
Jan 23 22:11:23 xserver hcid[22723]: syntax error line 5
Jan 23 22:11:23 xserver hcid[22723]: Register path:/org/bluez fallback:1

I have trying with passkey and pin_helper but it doesn't work me

Reply With Quote
Sponsored Links
  #2  
Old 24th January 2008, 07:21
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Post your configuration, as you can see from the logs you have a syntax error on line 5 of one of your configuration files am guessing /etc/bluetooth/hcid.conf
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 24th January 2008, 17:44
rickygm rickygm is offline
Junior Member
 
Join Date: May 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

options {
autoinit yes;
security auto;
pairing multi;
pin_helper /usr/bin/bluepin;
}

device {
name "MY PHONEC";
class 0x000100;
iscan enable; pscan enable;
lm accept;
lp rswitch,hold,sniff,park;
}
Reply With Quote
  #4  
Old 24th January 2008, 18:06
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

the "pin_helper" option is only valid with bluez-libs-2.x & bluez-utils-2.x and below.

Thats what is causing the service to fail to start up.

Bluez-3.X has replaced pin helpers with passkey agents such as kbluetoothd and bluez-gnome, the bluez-utils also comes with an command line agent passkey-agent.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.

Last edited by topdog; 24th January 2008 at 18:09.
Reply With Quote
  #5  
Old 24th January 2008, 19:05
rickygm rickygm is offline
Junior Member
 
Join Date: May 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

but that command passkey-agent doesn't have it installed, and my version of is

bluez-gnome-0.5-5.fc6

?

with the option of the passkey inside the hcid.conf, the cellular one requests me the PASSWORD every 5 seconds and it doesn't connect with my PC

as I can solve that?
Reply With Quote
  #6  
Old 24th January 2008, 19:17
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
 
Default

First you need to remove that option from your hcid.conf file then restart bluetooth, if you leave the option in bluetooth will not run.

I have not used bluez-gnome as i use kbluetoothd, but it is supposed to popup a dialog for you to type the pin in.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.