#1  
Old 9th November 2007, 20:02
grandpagenocide grandpagenocide is offline
Senior Member
 
Join Date: Jun 2007
Location: Brooklyn, NY
Posts: 308
Thanks: 13
Thanked 43 Times in 29 Posts
Send a message via AIM to grandpagenocide Send a message via MSN to grandpagenocide
Default dev 2.3.3 awstats

ok, I have dev 2.3.3 and awstats installed it has been over 24 hours, actually a few weeks and I keep getting 404 not found when i try to go to http://domain/stats or http://domain/awstats I have tried https://domain....
any ideas
Reply With Quote
Sponsored Links
  #2  
Old 9th November 2007, 22:35
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 531
Thanks: 11
Thanked 175 Times in 79 Posts
Default

Some days back I found out that AWStats was not working in 2.3.3. This is due because the changes in SVN were overwritten. There is no easy solution for this problem, Till is looking at which other files has been overwritten.
2.3.4 will surely correct this problem.

Sorry for the inconvenience.
Reply With Quote
  #3  
Old 10th November 2007, 07:58
grandpagenocide grandpagenocide is offline
Senior Member
 
Join Date: Jun 2007
Location: Brooklyn, NY
Posts: 308
Thanks: 13
Thanked 43 Times in 29 Posts
Send a message via AIM to grandpagenocide Send a message via MSN to grandpagenocide
Default

JNSC thanks for the info. Is there a way to get webalizer working again in 2.3.3 so my clients who are having a fit over not having stats will shut up.
Reply With Quote
  #4  
Old 10th November 2007, 15:31
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 531
Thanks: 11
Thanked 175 Times in 79 Posts
Default

You can add this lines to /root/ispconfig/scripts/lib/config.lib.php

Code:
////////////// Web Statistics ////////////////////
  $stats_alias = "";
  
   if($web["web_stats"] == "awstats"){
     $stats_alias = "Alias /stats \"".$document_root."/awstats\"";
   } elseif ($web["web_stats"] == "webalizer") {
     $stats_alias = "Alias /stats \"".$document_root."/webalizer\"";
   }
  ////////////// END of Web Statistics ////////////////////
Just after :
Code:
if($apache_version == 1){
     $error_alias = "";
   }
   if($apache_version == 2){
     $error_alias = "Alias /error/ \"".$document_root."/error/\"";
   }
Just before :
Code:
 ////////////// Error Pages ////////////////////
   if($web["web_individual_error_pages"]){
You also have to uncomment this line in root/ispconfig/isp/conf/vhost.conf.master

Code:
# {STATSALIAS}
Reply With Quote
  #5  
Old 11th November 2007, 22:47
grandpagenocide grandpagenocide is offline
Senior Member
 
Join Date: Jun 2007
Location: Brooklyn, NY
Posts: 308
Thanks: 13
Thanked 43 Times in 29 Posts
Send a message via AIM to grandpagenocide Send a message via MSN to grandpagenocide
Default

ok, I have done all that and forced the cron job with /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php now how do I access the stats? using http://mydomain.com/awstats still gives me a page not found
Reply With Quote
  #6  
Old 12th November 2007, 00:13
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 531
Thanks: 11
Thanked 175 Times in 79 Posts
Default

you have to use /stats you can check in your apache conf file that the alias has been created for your website.
Reply With Quote
  #7  
Old 17th November 2007, 15:53
grandpagenocide grandpagenocide is offline
Senior Member
 
Join Date: Jun 2007
Location: Brooklyn, NY
Posts: 308
Thanks: 13
Thanked 43 Times in 29 Posts
Send a message via AIM to grandpagenocide Send a message via MSN to grandpagenocide
 
Default

yes it did create the alias in the httpd conf. Now it kills httpd conf, so i had to go back and comment out every instance of {STATSALIAS} in httpd.conf to get it running again
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dev 2.3.3 issues grandpagenocide Installation/Configuration 1 7th November 2007 15:38
2.3.3 Dev TYPO3 Install??? grandpagenocide Installation/Configuration 10 24th October 2007 00:58
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38
AWStats jnsc Developers' Forum 5 7th February 2007 15:53
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 16th May 2006 00:04


All times are GMT +2. The time now is 05:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.