Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th November 2007, 21:11
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Question /etc/group problem

I have a conflict in my /etc/group file:

Code:
 
.
admispconfig:x:101:admispconfig
web1:x:10001:admispconfig,mysite1
web2:x:10002:admispconfig,mysite2
ossec:x:10003:apache
web3:x:10003:admispconfig,mysite3
When I installed Ossec it automatically created "ossec:x:10003".
Later when I created mysite3 in ISPConfig it duplicated "10003".

I have to leave Ossec at 10003 or it will not work.

What's the best way to fix this?
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
Sponsored Links
  #2  
Old 8th November 2007, 09:43
Theophilus Theophilus is offline
Junior Member
 
Join Date: Nov 2007
Posts: 3
Thanks: 0
Thanked 2 Times in 2 Posts
Default

You could change web3 from 10003 to 10004.

Then fix permissions with:

Code:
chgrp -R 10004 /var/www/web3
Or you could backup the web3 account, delete it, then restore it as a new account.
Reply With Quote
The Following User Says Thank You to Theophilus For This Useful Post:
wpwood3 (8th November 2007)
  #3  
Old 8th November 2007, 12:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Or you could backup the web3 account, delete it, then restore it as a new account.
This will be the better solution. If you just change the group number with chgrp, you will get a conflict with the next web created by ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 8th November 2007, 16:39
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Default

Quote:
Originally Posted by till
This will be the better solution. If you just change the group number with chgrp, you will get a conflict with the next web created by ISPConfig.
Thanks but...

It looks to me that ISPConfig is using an auto_increment counter in it's MySQL database to generate 10001,10002,10003, etc.

If I can simply change the Next Autoindex to 10005 then the chgrp fix would work. Unfortunately, I don't know what table in the database holds this value.
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
  #5  
Old 8th November 2007, 19:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

It's isp_isp_user.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 8th November 2007, 19:35
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Question

Quote:
Originally Posted by falko
It's isp_isp_user.
That doesn't make sense to me...
I don't see a field in the isp_isp_user table that would correspond to the groups (10001,10002,10003,etc).

I would think it would be isp_isp_web. That is where my 3 websites are and the doc_id has a Next Autoindex of 4. Can't I just change that to 5 in phpMyAdmin?

Then I can do the chgrp to make web3 10004.
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography

Last edited by wpwood3; 8th November 2007 at 19:59.
Reply With Quote
  #7  
Old 8th November 2007, 20:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The group ID should correspond to the doc_id if the table isp_isp_web (you must add the minimum group id that is set in server settings to the doc_id, the default is 10000).

The userid corresponds to doc_id in the table isp_isp_user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 8th November 2007, 20:04
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Default

Quote:
Originally Posted by till
The group ID should correspond to the doc_id if the table isp_isp_web (you must add the minimum group id that is set in server settings to the doc_id, the default is 10000).

The userid corresponds to doc_id in the table isp_isp_user.
Thanks Till.
I think you were posting your response at the same time I was revising my post above!

I don't think I would need to change anything in isp_isp_user. As far as I can see, the only conflict I have is with the group id.

Correct?
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
  #9  
Old 8th November 2007, 20:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Yes, changing the autoincrement value of the isp_isp_web table should be enough.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
wpwood3 (8th November 2007)
  #10  
Old 8th November 2007, 20:24
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
 
Talking Fixed!

To recap, I did these first 2 steps in phpMyAdmin:

1) Changed doc_id Next Autoindex to 5 in table isp_isp_web

2) Changed doc_id to 4 in table isp_isp_web for web3

3) Next I edited /etc/group

changed
Code:
web3:x:10003:admispconfig,mysite3
to
Code:
web3:x:10004:admispconfig,mysite3
4) Then I did
Code:
chgrp -R 10004 /var/www/web3
5) Finally I did this
Code:
chown -h root:root /var/www/web3/Maildir
I don't know if step 5 was critical but it did make the Maildir synlink group ownership consistent with the way ISPConfig creates the Maildir symlink in my other webs.
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography

Last edited by wpwood3; 11th November 2007 at 03:48.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56


All times are GMT +2. The time now is 07:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.