#1  
Old 16th December 2005, 20:00
binary_dreamer binary_dreamer is offline
Junior Member
 
Join Date: Dec 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem with new kernel

hi there.
i am running debian's stable codenamed Sarge. i followed the tutorial from http://www.howtoforge.com/forums/showthread.php?t=21
about installing a new kernel. after that when i boot the system to the new kernel all i get is:
VFS: cannot open root device "hda5" or unknown-block (0,0)
please append a correct "root=" boot option
kernel panic - not syncing : VFS :unable to mount root fs on unknown -block(0,0)
Reply With Quote
Sponsored Links
  #2  
Old 17th December 2005, 15:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Can you post the contents of /boot/grub/menu.lst and /etc/fstab?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd January 2006, 22:32
Januss Januss is offline
Junior Member
 
Join Date: Jan 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Is your root FS built into the kernel.

Had the same problem with 2.6.8.
Adding initrd.img-2.6.8 to menu.lst didn't help, just leaded to the next error:
/dev/console not found.
I think that the solution to my problem was - compiling the root filesystem (where / is mounted, for me it was ext3) support in the kernel. I am not 100% sure, because I changed kernel .config quite alot, but I think that this was the main problem.

P.S. Maybe I'm wrong. but then again.. maybe im not.
Hope this helps someone.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile Kernel 2.6 under Debian Sarge falko Kernel Questions 117 28th September 2009 14:03
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 02:56
Apache not adding domains adamluz Server Operation 3 16th August 2005 21:20
Use kernel 2.4 config for kernel 2.6? rookie Kernel Questions 1 20th May 2005 16:15
Install Debian Sarge with Kernel 2.6 root Installation/Configuration 4 10th May 2005 11:51


All times are GMT +2. The time now is 23:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.