Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th November 2007, 12:39
caffetin caffetin is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default invalidd used storage space

Not sure if that caused the problem but I noticed after I have updated the ispconfig that the used storage space on every site displays 0. the general information about the used disk space is ok, and from time to time I get notices if some user is nere or has exceeded their limit.
what could be the problem?

Last edited by caffetin; 6th November 2007 at 14:03.
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2007, 14:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Have you tried to set $go_info["server"]["sudo_du_enabled"] to 1 in /home/admispconfig/ispconfig/lib/config.inc.php?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th November 2007, 14:35
caffetin caffetin is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, I also added the ispconfig user to the sudoers file so that it can acces the /usr/bin/du
Reply With Quote
  #4  
Old 8th November 2007, 18:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by caffetin
that the used storage space on every site displays 0.
Hm, do you have a screenshot of this?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th November 2007, 14:15
caffetin caffetin is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default screenshot

here it is.
I have also noticed that the du command does not give me any useful info for example:

[root@ruby /]# du -h /home/web19/
[root@ruby /]#

does not output anything
Attached Images
  
Reply With Quote
  #6  
Old 10th November 2007, 20:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

That's strange. Only for that directory, or for any directory?
What's the output of
Code:
ls -la /home/web19
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 12th November 2007, 09:35
caffetin caffetin is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thats what is bottering me that the same output is given for every directory I try to check with the du command.

[root@ruby ~]# ls -la /home/web19/
total 56
drwxr-xr-x 8 web19_ad web19 4096 Nov 6 09:23 .
drwxr-xr-x 108 root root 12288 Nov 9 11:47 ..
-rw------- 1 web19_ad web19 24 Nov 6 09:23 .forward
-rw-rw-r-- 1 root web19 26 Nov 12 04:02 .htpasswd
-rw-r--r-- 1 root root 450 Nov 6 09:23 .procmailrc
lrwxrwxrwx 1 root root 43 Nov 6 09:23 .spamassassin -> /home/web19/user/web19_admin/.spamassassin/
lrwxrwxrwx 1 root root 44 Nov 6 09:23 .vacation.cache -> /home/web19/user/web19_admin/.vacation.cache
lrwxrwxrwx 1 root root 36 Nov 6 09:23 Maildir -> /home/web19/user/web19_admin/Maildir
drwxrwxr-x 2 web19_ad web19 4096 Jul 20 13:54 cgi-bin
drwxr-xr-x 3 web19_ad web19 4096 Nov 2 00:30 log
drwxrwxrwx 2 web19_ad web19 4096 Jul 20 13:49 phptmp
drwxr-xr-x 2 web19_ad web19 4096 Jul 20 13:49 ssl
drwxr-xr-x 3 web19_ad web19 4096 Jul 20 13:50 user
drwxrwxr-x 13 web19_ad web19 4096 Sep 12 04:05 web

Last edited by caffetin; 12th November 2007 at 10:42.
Reply With Quote
  #8  
Old 13th November 2007, 16:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by caffetin
[root@ruby ~]# ls -la /home/web19/
total 56
drwxr-xr-x 8 web19_ad web19 4096 Nov 6 09:23 .
drwxr-xr-x 108 root root 12288 Nov 9 11:47 ..
-rw------- 1 web19_ad web19 24 Nov 6 09:23 .forward
-rw-rw-r-- 1 root web19 26 Nov 12 04:02 .htpasswd
-rw-r--r-- 1 root root 450 Nov 6 09:23 .procmailrc
lrwxrwxrwx 1 root root 43 Nov 6 09:23 .spamassassin -> /home/web19/user/web19_admin/.spamassassin/
lrwxrwxrwx 1 root root 44 Nov 6 09:23 .vacation.cache -> /home/web19/user/web19_admin/.vacation.cache
lrwxrwxrwx 1 root root 36 Nov 6 09:23 Maildir -> /home/web19/user/web19_admin/Maildir
drwxrwxr-x 2 web19_ad web19 4096 Jul 20 13:54 cgi-bin
drwxr-xr-x 3 web19_ad web19 4096 Nov 2 00:30 log
drwxrwxrwx 2 web19_ad web19 4096 Jul 20 13:49 phptmp
drwxr-xr-x 2 web19_ad web19 4096 Jul 20 13:49 ssl
drwxr-xr-x 3 web19_ad web19 4096 Jul 20 13:50 user
drwxrwxr-x 13 web19_ad web19 4096 Sep 12 04:05 web
The output looks ok.

Quote:
thats what is bottering me that the same output is given for every directory I try to check with the du command.
For any directory, even if it wasn't created by ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th November 2007, 08:42
caffetin caffetin is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I haven't tried that before, it looks like the du works ok with the folders that the system created but it dosn't work with the folders that ispconfig created.
Reply With Quote
  #10  
Old 14th November 2007, 10:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,803
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
 
Default

Which filesystem type do you use for the home partition?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Storage space Tripple Installation/Configuration 1 15th October 2007 09:30
Space problem fobicodam General 5 3rd August 2007 23:38
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
Compiling kernel for FC6 fills up disk space ginda Kernel Questions 5 13th January 2007 15:43
Unlimited disk space reseller Davide General 4 27th July 2006 13:44


All times are GMT +2. The time now is 11:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.