Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th November 2007, 23:14
kmullen kmullen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect server on CentOS 5.0 64 bit

I'm using the instructions on the Perfect Server CentOS 5.0 (32 bit) on a 64 bit server. I am using the 64bit installation CD's.

When I get to the part :
/etc/init.d/httpd start

after the php installation line and editing the httpd.conf script, it fails returning:

Invalid command 'index.php3', perhaps misspelled or defined by a module not included in the server configuration

If I delete that in the DirectoryIndex I get the same error for index.pl.

Any help?
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2007, 20:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Please make sure that the DirectoryIndex line is just one line, not multiple ones.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
symmathites (28th June 2008)
  #3  
Old 7th November 2007, 01:46
kmullen kmullen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Right again

Falko,

Thanks for taking the time to answer all these questions on the forum. You were exactly right. The resolution on my screen did not allow me to put everything on one line.

Modified and all is fine. Is there a way to type a symbol would tell nano that something is all one line rather than wrapping the text?

Thanks again.

Kurt Mullen
Reply With Quote
  #4  
Old 11th November 2007, 12:33
tinkerbox tinkerbox is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Cant open ISPConfig URL

rather than start new topic, I thought i can use this to group same problem for CentOS 5 64bit

I just got the new server from Softlayer, so the OS is still fresh. First step was, configure my box with this tutorial: perfect_setup_centos5.0

There is no error from step #3(of course SL did the OS install) untill I finished install the ISPConfig. So I tried to open the default URL: https://www1.domain.com:81, not working
Next i tried open https://www1.domain.com - SSL works
I also try using the IP, same...

Then I tried changing the port to 2087(WHM port, and few more free port), this doesnt work as well. tried reboot, check all the service is running and try to open ISPConfig url again, still no luck

No firewall install on the server, and I have disable firewall on my pc. I have tried this, install centos 5 on my pc and configure it with ISPconfig. It works on my pc.

I just sent ticket to SL, asking if any problem with the port(although i dont think they block it, just hope if they can advise something..)

Any idea??
Im lookin in the darkness...

Last edited by tinkerbox; 11th November 2007 at 12:54.
Reply With Quote
  #5  
Old 11th November 2007, 16:12
tinkerbox tinkerbox is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I solved this myself. As i thought no firewall install, actually there is, installed by SL. I thought i removed it :P

This two lines fixed the problem:
service apf stop
service iptables stop

Someone might asking later, how did i change the port. Stop the ispconfig service:
/etc/rc.d/init.d/ispconfig_server stop

Edit this file, search for port 81 or $go_info["server"]["server_url"], change with port number you want
nano /home/admispconfig/ispconfig/lib/config.inc.php

Edit this file, change every port 81 you find:
nano /root/ispconfig/httpd/conf/httpd.conf

Start ispconfig:
/etc/rc.d/init.d/ispconfig_server start
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VMware Server on Linux Host (CentOS?) BlahBlah Suggest HOWTO 10 13th February 2010 04:16
Centos 5 Perfect Install with SSH tal56 Installation/Configuration 3 31st October 2007 06:23
CentOs 4.5 Perfect Server ISPConfig install error sird Installation/Configuration 4 25th June 2007 05:35
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44
Perfect CENTOS 4.4 32 Bit Installation and ncftp joeinazusa Installation/Configuration 1 25th December 2006 14:18


All times are GMT +2. The time now is 05:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.