Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th December 2005, 12:15
igorj igorj is offline
Junior Member
 
Join Date: Nov 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy File size limit exceeded ?

Hello everyone.
I must say that Im total newbie with ispconfig, but I like it already.

I recently installed ispconfig 2.0.6 on Debian 3.1 and I have a following problem with webalizer statistics.

For virtual hosts which have web.log file that is 2048M in size statistics is not working.
When I try to run webalizer manually I get error that said:

File size limit exceeded

What is wrong ?

Please help. Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 14th December 2005, 12:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

This is what I found:
http://www.madirish.net/tech.php?section=5&article=27
http://www.linuxquestions.org/questi...ad.php?t=32681
http://info.ccone.at/INFO/Mail-Archi.../msg00504.html
http://archives.postgresql.org/pgsql...3/msg00260.php
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th December 2005, 02:40
martinoc martinoc is offline
Junior Member
 
Join Date: Dec 2005
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by igorj
Hello everyone.
I must say that Im total newbie with ispconfig, but I like it already.

I recently installed ispconfig 2.0.6 on Debian 3.1 and I have a following problem with webalizer statistics.

For virtual hosts which have web.log file that is 2048M in size statistics is not working.
When I try to run webalizer manually I get error that said:

File size limit exceeded

What is wrong ?

Please help. Thanks in advance.
Hi,

I came accross this problem recently and I have the solution!
The default stock kernel that comes with Debian 3.1 is kernal-image....i386
this means that it will run on any x86 machine. However the options for LFS (Large File System) have not been enabled in this kernel .

Your choices are a)to compile a custom kernel or more likely for the newbie
b) download the kernel-image...i686
at the moment this is kernel-image-2.6.8-2-686

so just type:

Code:
apt-get install kernel-image-2.6.8-2-686
and then reboot. The problem should then be fixed.
Reply With Quote
  #4  
Old 16th March 2006, 02:27
Pana Pana is offline
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the exact same problem.... I'm running the 2.6.8-2-k7 kernel on debian sarge..

/etc/fstab/
----------------
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
/dev/hda5 none swap sw 0 0


I've read through all the threads and searched google etc and haven't found a solution to fix this.... I read here: http://www.linuxquestions.org/questi...ad.php?t=32681 that this guys problem came from bastille's configuration. From what I can see bastille (well, the one supplied with ispconfig) doesn't have an effect on the filesystem... only firewall.

I've also check disk quotas... there are no limits set... including for www-data user:
Disk quotas for user www-data (uid 33):
Filesystem blocks quota limit grace files quota limit grace
/dev/hda1 14008588 0 0 105161 0 0


"ulimit -a" reports this
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
file size (blocks, -f) unlimited
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) unlimited
virtual memory (kbytes, -v) unlimited

so it doesn't appear to be a bash enforced limit.

Can anyone think of anything else?
Reply With Quote
  #5  
Old 16th March 2006, 11:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
 
Default

Maybe it's really a problem with the kernel, as martinoc suggested. You could try to install another one.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 14:01
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 10:53
IMAP & POP3 FC3 Samer A. Yaghi Installation/Configuration 6 17th October 2005 12:54
/stats doesn't work (password not accepted) Hellbound General 6 15th September 2005 15:34


All times are GMT +2. The time now is 12:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.