Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th October 2007, 21:54
ACDII ACDII is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 7
Thanked 3 Times in 3 Posts
Question Postfix sending mail from webpage problem

I have a FC6 server that I run ISPconfig on. I have our main website setup on it pre-release pending a successful test of the contact us page. Problem is, the server domain is the same as the website domain and the mail gets sent to itself. I setup the website to use external mailserver, but when I send an email it winds up on the root mailbox. the box is server.domain.cxm and the website is www.domain.cxm. Email from the contact forms is sent to address@domain.cxm, and the logs show the mail being sent locally. How do I get the emails to be sent to our exchange server for this domain instead?
Reply With Quote
Sponsored Links
  #2  
Old 31st October 2007, 08:02
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,990
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
Default

You must set the website AND the co-domain to external mailserver.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st October 2007, 17:18
ACDII ACDII is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 7
Thanked 3 Times in 3 Posts
Default

I dont have a co domain setup for this.
Reply With Quote
  #4  
Old 31st October 2007, 18:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

domain.cxm is not set up in ISPConfig? Does it show up in /etc/postfix/local-host-names?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd December 2007, 05:47
ACDII ACDII is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 7
Thanked 3 Times in 3 Posts
 
Default

yes it is in there. I created a work around for now by sending the email to another domain not associated with this server, but had to force postfix to relay everything and not use DNS for it to work. Now that I think about it, it may be that I have the wrong internal DNS server in there. I just changed it to use the correct one and will give it a test when I get back to work.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: Cant send mail - Ubuntu Edgy + Postfix + Saslaught mrmagoo Server Operation 1 1st December 2006 15:56
Postfix sending mail to wrong mailbox/user 3cwired_com Installation/Configuration 8 30th October 2006 21:31
sending mail to two address with postfix paulley Server Operation 1 3rd July 2006 23:34
problems sending receiving mail on Postfix mavgh1 HOWTO-Related Questions 17 10th March 2006 12:43
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 13:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.