#1  
Old 14th December 2005, 00:52
keyser_soze keyser_soze is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Apache2 setup

I think this is a quick nube question.

I have Debian stable installed and have set up two virtual hosts, one on port 80 and the other a secure site on port 443. Currently, they both point to the same site.

I can access the site if I type www.site.com/index.phtml but www.site.com brings up
www.site.com/apache2-default/

How can I correct this?

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 14th December 2005, 01:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Please post your vhost configuration.
Reply With Quote
  #3  
Old 14th December 2005, 01:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

You can try to change the DirectoryIndex directive in your Apache configuration so that index.phtml comes first, e.g.
Code:
DirectoryIndex index.phtml index.html ...
Don't forget to restart Apache afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 14th December 2005, 06:03
keyser_soze keyser_soze is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Please post your vhost configuration.
I am not sure what you are referring to. Are you asking for the files in sites-enabled?
Reply With Quote
  #5  
Old 14th December 2005, 06:04
keyser_soze keyser_soze is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
You can try to change the DirectoryIndex directive in your Apache configuration so that index.phtml comes first, e.g.
Code:
DirectoryIndex index.phtml index.html ...
Don't forget to restart Apache afterwards.
Thanks for the suggestion. index.phtml was not in the list. I added it in but the problem is still there. (and yes, I did restart Apache2 afterwards.)
Reply With Quote
  #6  
Old 14th December 2005, 12:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Quote:
Originally Posted by keyser_soze
I am not sure what you are referring to. Are you asking for the files in sites-enabled?
Yes, if you added the vhost there.
Reply With Quote
  #7  
Old 14th December 2005, 13:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by keyser_soze
Thanks for the suggestion. index.phtml was not in the list. I added it in but the problem is still there. (and yes, I did restart Apache2 afterwards.)
Did you put index.phtml in the first place?

Quote:
I am not sure what you are referring to. Are you asking for the files in sites-enabled?
If you're on Debian Sarge, then yes, the default vhost is in sites-enabled.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 14th December 2005, 13:41
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default

actually, by default debian does this on the "default" vhost in "/etc/apache2/sites-available/default". You need to either create a separate vhost and leave this default in tact... or just remove the line that looks similar to "Redirect blahbla /apache2-default/" .... err maybe its "Rewrite".... dunno
__________________
themachine
5dollarwhitebox.org
Reply With Quote
  #9  
Old 14th December 2005, 14:21
keyser_soze keyser_soze is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by themachine
or just remove the line that looks similar to "Redirect blahbla /apache2-default/" .... err maybe its "Rewrite".... dunno
BINGO!

Thanks to all for your help!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 23:06
apache2 with mod_cache and mod_mem_cache Ovidiu Server Operation 3 6th April 2006 18:37
Attempting The Perfect Setup (To Some Extent) PsyVision HOWTO-Related Questions 3 3rd November 2005 12:50
Perfect setup (debian sarge) Pelle Installation/Configuration 4 11th October 2005 18:17
Suse 9.3 setup probs with php5 hyperclock Tips/Tricks/Mods 0 21st September 2005 03:34


All times are GMT +2. The time now is 05:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.