#1  
Old 13th December 2005, 03:33
kingkunt kingkunt is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation cant connect to ispconfig

Im using suse9.3 perfect setup and just finished a clean install of the server and ispconfig,everything seems to be fine with the install and setup.
When i try to connect to htts://www.mysite.her.com:81 i get connection refused?

I checked the ispconfig file and the path is correct,ispconfig is running, and i get 403 error if i try the url without https://

Any idea why id be unable to connect to ispconfig?
thanks
Reply With Quote
Sponsored Links
  #2  
Old 13th December 2005, 10:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You have to use the same URL that's in /home/admispconfig/ispconfig/lib/config.inc.php and that you entered during installation. Of course, the DNS records for this URL have to point to your ISPConfig system.

Can you connect when you use the IP address instead?

Did you disable SuSE's firewall, as suggested in the "Perfect Setup"?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th December 2005, 10:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by kingkunt
I checked the ispconfig file and the path is correct,ispconfig is running, and i get 403 error if i try the url without https://
ISPConfig supports either http or https, never both. Have selected http or https during install?
Reply With Quote
  #4  
Old 14th December 2005, 09:42
kingkunt kingkunt is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok
I did a fresh install of suse9.3 perfect setup and installed ispconfig everything seems to work ok.
When i first tried to connect to the adminCP i got a blank page(IE) when i tried with firefox it showed me the error invalid certificate,so i fixed that by rebuilding my cert and restarting ispconfig.
My path in ispconfig is https://www.my.site.com:81
When i try to connect to it via this url i get a page cannot be displayed error.
When i connect to it via https://my.site.com:81 it prompts me to accept cert and i can login,BUT when im logged in i see broken images and if i try to change some settings it asks if i want to display secure and non secure pages selecting eeither shows a blank page???

i reinstalled because i had this problem last time so at this point im stumped.

Quote:
ISPConfig supports either http or https, never both. Have selected http or https during install?
I selected https:

Quote:
You have to use the same URL that's in /home/admispconfig/ispconfig/lib/config.inc.php and that you entered during installation. Of course, the DNS records for this URL have to point to your ISPConfig system.

Can you connect when you use the IP address instead?

Did you disable SuSE's firewall, as suggested in the "Perfect Setup"?
I cannot connect using the WAN ip but i can connect using the router ip 192.168.x.x
Firewall is off

aaahrghh i want to fix this so i can try the new 2.1.2!!
Reply With Quote
  #5  
Old 14th December 2005, 10:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by kingkunt
My path in ispconfig is https://www.my.site.com:81
When i try to connect to it via this url i get a page cannot be displayed error.
When i connect to it via https://my.site.com:81 it prompts me to accept cert and i can login,BUT when im logged in i see broken images and if i try to change some settings it asks if i want to display secure and non secure pages selecting eeither shows a blank page???
When you try to connect to ISPconfig, you must use the same URL that is in /home/admispconfig/ispconfig/lib/config.inc.php, and you have to make sure the the DNS records for this URL are pointing to your ISPConfig server (unless you have an IP address in the file instead of a FQDN).


Quote:
Originally Posted by kingkunt
I cannot connect using the WAN ip but i can connect using the router ip 192.168.x.x
Firewall is off
You must forward port 81 from your router to your ISPConfig server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 14th December 2005, 17:23
kingkunt kingkunt is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

well it seems my problem was the url in my ispconfig wouldnt let me connect using https://www.my.site.com:81
so i changed the url to https://my.site.com:81 removing the hostname from the url and it now works 100%

it seems the ISPconfig setup idnt like my hostname added to the url.
thanks for your patience.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot access ispconfig site Nu2Linux Installation/Configuration 13 3rd January 2009 15:29
How can I get PHP to work after ISPConfig Install alvadore Installation/Configuration 22 30th March 2008 15:57
ISPConfig Devel Report. till Developers' Forum 3 27th November 2005 15:07
install successful but no ispconfig site Nu2Linux Installation/Configuration 3 3rd November 2005 23:30
ISPConfig system stoped johnking Installation/Configuration 7 27th October 2005 02:37


All times are GMT +2. The time now is 01:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.