Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th November 2005, 08:38
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to check if DNS is functioning

How do I check if my Debian DNS Server is functioning correctly.
__________________
www.ecomp.com.au
Reply With Quote
Sponsored Links
  #2  
Old 30th November 2005, 09:20
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,270
Thanks: 84
Thanked 25 Times in 21 Posts
Default

well I sugest testing the domains that your DNS server is hosting, go here and test your domain. just enter yourdomain.com on the lefthand, press enter and you`re done
Reply With Quote
  #3  
Old 30th November 2005, 12:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by new_bee05
How do I check if my Debian DNS Server is functioning correctly.
You can use dig to test it, e.g.

Code:
dig @localhost example.com
dig@localhost MX example.com
dig @localhost ANY example.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 30th November 2005, 16:14
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK I get this when typing: dig @localhost mydomain.com

SERVFAIL, id:30662

which means?

Also nslookup gives me:
Server: 192.168.1.100
Address: 192.168.1.100#53

is this correct?
__________________
www.ecomp.com.au

Last edited by new_bee05; 30th November 2005 at 16:27.
Reply With Quote
  #5  
Old 30th November 2005, 18:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Your DNS server isn't running. Try to restart it, and have a look at the logs in /var/log to see if any errors occur.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 1st December 2005, 01:39
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have restarted bind 9 same result. how do i open the log files so i can view them.
__________________
www.ecomp.com.au
Reply With Quote
  #7  
Old 1st December 2005, 02:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by new_bee05
I have restarted bind 9 same result. how do i open the log files so i can view them.
Run
Code:
tail -n100 /var/log/syslog
or
Code:
tail -n100 /var/log/messages
This will sshow the last 100 lines of these files.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 1st December 2005, 02:57
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Only error messages I can see are:

myhost named[1872]: zone mydomain.com/IN: loading master file zones/master/master.mydomain.com: not at top of zone

myhost named[1518]: zone 1.168.192.IN-ADDR.ARPA/IN: loading master file zones/192.168.1.rev: unexpected end of input

myhost named[1518]:dns_rdata_fromtext: zones/192.168.1.rev:3: near eol: unexpected end of input
__________________
www.ecomp.com.au
Reply With Quote
  #9  
Old 1st December 2005, 11:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by new_bee05
myhost named[1872]: zone mydomain.com/IN: loading master file zones/master/master.mydomain.com: not at top of zone

myhost named[1518]: zone 1.168.192.IN-ADDR.ARPA/IN: loading master file zones/192.168.1.rev: unexpected end of input

myhost named[1518]:dns_rdata_fromtext: zones/192.168.1.rev:3: near eol: unexpected end of input
That's the reason why Bind doesn't start. Try to have a look into these files and try to fix the problems.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 1st December 2005, 11:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,750
Thanks: 840
Thanked 5,601 Times in 4,412 Posts
 
Default

Quote:
Originally Posted by new_bee05
Only error messages I can see are:

myhost named[1872]: zone mydomain.com/IN: loading master file zones/master/master.mydomain.com: not at top of zone

myhost named[1518]: zone 1.168.192.IN-ADDR.ARPA/IN: loading master file zones/192.168.1.rev: unexpected end of input

myhost named[1518]:dns_rdata_fromtext: zones/192.168.1.rev:3: near eol: unexpected end of input
I guess you are not the owner of the domain mydomain.com and your server is connected to the internet?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quotacheck on Debian Sarge Install m u r Installation/Configuration 6 31st October 2005 09:32
How can I check whether SPF Record is running lexcomputer Installation/Configuration 1 12th October 2005 11:03
Server can't "see" the internet Luciano Installation/Configuration 8 23rd August 2005 00:22


All times are GMT +2. The time now is 17:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.