Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th December 2007, 19:45
blizzardville blizzardville is offline
Junior Member
 
Join Date: Dec 2007
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default You cannot assign HTTPD Includes to this website

I'm attempting ISPconfig + Mongrel setup. I would like to place my proxy stuff into the "Apache Directives (Optional):" box.

It doesn't matter what I put in there though I always get:

You cannot assign HTTPD Includes to this website

This is what I would like to put in there (substituting my own configuration)

ServerName myapp.com
ServerAlias www.myapp.com

ProxyPass / http://www.myapp.com:8000/
ProxyPassReverse / http://www.myapp.com:8000
ProxyPreserveHost on

Even if I cut this down to just:

ServerAlias www.myapp.com

I still get the error. How can I diagnose this problem. I have looked in the apache error log but nothing is there.
Reply With Quote
Sponsored Links
  #2  
Old 6th December 2007, 19:52
blizzardville blizzardville is offline
Junior Member
 
Join Date: Dec 2007
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Woops, just found the answer here:

http://www.howtoforge.com/forums/sho...HTTPD+Includes
Reply With Quote
  #3  
Old 6th December 2007, 20:16
blizzardville blizzardville is offline
Junior Member
 
Join Date: Dec 2007
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default ProxyPass not working in Apache Directives

I look in the vhosts file and my

ServerAlias myserver.com

directive is there but the Proxy???? directives do not show up.

The documentation says they would be commented out if there was syntax error, so something else must be happening because they are not even in there commented out.

This thread says to edit the vhosts file directly for this.

Is that wise? Won't subsequent changes to Vhosts via ISPConfig wipe out any manual edits I put in there?

http://www.howtoforge.com/forums/sho...ight=proxypass
Reply With Quote
  #4  
Old 7th December 2007, 12:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,046
Thanks: 842
Thanked 5,661 Times in 4,468 Posts
Default

Quote:
s that wise? Won't subsequent changes to Vhosts via ISPConfig wipe out any manual edits I put in there?
Thats not a good idea as your changes will be lost. The Vhost_ispconfig.conf file should never be edited manually.

Please check this:

http://www.howtoforge.com/forums/showthread.php?t=13596
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
blizzardville (7th December 2007)
  #5  
Old 7th December 2007, 20:49
blizzardville blizzardville is offline
Junior Member
 
Join Date: Dec 2007
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Ok, that makes sense.

What I need to know is how to do a ProxyPass then.

If I put ProxyPass into Apache Directives it gets filtered out and never makes it to the Vhosts_ispconfig.conf file. I can't edit it directly, how do I get ProxyPass in there?

Do I need to dig through the ispconfig php code and make some custom edits to solve this one?
Reply With Quote
  #6  
Old 7th December 2007, 21:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,046
Thanks: 842
Thanked 5,661 Times in 4,468 Posts
Default

ISPConfig does not filter the code in the apache directives field. So please check your apache config as described in the thread that I posted above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
blizzardville (8th December 2007)
  #7  
Old 8th December 2007, 01:52
blizzardville blizzardville is offline
Junior Member
 
Join Date: Dec 2007
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
 
Thumbs up

Aaahhh now I see.

I was expecting the proxypass directives to be inserted into the config file but be commented out if they were syntax erroring out. I read this somewhere, but it is not so.

So if syntax errors are generated then the Vhosts file is created with the date and time instead.

You are right I tried putting the proxypass directives in again and it worked this time.

The real issue I was having that was causing the proxypass problem was not having both mod_proxy and mod_proxy_http enabled.

It seems like most of the howto guides I was looking at leave out the mod_proxy_http part.

Its working now, and I love this ISPConfig. I'm not an ISP and am probably only going to host a handfull of virtual sites on this host, but it seems to me this ISPConfig tool is going to make managing this webserver a lot easier.

Thanks again!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
You cannot assign MySQL databases to this website. chris.zeman Installation/Configuration 2 13th September 2007 00:47
HTTPD Includes: Where is the check? vaio1 Installation/Configuration 8 4th September 2007 12:16
You cannot assign MySQL databases to this website. vaio1 General 3 15th August 2007 21:11
You cannot assign MySQL databases to this website hans2512 Installation/Configuration 4 25th February 2007 16:23
MaxClients set to appropriate level, but ISPconfig is crashing from it (I think) bpmee Server Operation 6 11th January 2007 20:29


All times are GMT +2. The time now is 18:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.