Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd October 2007, 05:38
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 221
Thanks: 11
Thanked 10 Times in 10 Posts
Default Postfix Authentication - Relay not allowed

I followed the Postfix Virtual MySQL howto, and I'm having problems with sending mail. I get a relay not allowed in the mail log.

Here's my postfix.conf file

Quote:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

append_dot_mydomain = no


smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache


myhostname = mail.brian-schultz.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mail.brian-schultz.com, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
Yes, I do have the authentication turned on in my email client (using the same login info as receiving).

Any ideas? I've looked over nearly 15 pages of a search on the forums, but couldn't find an answer that seemed to fit my problem.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 2nd October 2007, 20:07
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 221
Thanks: 11
Thanked 10 Times in 10 Posts
Default

I followed Falko's advice on another thread and removed the domain from mydestination, now I get this error:

Quote:
Oct 2 13:02:44 mail postfix/smtpd[11443]: connect from unknown[192.168.1.1]
Oct 2 13:02:44 mail postfix/smtpd[11443]: warning: SASL authentication problem: unknown password verifier
Oct 2 13:02:44 mail postfix/smtpd[11443]: warning: unknown[192.168.1.1]: SASL LOGIN authentication failed: no mechanism available
Oct 2 13:02:44 mail postfix/smtpd[11443]: lost connection after AUTH from unknown[192.168.1.1]
Any ideas?

Thanks!
Reply With Quote
  #3  
Old 3rd October 2007, 18:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Which distribution do you use? If it's Debian or Ubuntu, what's in /etc/postfix/sasl/smtpd.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 3rd October 2007, 19:08
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 221
Thanks: 11
Thanked 10 Times in 10 Posts
Default

Thanks for the reply Falko. I'm using Etch

Quote:
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: mail_admin
sql_passwd: xxxxxxxxxx
sql_database: mail
sql_select: select password from users where email = '%u'pwcheck_method: saslauthd
mech_list: plain login
Reply With Quote
  #5  
Old 4th October 2007, 15:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

It should read
Code:
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: mail_admin
sql_passwd: mail_admin_password
sql_database: mail
sql_select: select password from users where email = '%u'
instead.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 4th October 2007, 17:10
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 221
Thanks: 11
Thanked 10 Times in 10 Posts
Default

I changed the file (not sure how I got those other 2 entries in there) and rebooted the machine. It still didn't work. What other files do you want to see the settings in?

Thanks again, Falko!
Reply With Quote
  #7  
Old 4th October 2007, 19:44
giganet giganet is offline
Senior Member
 
Join Date: Aug 2007
Location: California
Posts: 243
Thanks: 116
Thanked 1 Time in 1 Post
Send a message via AIM to giganet
Default

I'm just curious...

Is the 'relay not allowed' in your log coming from your system or possibly your ISP?

I have found many mainstream ISP's don't allow relaying, so if you are trying to use a MSN account to send a piece of email from any email account other than one originating from MSN will not be allowed as that ISP has closed relaying in their email server.



Regards
Reply With Quote
  #8  
Old 4th October 2007, 19:46
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 221
Thanks: 11
Thanked 10 Times in 10 Posts
Default

I've got a local ISP that I pay for a static address (which they only give to people who run their own servers), so that's not the issue.

Thanks, though!
Reply With Quote
  #9  
Old 4th October 2007, 20:13
giganet giganet is offline
Senior Member
 
Join Date: Aug 2007
Location: California
Posts: 243
Thanks: 116
Thanked 1 Time in 1 Post
Send a message via AIM to giganet
Default

If you are using your ISP's mail server as your outgoing SMTP it would cause the no relay issue if your ISP does not allow relaying though.


Not trying to be a pest

Regards
Reply With Quote
  #10  
Old 4th October 2007, 21:10
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 221
Thanks: 11
Thanked 10 Times in 10 Posts
 
Default

I appreciate the help, but I'm not using my ISP for my outgoing server...and they do allow relaying if I were to do that.

Thanks again, though!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix: smtpd --> SASL LOGIN authentication failed tom General 25 2nd February 2010 17:43
Postfix relay domains, transports and virtual maps.... veggieryan Server Operation 3 18th July 2007 19:17
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 20:25


All times are GMT +2. The time now is 04:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.