Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th November 2007, 00:05
SkykerZio SkykerZio is offline
Junior Member
 
Join Date: Oct 2007
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default Finished Perfect setup 10.2 but now...

Everything installed (finally) and I've reached the end of the walkthrough.
Thanks falko!

I installed the optional component ISPConfig, But did not take SuExec yet.

the error im getting on boot is

"Starting httpd2 (pitchfork) (98) Address is already in use: make_sock: could not bind to address [::]:80
(98) address already in use :make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs

startproc:exit status of parent of /usr/sbin/httpd2-prefork: 1"

So this means I need to change my listening IP right?

how do I do that?
Reply With Quote
Sponsored Links
  #2  
Old 4th November 2007, 10:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,469
Thanks: 813
Thanked 5,254 Times in 4,120 Posts
Default

The error means, that there is already a program (possibly a webserver) started on port 80. Please post the output of:

netstat -tap
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th November 2007, 04:03
SkykerZio SkykerZio is offline
Junior Member
 
Join Date: Oct 2007
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

well...theres alot of typing and wlaking back and forth across the room involved in that... are you looking for a specific line?

I noticed 2 different entries that say:

localhost:953 3954/named

ill post the rest of it later

EDIT:

ok I found this command

netstat -lnp | grep ':80'

and got

tcp 0 0 :::80 LISTEN 3678/httpd-prefork

so I also ran

netstat -lnp | grep ':81'

and got

tcp 0 0 0.0.0.0:81 0.0.0.0:* LISTEN 3576/ispconfig_http

Last edited by SkykerZio; 5th November 2007 at 04:20.
Reply With Quote
  #4  
Old 6th November 2007, 21:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Take a look at your Apache configuration (I think it's somewhere in /etc/httpd on SUSE). There must be a Listen line somewhere. How exactly does it look?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th November 2007, 03:55
SkykerZio SkykerZio is offline
Junior Member
 
Join Date: Oct 2007
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

yeah Its in /etc/apache2/

There are two lines that have listen:


listen 80

and listen 443

i dont have a /etc/httpd

UPDATE:

ok i changed the first "listen 80" line to "listen 192.168.1.2:80"

and that solved the error but localhost/127.0.0.1 still doesnt work.
I tried 192.168.1.2 in my browser and I got

"Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403
192.168.1.2
Tue Nov 6 22:55:32 2007
Apache/2.2.3 (Linux/SUSE)"

im looking for where My index.html file should be to see if its there, to eliminate that possible problem.

in looking at my httpd.conf file I noticed:

# forbid access to entire file system by default
<Directory />
Options None
Allowoverride None
Order deny,allow
Deny from all
</Directory>

and Im about to try commenting this out, will update after restart and test

Last edited by SkykerZio; 7th November 2007 at 07:23.
Reply With Quote
  #6  
Old 7th November 2007, 15:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by SkykerZio
ok i changed the first "listen 80" line to "listen 192.168.1.2:80"

and that solved the error but localhost/127.0.0.1 still doesnt work.
Add another Listen line:
Code:
Listen 127.0.0.1:80
and restart Apache.

Quote:
Originally Posted by SkykerZio
"Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403
192.168.1.2
Tue Nov 6 22:55:32 2007
Apache/2.2.3 (Linux/SUSE)"

im looking for where My index.html file should be to see if its there, to eliminate that possible problem.
I think the default document root for SUSE is /srv/www/html or /srv/www/htdocs or just /srv/www, so you must place your index.html there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Issues with Suse 10.2 perfect setup Azimuth Installation/Configuration 4 6th September 2007 12:08
Perfect Setup OpenSuse 10.2 Guide, Problem with starting Apache, Please help! Jerry HOWTO-Related Questions 1 31st July 2007 09:45
The Perfect Setup - OpenSuSE 10.2 wvsailor HOWTO-Related Questions 6 30th January 2007 11:58
Perfect setup and kernel ubgrade for SUSE 10.2 simby Suggest HOWTO 7 21st December 2006 18:41
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 13:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.