Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th October 2007, 07:26
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Question SSH access for clients

How to I allow clients to access the sites they manage via SSH?

I have set up clients and websites in ISPConfig. All looks well there. They can login to ISPConfig and can use FTP. They all show up if I run:
Code:
getent passwd
Is there something additional I need to do in CentOS to give clients access via SSH?
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2007, 07:36
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Did you enable "Shell Access:" for the site?
It's in ISPconfig > site > Basis

You might also like to "chroot" the users.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 13th October 2007, 08:03
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Default

Quote:
Originally Posted by edge
Did you enable "Shell Access:" for the site?
It's in ISPconfig > site > Basis
Yes, I had already done that. Still no SSH access...

Any other ideas?
Attached Images
 
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
  #4  
Old 13th October 2007, 09:14
mlz mlz is offline
Senior Member
 
Join Date: Dec 2006
Posts: 189
Thanks: 16
Thanked 9 Times in 9 Posts
Default

I know this sounds stupid, but you've installed openssh and have it running, right?
Reply With Quote
  #5  
Old 13th October 2007, 09:19
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Default

When I try to access a site via SSH as a client I get this error:

File transfer server could not be started or it exited unexpectedly.
Exit value 1 was returned. Most likely the sftp-server is not in the path of the user on the server side.
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
  #6  
Old 13th October 2007, 12:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

What you are trying to do is to use sftp and not SSH. Try to use a SSH client like putty to connect to your SSH server.

For sftp, have a look at your sshd config file and make sure that sftp is installed and enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 13th October 2007, 16:57
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Default

Quote:
Originally Posted by till
What you are trying to do is to use sftp and not SSH. Try to use a SSH client like putty to connect to your SSH server.

For sftp, have a look at your sshd config file and make sure that sftp is installed and enabled.
I thought SSH and SFTP were the same thing.
http://en.wikipedia.org/wiki/SSH_file_transfer_protocol

Regardless, I've always used SSH Secure Shell 3.2.9 and I assume that uses SSH. I have no problem connecting and transferring files as root but none of my clients can login.

My sshd_config contains the following line:
Subsystem sftp /usr/libexec/openssh/sftp-server

I downloaded and installed Putty but still got exactly the same result. Only root can login.

This server is a test server sitting right next to me. I cannot login to the console using any of the client usernames/passwords that were created in ISPConfig.
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
  #8  
Old 13th October 2007, 17:44
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Exclamation Progress but no solution

I think I'm starting to understand the problem but, I don't know why it is happening.

If I look at the clients in my /etc/passwd file they look like this:
Code:
bill:x:10007:10006:Bill:/var/www/web6:/bin/false
The "/bin/false" is preventing them from being able to login and receive a Bash prompt. I would assume that checking the "Shell Access" box in ISPConfig would change "/bin/false" to "/bin/bash" but it didn't!

Why??
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
  #9  
Old 13th October 2007, 17:56
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 31 Times in 21 Posts
Red face Problem solved

I'm an idiot! Please kick me...

I had shell access turned ON for the SITES but NOT for my clients. Doh...

After looking at the results in the passwd file I went back and looked at each client in ISPConfig. Sure enough, the little boxes that say "Shell Access" were not checked. When I originally setup each site I did not check shell access for any site or users. It was only after I enabled shell access for the sites that I started testing if the users could login.

...I'll go back to my room now.
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote
The Following User Says Thank You to wpwood3 For This Useful Post:
cnavarro (21st October 2007)
  #10  
Old 2nd January 2008, 15:05
alfonso alfonso is offline
Junior Member
 
Join Date: Dec 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Question Not working for me

Quote:
Originally Posted by wpwood3
I had shell access turned ON for the SITES but NOT for my clients. Doh...
Which way did you enable access for clients? I only see the Shell access option on the site tab.

Thank you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Prevent ssh access view of other directories? PermaNoob General 24 23rd February 2008 17:53
SSH Access for Reseller cic General 1 19th September 2007 09:24
directories in /home/admispconfig/ispconfig renamed? Spudchat General 10 12th April 2007 20:37
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 19:26
Update to 2.2.0 question brianetilley Installation/Configuration 10 4th March 2006 18:02


All times are GMT +2. The time now is 05:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.