Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 16th October 2007, 23:07
albertux albertux is offline
Member
 
Join Date: Sep 2006
Location: Chile
Posts: 90
Thanks: 7
Thanked 0 Times in 0 Posts
Send a message via Skype™ to albertux
Default

not no, everything happened the 11, but already I solved it, of the way that I commented previously

Last edited by albertux; 16th October 2007 at 23:09.
Reply With Quote
Sponsored Links
  #22  
Old 16th October 2007, 23:48
teveo1 teveo1 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well.. first crash in interactive mode reports

"Error in named configuration: /home/admispconfig/ispconfig/web/mulc/edit " failed: file not found"

this is where my box started complaining before i did any updates .. ( in a server room with 60 servers i had no chance to analyze or do much but take the box with me )... from there it is all downhill. what could this be?

Correction:
"Error in named configuration: /home/admispconfig/ispconfig/web/multidoc/edit " failed: file not found"

Last edited by teveo1; 17th October 2007 at 00:08.
Reply With Quote
  #23  
Old 17th October 2007, 00:15
teveo1 teveo1 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

.. from syslog..
/etc/named.conf:3 ... change directory to /home/admispconfig/ispconfig/web/multidoc/edit " failed: file not found"

/etc/named.conf:3 .. parsing failed...

??
Reply With Quote
  #24  
Old 17th October 2007, 10:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

The probelm above occurs when ISPConfig has no permissions to read the named files. Please redo the BIND configuration steps from the perfect setup for your linux distribution to ensure that the permissions of the files and directories are correct. Then login to ISPConfig and corect the path to the named conf under management > server > settings
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #25  
Old 5th November 2007, 10:44
marvinh marvinh is offline
Junior Member
 
Join Date: Jul 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

Hello focks,

I have the same error;

[root@localhost /]# /etc/init.d/named start
Starting named:
Error in named configuration:
/etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found
/etc/named.conf:3: parsing failed

Did everything here, nothing worked... some solution?

Here are some settings:

Locate named.conf:
/usr/share/man/man5/named.conf.5.gz
/root/ispconfig/isp/conf/named.conf.master
/etc/named.conf
/etc/named.conf~
/etc/vhcs2/bind/named.conf
/etc/vhcs2/bind/working/named.conf
/etc/log.d/conf/services/named.conf
/var/named/chroot/etc/named.conf

Named.conf ISPconfig: /etc/named.conf
Zonefile dir in ISPconfig: /var/named/chroot/var/named

Did already all the 755 chmod settings...

Please help
Reply With Quote
  #26  
Old 5th November 2007, 11:08
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

Please make sure that the chmod settings of the named directory are as described in the perfect setup. Then set the correct path to your named config directory in ISPConfig under management > server > settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #27  
Old 5th November 2007, 11:14
marvinh marvinh is offline
Junior Member
 
Join Date: Jul 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Please make sure that the chmod settings of the named directory are as described in the perfect setup. Then set the correct path to your named config directory in ISPConfig under management > server > settings.
Already did, but i think there is a strange thing... some Loop...

in my /var/named are the following items:
drwxrwxr-x 6 0 25 4096 Jul 24 18:51 chroot
drwxrwx--- 2 25 25 4096 Jul 24 18:51 data
drwxrwx--- 2 25 25 4096 Jul 24 18:51 slaves

if i enter chroot, then i get this:
drwxr-xr-- 2 0 25 4096 Nov 5 10:14 dev
drwxr-x--- 2 0 25 4096 Nov 5 10:14 etc
dr-xr-xr-x 135 0 0 0 Nov 2 23:22 proc
drwxrwxr-x 5 0 25 4096 Nov 5 10:14 var

Ill go to var and then named, there is the following:
lrwxrwxrwx 1 0 0 6 Nov 5 10:15 chroot -> ../../
drwxrwx--- 2 25 25 4096 Aug 25 2004 data
drwxrwx--- 2 25 25 4096 Jul 27 2004 slaves

If i enter chroot, ill start from the beginning...
drwxr-xr-- 2 0 25 4096 Nov 5 10:14 dev
drwxr-x--- 2 0 25 4096 Nov 5 10:14 etc
dr-xr-xr-x 138 0 0 0 Nov 2 23:22 proc
drwxrwxr-x 5 0 25 4096 Nov 5 10:14 var

IS it possible the Bind9 is in a loop when checking the dirs?
Reply With Quote
  #28  
Old 5th November 2007, 11:33
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

No, this "loop" is normal. the problem is just that ISPConfig aws not able to get read access to the bind config directoyr and thoufh set the path to /home/admispconfig/ispconfig/web/multidoc/edit what is wrong. Please do as I advised above and correct the path in ISPConfig and BIND should be able to start again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #29  
Old 5th November 2007, 11:39
marvinh marvinh is offline
Junior Member
 
Join Date: Jul 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
No, this "loop" is normal. the problem is just that ISPConfig aws not able to get read access to the bind config directoyr and thoufh set the path to /home/admispconfig/ispconfig/web/multidoc/edit what is wrong. Please do as I advised above and correct the path in ISPConfig and BIND should be able to start again.
My path config is "/var/named/chroot/var/named" in ISPconfig.

and still doesn't work...
Reply With Quote
  #30  
Old 5th November 2007, 11:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
 
Default

Is the same path set in /etc/named.conf ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Copy compiled php5 to another machine cooljai Installation/Configuration 4 11th October 2007 16:15
Migration from a virtual machine to physical sonoffett Technical 3 15th September 2007 16:09
How to connect to a Linux machine using VB rocket1356 Programming/Scripts 4 24th June 2007 19:48
connecting to windows machine sudha General 0 29th January 2007 13:38
I cannot resolve www.example.com on the local machine braakiss Installation/Configuration 5 12th January 2007 15:58


All times are GMT +2. The time now is 10:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.