Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th October 2007, 18:20
SlightlyMighty SlightlyMighty is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual domains and SMTP error 553

Hello! I've followed the debian postfix/virtual email hosting tutorial & keep getting these "no good user" SMTP errors whenever I try to send emails to my virtual domains from any non-local hosts.

I'm imagining that this is an rDNS entry issue, but is there a way to solve this without having a unique IP for every domain I want to provide email for?
Reply With Quote
Sponsored Links
  #2  
Old 6th October 2007, 14:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are you sure that the MX records for your domains point to the correct server? You can check with
Code:
dig mx yourdomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th October 2007, 18:46
SlightlyMighty SlightlyMighty is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Let's see... The server's name is robothq.org, all of whose email addresses are working. But I'd like the virtual domains I'm hosting to work as well. Here's the digs:

Quote:
; <<>> DiG 9.2.4 <<>> mx robothq.org
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57122
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3

;; QUESTION SECTION:
;robothq.org. IN MX

;; ANSWER SECTION:
robothq.org. 86400 IN MX 50 64.5.53.148.

;; AUTHORITY SECTION:
robothq.org. 86400 IN NS c.ns.joker.com.
robothq.org. 86400 IN NS a.ns.joker.com.
robothq.org. 86400 IN NS b.ns.joker.com.

;; ADDITIONAL SECTION:
a.ns.joker.com. 69954 IN A 69.39.224.27
b.ns.joker.com. 69954 IN A 159.25.97.69
c.ns.joker.com. 69954 IN A 207.44.185.10

;; Query time: 205 msec
;; SERVER: 138.23.169.10#53(138.23.169.10)
;; WHEN: Sat Oct 6 09:43:18 2007
;; MSG SIZE rcvd: 164
All pretty normal looking, eh?
Reply With Quote
  #4  
Old 7th October 2007, 20:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by SlightlyMighty
;; ANSWER SECTION:
robothq.org. 86400 IN MX 50 64.5.53.148.
An MX record must point to an A record, not to an IP address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP Issue - Virtual Users And Domains ... Ubuntu knight_killer HOWTO-Related Questions 6 4th August 2007 15:03
Virtual users and domains... connection refused when testing w/ localhost Postman HOWTO-Related Questions 1 15th February 2007 10:02
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 03:39
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 22:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.