Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd October 2007, 18:53
Jayock Jayock is offline
Junior Member
 
Join Date: Oct 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Server randomly stops responding

I am running an FC7 server setup using the Perfect server guide, and running ISPConfig. The server randomly stops responding to all requests except for telnet, which always goes through. This happens fairly frequently with dovecot, apache, and SSH. Restarting the services will typically bring them back to life, but not always. They go back down again, and I repeat while I try to figure out the permanent solutions. Nothing in the system logs seems to be showing me any solutions. Any ideas where to start looking from here?

Im wondering if it might be a PAM issue, or PHP scripts on my website (which worked perfectly on a debian server before migrating here).

Thanks,
Justin
Reply With Quote
Sponsored Links
  #2  
Old 3rd October 2007, 20:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Just a shot in the dark: is SELinux enabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th October 2007, 01:19
Jayock Jayock is offline
Junior Member
 
Join Date: Oct 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nope, its off. The ISPConfig firewall is the only firewall too. Ive tried turning that on and off, no difference.

Had a large outage this afternoon. About an hour long, Restarting services, and even the entire server did nothing. Pings OK, but nothing else works, ssh, ftp, http, bind, you name it.

Very perplexing.
Reply With Quote
  #4  
Old 4th October 2007, 01:56
Jayock Jayock is offline
Junior Member
 
Join Date: Oct 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oddly enough ive noticed that while on the local network, ping times go from 1ms to 27-47ms when the server isn't responding, but only on the primary IP. It doesn't ever slow down on the secondary IP (on eth0:1)

munin doesnt show any excessive loads on anything that should be causing this (and the server is 2x Quad core Xeon 8gb ram, Gig-E) So is it possible that a service is causing the eth0 address to respond slowly, but not the eth0:1? Or is it a network issue. The server always gets all services outbound, just never inbound. Ive already replaced the switch, since i had a second lying around, just to narrow it down.

Any ideas with this new Info?
Reply With Quote
  #5  
Old 4th October 2007, 16:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Can you disable the firewall for testing purposes? Does it then happen again?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 4th October 2007, 18:05
Jayock Jayock is offline
Junior Member
 
Join Date: Oct 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ive already tried. It does not seem to be the firewall.
Reply With Quote
  #7  
Old 4th October 2007, 18:38
Jayock Jayock is offline
Junior Member
 
Join Date: Oct 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

More interesting developments. After pinging the eth0:1 address, the eth0 address seems to respond normally. So when it isn't working, I ping the eth0:1 address, and everything comes back to life. Very odd. Any ideas?
Reply With Quote
  #8  
Old 5th October 2007, 14:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

What's in /etc/sysconfig/network-scripts/ifcfg-eth0, /etc/sysconfig/network-scripts/ifcfg-eth0:0, /etc/sysconfig/network-scripts/ifcfg-eth0:1, etc.?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 5th October 2007, 17:37
Jayock Jayock is offline
Junior Member
 
Join Date: Oct 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What's in /etc/sysconfig/network-scripts/ifcfg-eth0, /etc/sysconfig/network-scripts/ifcfg-eth0:0, /etc/sysconfig/network-scripts/ifcfg-eth0:1, etc.?
ifcfg-eth0:
# Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet
DEVICE=eth0
BOOTPROTO=none
BROADCAST=XX.XX.XX.239
HWADDR=00:1c:23:ba:5d:1f
IPADDR=XX.XX.XX.236
NETMASK=255.255.255.248
NETWORK=XX.XX.XX.232
ONBOOT=yes
GATEWAY=XX.XX.XX.233
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

No ifcfg-eth0:0 exists

ifcfg-eth0:1
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
GATEWAY=XX.XX.XX.233
TYPE=Ethernet
DEVICE=eth0:0
BOOTPROTO=none
NETMASK=255.255.255.248
IPADDR=XX.XX.XX.237
USERCTL=no
IPV6INIT=no
PEERDNS=yes
ONPARENT=yes

It was doing the same thing when it was just eth0. I added the eth0:1 to help diagnose. Didn't really end up helping.
Reply With Quote
  #10  
Old 6th October 2007, 15:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

I was thinking that maybe you use HWADDR (used by eth0) again for the erh0:1 configuration, but that's not the case.

Hm... Maybe it's a problem with the network card driver? What's the output of
Code:
lspci
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 23:53
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 02:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.