Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th September 2007, 06:32
spuppy spuppy is offline
Member
 
Join Date: Aug 2007
Posts: 74
Thanks: 5
Thanked 0 Times in 0 Posts
Default Sites are no longer adding

I just tried to add a site, but when I go to the domain, it goes to the "this IP is shared" error.

Furthermore, when I restart Apache, I get the following messages:

Code:
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Stopping httpd:     [  OK  ]
Starting httpd: [Wed Sep 26 21:27:34 2007] [warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts      [  OK  ]
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2007, 08:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Post #3 + #4: http://www.howtoforge.com/forums/sho...ghlight=getcwd

See here:
http://www.howtoforge.com/forums/sho...=date+appended
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th September 2007, 08:17
spuppy spuppy is offline
Member
 
Join Date: Aug 2007
Posts: 74
Thanks: 5
Thanked 0 Times in 0 Posts
Default

OK the site is now showing up. However, how to I prevent this from happening in the future? Is it related to an incorrect Apache Directive? I tried enabling output_buffering on one of the sites, but it gives a syntax error.

I still get this message when I start apache:

Starting httpd: [Wed Sep 26 23:16:27 2007] [warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts
Reply With Quote
  #4  
Old 27th September 2007, 08:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Did you add output buffering in a file or in the apache directives field in ISPConfig?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th September 2007, 09:23
spuppy spuppy is offline
Member
 
Join Date: Aug 2007
Posts: 74
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Did you add output buffering in a file or in the apache directives field in ISPConfig?
First I edited one (or two?) of the php.ini files, and enabled it there. I restarted apache and nothing happened. So then I tried putting it into ISPConfig for that site. Again, nothing happened. It wasn't until now that I found the syntax error (even after restarting apache several times)
Reply With Quote
  #6  
Old 27th September 2007, 09:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

If you change a setting in any apache config file, run:

httpd -t

to test if your manual changes are correct. If you do the changes in ISPConfig, ISPConfig will check for correct syntax before it saves the file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 27th September 2007, 16:46
spuppy spuppy is offline
Member
 
Join Date: Aug 2007
Posts: 74
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Which php.ini is the correct one to edit?
Reply With Quote
  #8  
Old 27th September 2007, 21:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

/etc/php5/apache2/php.ini
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 28th September 2007, 04:57
spuppy spuppy is offline
Member
 
Join Date: Aug 2007
Posts: 74
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
/etc/php5/apache2/php.ini
That file does not exist on my installation.

I have:

/etc/php.ini
/root/ispconfig/php/php.ini

It seems to be working, but for some reason my software wasn't detecting it. I'll have to look elsewhere for help though, since it is unrelated to ISPConfig.

Also, are you sure you don't know what is causing the error:

[warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts

?

Thanks!

Last edited by spuppy; 28th September 2007 at 05:00.
Reply With Quote
  #10  
Old 28th September 2007, 18:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by spuppy
Also, are you sure you don't know what is causing the error:

[warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts

?

Thanks!
It's just a warning that can be ignored. IT means that you have a NameVirtualHost 64.40.112.130:80 directive in your configuration, but no vhost for 64.40.112.130.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php disabled on sites amgat Installation/Configuration 3 30th August 2007 20:14
Strato Server - Restoring with SystemImager popper2001 HOWTO-Related Questions 5 28th July 2007 10:18
Creating image with Systemimager cuongtim HOWTO-Related Questions 3 18th November 2006 13:55
Sites Viewed From Server Go To Shared IP mojosound General 4 3rd April 2006 20:13
Error adding sites mphayesuk General 2 6th November 2005 18:48


All times are GMT +2. The time now is 20:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.