Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 10th December 2005, 17:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by brianetilley
From the file 'config.inc.php'
["server_url"] = "https://www.earthstationproductions.com:81";

When I try to login from another machine with URL 'https://www.earthstationproductions.com:81' I get a not found error.
This seems to be an DNS problem.

Quote:
When I use the IP address I get a connection refused error.
Are there any firewalls / routers between your workstation and server.

Quote:
Using Lynx on the server I get 'SSL error: Can't find common name in certificate -Continue ? (y). When I continue the login page comes up as follows;

[login_logo.png]
Here you can login:
Username:_ _ _ _ _ _ _ _ _ _
Password:_ _ _ _ _ _ _ _ _ _
Login

Using 'admin' for both fields returns returns another SSL error: Can't find common name in certificate - Continue? (y)
refresh URL not absolute
The first error is normal because its a self signed certificate.
The second error means that you have not entered a common name for the SSL cert during ISPConfig installation.
Reply With Quote
Sponsored Links
  #12  
Old 10th December 2005, 17:34
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default

My workstation is running SuSE 9.3 and has the same ISP as the server. There is no firewall/router on either machine. I entered my name in the 'common name' field of the certificate (from the example). I have to leave for 3 hours...

Brian
Reply With Quote
  #13  
Old 10th December 2005, 18:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

This is what I found out:

Quote:
~# dig www.earthstationproductions.com

; <<>> DiG 9.2.1 <<>> www.earthstationproductions.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 52678
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.earthstationproductions.com. IN A

;; Query time: 439 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Sat Dec 10 18:09:12 2005
;; MSG SIZE rcvd: 49
There's no A record for www.earthstationproductions.com! You have to create that first.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 10th December 2005, 20:40
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Could you please give me a link to the documentation that explains how to set up the "A" record. Thanks..

Brian
Reply With Quote
  #15  
Old 10th December 2005, 22:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

There is no documentation especially for A records.

Go to DNS Manager, open the SOA for the domain, go to the records tab and add a new A record. As hostname you enter www and as IP you enter your IP address.
Reply With Quote
  #16  
Old 10th December 2005, 22:57
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default

I can not access the ispconfig interface, so any changes I make must be from the command line. Please tell me what file to edit...and the correct syntax. Thank you...

Brian
Reply With Quote
  #17  
Old 10th December 2005, 23:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Open the config.inc.php file, replace the URL with the IP of your server, then you can access ISPConfig. If you have not accessed ISPConfig yet, your server can not be authoritive for your domain. So you need to create the A record at your domain registry.
Reply With Quote
  #18  
Old 10th December 2005, 23:31
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Do you mean I should change the nameservers of my Domain Registrar to the IP address in the conf.inc.php file (without the port 81). Is this the same IP address used by the DNS server installed with ISPConfig?

Brian
Reply With Quote
  #19  
Old 11th December 2005, 11:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by brianetilley
Do you mean I should change the nameservers of my Domain Registrar to the IP address in the conf.inc.php file (without the port 81). Is this the same IP address used by the DNS server installed with ISPConfig?
No. You should buy managed DNS at your domain registrar for your first domain. Then add an A record (at your domain registrar) that points to the IP of your server. Then you can login to the ISPCOnfig controlpanel.

For all other domains that you buy later you can use the DNS manager in ISPConfig to create and manage the DNS records.
Reply With Quote
  #20  
Old 11th December 2005, 13:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
~# dig any earthstationproductions.com

; <<>> DiG 9.2.1 <<>> any earthstationproductions.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32014
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;earthstationproductions.com. IN ANY

;; ANSWER SECTION:
earthstationproductions.com. 172800 IN NS ns1.dnsexit.com.
earthstationproductions.com. 172800 IN NS ns2.dnsexit.com.

;; AUTHORITY SECTION:
earthstationproductions.com. 172800 IN NS ns2.dnsexit.com.
earthstationproductions.com. 172800 IN NS ns1.dnsexit.com.

;; Query time: 123 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Sun Dec 11 13:25:06 2005
;; MSG SIZE rcvd: 117
The authoritative name servers for earthstationproductions.com are ns2.dnsexit.com and ns1.dnsexit.com. That's where you have to create the DNS records for your domain ("Managed DNS").

Also have a look here: http://www.howtoforge.com/forums/sho...92&postcount=4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL problem on install badben Installation/Configuration 12 20th December 2005 12:59
MySQL installing problem n!x Server Operation 7 24th November 2005 09:44
MySQL connection problem cartdev Installation/Configuration 17 17th November 2005 22:30
SUSE 10.0. x86-64 mysql problem hobit007 Installation/Configuration 2 21st October 2005 16:51
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37


All times are GMT +2. The time now is 00:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.