Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th December 2005, 00:57
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default mysql password problem

So close...But it choked at the mysql password. I entered 'localhost' for server.
'root' for user...and the mysql password I created when installing the base system. Should I have used 'debian-sys-maint' for user? Should I use 'ispconfigdb' for database. Should I enter the static IP address I used during the base install for ISPConfig web? Please explain the proper syntax for this step. Thank you.

Brian
Reply With Quote
Sponsored Links
  #2  
Old 8th December 2005, 01:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by brianetilley
So close...But it choked at the mysql password. I entered 'localhost' for server.
Correct.
Quote:
Originally Posted by brianetilley
'root' for user...
Correct.

Quote:
Originally Posted by brianetilley
and the mysql password I created when installing the base system. Should I have used 'debian-sys-maint' for user?
No, root is correct. Make sure you make no typos when you type in the password.
Quote:
Originally Posted by brianetilley
Should I use 'ispconfigdb' for database.
Any name you like and that doesn't exist as database yet.

Quote:
Originally Posted by brianetilley
Should I enter the static IP address I used during the base install for ISPConfig web?
As host and domain you type in the FQDN you want to use for the ISPConfig web interface (normally your servers hostname). You have to make sure that the FQDN exists in DNS and points to your ISPConfig server, and your firewall must allow pings to the server.
If you don't have a DNS record for your FQDN, you can leave the host empty and enter your system's IP address as domain.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th December 2005, 04:59
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default

I started from the beginning...and got the same results. The password choked. This is the error message:
ERROR:1045: Access denied for user:'root@localhost' (Using password:YES)
ERROR: The provided MySQL password is wrong! The installation routine stops here! Is there a way to reconfigure/edit the MySQL password? Thank you...

Brian
Reply With Quote
  #4  
Old 8th December 2005, 11:43
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,007
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Do you have any special chars in your password? Did you have a look at the debian howtos for ISPConfig? It is described there how you can set the an mySQL password:

http://www.ispconfig.org/documentation.htm

mysqladmin -u root password yourrootsqlpassword
Reply With Quote
  #5  
Old 8th December 2005, 13:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by till
mysqladmin -u root password yourrootsqlpassword
If you have set another MySQL password before, the command to set a new password would be:

Code:
mysqladmin -u root -p<current_password> password <new_password>
(there's no space between -p and <current_password>!)
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 10th December 2005, 02:10
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Changing the password worked. I have tried to find some info about the use of special characters in MySQL passwords with no luck. Do you have a link to the appropriate docs? After a successful install of ispconfig I can not login to the ispconfig interface. Do I need to install a browser on the server to access the interface? Or do I use the IP address I used on the base install for a DNS lookup? Thank you...
Reply With Quote
  #7  
Old 10th December 2005, 13:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,007
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Quote:
Originally Posted by brianetilley
Changing the password worked. I have tried to find some info about the use of special characters in MySQL passwords with no luck. Do you have a link to the appropriate docs? After a successful install of ispconfig I can not login to the ispconfig interface.
Please describe it a bit more detailed. Wich uRL did you use? Is it the URL that you entered during the setup? Did you use username: admin password: admin?

Quote:
Do I need to install a browser on the server to access the interface?
No.

Quote:
Or do I use the IP address I used on the base install for a DNS lookup?
No. Only if the Server domain is not propagated in DNS yet.
Reply With Quote
  #8  
Old 10th December 2005, 16:41
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
Smile

These are the values returned by the system;

hostname:www.earthstationproductions.com
dns domainname:localdomain
hostname --fgdn:localhost.localdomain

I used a staticIP address given to me from my ISP when installing ISPConfig. I tried using Lynx and it logged me in, I entered 'admin' for user, but it would not accept 'admin' for password...the cursor jumps out of the field. Do I need to set the nameservers on my domain registrar's site to point to the static IP...is the static IP the IP of the DNS set up by ISPConfig? I apologize for my ignorance of these issues...the more I research this the more confusing it gets...but I know I am only a few keystrokes away from success. Thanks for the patience.

Brian
Reply With Quote
  #9  
Old 10th December 2005, 17:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

When you try to log in, you have to use the same URL that you typed in during setup and that is now in the file /home/admispconfig/ispconfig/lib/config.inc.php.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 10th December 2005, 18:01
brianetilley brianetilley is offline
Member
 
Join Date: Oct 2005
Posts: 82
Thanks: 4
Thanked 3 Times in 3 Posts
 
Default

From the file 'config.inc.php'
["server_url"] = "https://www.earthstationproductions.com:81";

When I try to login from another machine with URL 'https://www.earthstationproductions.com:81' I get a not found error.
When I use the IP address I get a connection refused error.

Using Lynx on the server I get 'SSL error: Can't find common name in certificate -Continue ? (y). When I continue the login page comes up as follows;

[login_logo.png]
Here you can login:
Username:_ _ _ _ _ _ _ _ _ _
Password:_ _ _ _ _ _ _ _ _ _
Login

Using 'admin' for both fields returns returns another SSL error: Can't find common name in certificate - Continue? (y)
refresh URL not absolute

I hope this helps....

Brian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL problem on install badben Installation/Configuration 12 20th December 2005 13:59
MySQL installing problem n!x Server Operation 7 24th November 2005 10:44
MySQL connection problem cartdev Installation/Configuration 17 17th November 2005 23:30
SUSE 10.0. x86-64 mysql problem hobit007 Installation/Configuration 2 21st October 2005 17:51
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 17:37


All times are GMT +2. The time now is 12:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.