Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th September 2007, 18:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by Spoiler
i have the same problem here ... all sites go to /var/www.

in my case i found the error very quickly ... /etc/apache2/vhosts/Vhost_ispconfig.conf was empty.

i dont know how this can be.

There are some other files starting with "Vhost_ispconfig".
for example: Vhost_ispconfig.c~27-09-07_15-10-29

I think this file is a backup?
No, it's not a backup, it contains a configuration that makes oyur Apache fail to start, in your case because you don't seem to have the PHP module installed. Install/enable it, and everything should work then.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 1st October 2007, 08:54
Spoiler Spoiler is offline
Junior Member
 
Join Date: Mar 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes of course ... php5.conf and php5.load was not linked from mods-available to mods enabled.

just created this links and every thing is ok

Thx
Reply With Quote
  #13  
Old 10th December 2007, 12:25
patfee patfee is offline
Junior Member
 
Join Date: Nov 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

how can i manage this:
Quote:
php5.conf and php5.load was not linked from mods-available to mods enabled
because i have the same problem

thanks
Patrick
Reply With Quote
  #14  
Old 10th December 2007, 13:11
Spoiler Spoiler is offline
Junior Member
 
Join Date: Mar 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

what system?

normaly u have to check if the links exist in /etc/apache2/mods-enabled

just go to the directory and type:
Code:
ls -l php*
My output is:
Quote:
:/etc/apache2/mods-enabled$ ls -l php*
lrwxrwxrwx 1 root root 27 2007-10-22 14:52 php5.conf -> ../mods-available/php5.conf
lrwxrwxrwx 1 root root 27 2007-10-22 14:52 php5.load -> ../mods-available/php5.load
if u have no output for php* u have check for the php-modules:
Code:
cd /etc/apache2/mods-available
ls -l php*
should look like this:
Quote:
:/etc/apache2/mods-available$ ls -l php*
-rw-r--r-- 1 root root 135 2007-10-22 12:03 php5.conf
-rw-r--r-- 1 root root 59 2007-07-02 23:46 php5.load
if there is no output too, you have to install the php-modules (look at howto-forge tutorial).

If the modules are installed, you have to creakte the links.
Code:
ln -s /etc/apache2/mods-available/php5.conf /etc/apache2/mods-enabled/php5.conf
ln -s /etc/apache2/mods-available/php5.load /etc/apache2/mods-enabled/php5.load
Then restart the apache.

Now apache should start with php support.

Hope i could help ....
Reply With Quote
  #15  
Old 22nd December 2007, 14:10
davy davy is offline
Member
 
Join Date: Aug 2007
Posts: 43
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
No, it's not a backup, it contains a configuration that makes oyur Apache fail to start, in your case because you don't seem to have the PHP module installed. Install/enable it, and everything should work then.

How can i Install/enable PHP module (what modules)? I am using CentOS 5.1 64 bits.I got a same problems.

Thanks for help

davy
Reply With Quote
  #16  
Old 23rd December 2007, 16:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Please try this:
Code:
yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc
Then restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
monit howto Jamesk5 HOWTO-Related Questions 11 5th August 2008 15:10
Add Webmin to the system sushestvo Installation/Configuration 44 21st August 2007 16:52
Server Side Includes don't work PermaNoob General 7 1st May 2007 20:38
Apache - Virtual hosts - ISPConfig Hans Server Operation 8 23rd April 2006 16:29
cannot connect to ispconfig guidovanh Installation/Configuration 22 3rd March 2006 19:52


All times are GMT +2. The time now is 09:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.