#1  
Old 13th December 2005, 01:37
webstergd webstergd is offline
Member
 
Join Date: Dec 2005
Location: Washington, DC
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Default problems with ftp server

when loging in with web-ftp I get the following error:
Code:
 Could not connect as user webmaster
If I connect directly to the server using firefox I am able to browse the ftp directory with the user webmaster and proper password. (different computer)

If I connect using SmartFTP v1.5 here is the following error message: (from a different computer)
Code:
    SmartFTP v1.5.990.2
    Resolving host name "www.axiompvp.com"
    Connecting to 24.125.34.87 Port: 21
    Connected to www.axiompvp.com.
220 ProFTPD 1.2.10 Server (ProFTPD server) [192.168.1.55]
    USER webmaster
331 Password required for webmaster.
    PASS (hidden)
230 User webmaster logged in.
    SYST
215 UNIX Type: L8
    FEAT
211-Features:
 MDTM
 REST STREAM
 SIZE
211 End
    PWD
257 "/" is current directory.
    TYPE I
200 Type set to I
    PASV
227 Entering Passive Mode (192,168,1,55,128,34).
    Opening data connection to 192.168.1.55 Port: 32802
    LIST -aL
    Timeout (20s).
    Active Help: http://www.smartftp.com/support/kb/index.php/74
    Client closed the connection.
    Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
If i use gFTP I am able to log in perfectly. (on the server itself)

Any idea's on why web-ftp is not allowing me to connect? I have been working on this for about 2 days currently and any help would be amazing. I need to finish the website in as little time as possible. I also have my senior engineering finals this week so I am a little short on time to figure it out myself.

Thank you so much for your help
webstergd
Reply With Quote
Sponsored Links
  #2  
Old 13th December 2005, 01:39
webstergd webstergd is offline
Member
 
Join Date: Dec 2005
Location: Washington, DC
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Server is set up using Perfect Fedora Core 4. I added programs and codec's in order to listen to music and watch movie and that is about it.
Reply With Quote
  #3  
Old 13th December 2005, 06:13
webstergd webstergd is offline
Member
 
Join Date: Dec 2005
Location: Washington, DC
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Default

/etc/pam.d/ftp:
Code:
#%PAM-1.0
auth    required        pam_unix.so     nullok
account required        pam_unix.so
session required        pam_unix.so
I checked to see if the ftpclients that could connect could also upload and they cannot. it is also extreamly slow.
Reply With Quote
  #4  
Old 13th December 2005, 07:00
webstergd webstergd is offline
Member
 
Join Date: Dec 2005
Location: Washington, DC
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation

after playing with it I have been able to get web-ftp to work. no have idea how. Currently I cannot log into the server with any other ftp clients.

Last edited by webstergd; 13th December 2005 at 08:27.
Reply With Quote
  #5  
Old 13th December 2005, 09:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Have you tried both active and passive mode in your ftp clients?
Might be a firewall problem... Can you post the output of
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 13th December 2005, 11:13
webstergd webstergd is offline
Member
 
Join Date: Dec 2005
Location: Washington, DC
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

thank you for the reply. Ish Liber Dich! <- about the only German I can write. I can only understand spoken.

in my router I set the server to DMZ. I also took down the firewall on my laptop, router, and server. Still same result. Passive and active both will not connect. Error:
Code:
Response:	227 Entering Passive Mode (192,168,1,55,129,155).
Command:	LIST
Error:	Transfer channel can't be opened. Reason: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Error:	Could not retrieve directory listing
Command:	TYPE I
iptables -L:
Code:
Chain FORWARD (policy DROP)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED
DROP       all  --  anywhere             anywhere

Chain INPUT (policy DROP)
target     prot opt source               destination
DROP       tcp  --  anywhere             127.0.0.0/8
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED
ACCEPT     all  --  anywhere             anywhere
DROP       all  --  BASE-ADDRESS.MCAST.NET/4  anywhere
PUB_IN     all  --  anywhere             anywhere
PUB_IN     all  --  anywhere             anywhere
PUB_IN     all  --  anywhere             anywhere
DROP       all  --  anywhere             anywhere

Chain INT_IN (0 references)
target     prot opt source               destination
ACCEPT     icmp --  anywhere             anywhere
DROP       all  --  anywhere             anywhere

Chain INT_OUT (0 references)
target     prot opt source               destination
ACCEPT     icmp --  anywhere             anywhere
ACCEPT     all  --  anywhere             anywhere

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
PUB_OUT    all  --  anywhere             anywhere
PUB_OUT    all  --  anywhere             anywhere
PUB_OUT    all  --  anywhere             anywhere

Chain PAROLE (9 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere

Chain PUB_IN (3 references)
target     prot opt source               destination
ACCEPT     icmp --  anywhere             anywhere            icmp destination-unreachable
ACCEPT     icmp --  anywhere             anywhere            icmp echo-reply
ACCEPT     icmp --  anywhere             anywhere            icmp time-exceeded
ACCEPT     icmp --  anywhere             anywhere            icmp echo-request
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ftp
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ssh
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:smtp
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:domain
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:http
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:81
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:pop3
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:https
PAROLE     tcp  --  anywhere             anywhere            tcp dpt:10000
ACCEPT     udp  --  anywhere             anywhere            udp dpt:domain
DROP       icmp --  anywhere             anywhere
DROP       all  --  anywhere             anywhere

Chain PUB_OUT (3 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
Mail server jas_esp Server Operation 1 7th December 2005 18:17
How to retrive mails from 2nd server dstme Server Operation 3 1st December 2005 18:28
Can't get MX for external mail server to work semmelbroesel Installation/Configuration 4 25th November 2005 17:48
Server can't "see" the internet Luciano Installation/Configuration 8 22nd August 2005 23:22


All times are GMT +2. The time now is 19:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.