Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 7th December 2005, 19:56
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

Quote:
Originally Posted by till
If you use --with-openssl=${INSTALL_ROOT}/openssl it uses the OpenSSL that comes with ISPConfig, but this OpenSSL definetly wont work on 64 bit systems.

Try to use: --with-openssl or --with-openssl=/path/to/openSSL/from/suse
Tried same as the last mod but change with --with-openssl
here is the error msg:
configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP

and now with --with-openssl=/usr/include/openssl
here is the error:
configure: error: Cannot find OpenSSL's <evp.h>
ERROR: Could not configure PHP

and evp.h is in /usr/include/openssl
Reply With Quote
Sponsored Links
  #12  
Old 7th December 2005, 20:01
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

Quote:
Originally Posted by falko
Did you try "Modifications 3" With this configure line?
Code:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
Is evp.h on your system? Run
Code:
updatedb
locate evp.h
to find out.

Tried with Mod3 +
Code:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
here is the error msg:
configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP

and
Code:
updatedb
locate evp.h
return:
/tmp/install_ispconfig # locate evp.h
/usr/include/openssl/evp.h


I really don't understand why it's not working

Thanks for your help!

SeaWolf
Reply With Quote
  #13  
Old 7th December 2005, 20:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,533 Times in 4,351 Posts
Default

And you run the installer as root user, not sudo or something like that?
Reply With Quote
  #14  
Old 7th December 2005, 20:21
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

yep.. I log admin and then switch with SU.. the same way I do on my DualP3 and it's working on it.
Reply With Quote
  #15  
Old 7th December 2005, 20:35
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

Do you want me to let you in as root?? It's a fresh install so nothing is installed right now, except Suse10 and trying to install ISPConfig. I can give you IP and a temp password for root and you can try it? Lemme know if u would like to see it.

Thanks,
SeaWolf
Reply With Quote
  #16  
Old 7th December 2005, 21:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Can you try again with this line?

Code:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=/usr --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 8th December 2005, 00:51
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

Quote:
Originally Posted by falko
Can you try again with this line?

Code:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=/usr --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
With this option, I got this msg:
configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP


I think that ghosts are in my server
Reply With Quote
  #18  
Old 8th December 2005, 23:07
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

Do you have another idea? I've reinstall again Suse 10 with all update that yast ask me in the install, then install openssl-devel and finally when I install ISPConfig, I got this error again

Configuring extensions
checking whether to enable LIBXML support... no
checking libxml2 install dir... no
checking for OpenSSL support... yes
checking for Kerberos support... no
checking for pkg-config... no
configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP


Someone wanna take a look?

SeaWolf
Reply With Quote
  #19  
Old 15th February 2006, 17:54
jneundorf jneundorf is offline
Junior Member
 
Join Date: Feb 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Here's what worked for me

Seawolf,

I installed suse 10 on an x86-64 system and ran into the same problem with evp.h.

In order to fix it I installed the 32bit openssl dev lib using yast (ie installed 32 & 64 bit openssl + dev libs).

When compiling php, i just used --with-openssl (didn't need =/path..).

Hope that helps.
Reply With Quote
  #20  
Old 13th May 2006, 14:44
vktechnology vktechnology is offline
Junior Member
 
Join Date: May 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I have samilar problem

install PHP...relocation R_X86_64_32... recompile with -fPIC...
http://www.howtoforge.com/forums/sho...ht=R_X86_64_32
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.