Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th December 2007, 07:30
emil2k emil2k is offline
Junior Member
 
Join Date: Oct 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation Perl Files Downloading Instead of Running

I have set up a development machine at home and I'm trying to move perl files that I know work from my HostGator account to my home account, but when I placed the files and proceded with the installation and matched the same permissions as on my previous host, for some reason when I try to view the perl file via browser it tries to download it instead of running it.

This is what I have in my httpd.conf and this is a Debian Etch with Apache2

Code:
ScriptAlias /cgi-bin/ /var/www/project/trunk/cgi-bin/
<Directory /var/www/project/trunk/cgi-bin>
        AllowOverride None
        Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
</Directory>
Can somebody tell me what I should do
Reply With Quote
Sponsored Links
  #2  
Old 16th December 2007, 13:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Add this to your vhost configuration and restart Apache:

Code:
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th December 2007, 23:38
emil2k emil2k is offline
Junior Member
 
Join Date: Oct 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Add this to your vhost configuration and restart Apache:

Code:
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
It's still downloading the file instead of running it
Reply With Quote
  #4  
Old 17th December 2007, 17:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you post your vhost configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th December 2007, 19:32
emil2k emil2k is offline
Junior Member
 
Join Date: Oct 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Question

I actually just fixed this, it figures that I just needed some modules installed and the scripts were not running but for some reason whether it is FireFox or the server the 500 error wasn't showing like usual instead it was downloading some empty files, I found the logs in /var/log/apache2/error.log which said which modules needed to be installed.

I installed them through the cpan command and it works now.

But now I'm having trouble (not related to the above) with .htaccess files running mod_rewrite, I enabled the rewrite module with a symlink and changed the AllowOverride to All and reloaded and it still doesn't do the simple check found here:

http://www.webune.com/forums/viewtopic-p-62.html

When I click the second link it simply shows a 404, this is what I put in the httpd.conf for this:

Code:
<Directory /var/www>
        AllowOverride All
</Directory>
Should I start another topic for this?
Reply With Quote
  #6  
Old 18th December 2007, 17:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's in your .htaccess file?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 19th December 2007, 04:00
emil2k emil2k is offline
Junior Member
 
Join Date: Oct 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
What's in your .htaccess file?
.htaccess

Code:
RewriteEngine On
RewriteRule ^link([^/]*)\.html$ rewrite.php?link=$1 [L]
I just did this test here...
http://www.webune.com/forums/viewtopic-p-62.html
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
Runaway Perl aws910 Server Operation 2 19th November 2007 17:24
perl scripts not running teves Installation/Configuration 1 25th June 2007 18:13
Network questions regarding Ubuntu Server lubod Installation/Configuration 7 3rd January 2007 18:53
Pure-FTPd downloading Leedude Server Operation 2 9th May 2006 00:16


All times are GMT +2. The time now is 09:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.