Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th September 2007, 16:23
skara skara is offline
Junior Member
 
Join Date: Apr 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ProFTPD - Strange behaviour - double config?

Hello,

i've installed an Debian Etch on a Strato vServer. Most of installation was done almost similar to the Perfect Debian Etch How-to here on howtoforge.

Playing around with ProFTPD-Settings to get TLS working i pointed out a strange behaviour of the ftpserver.

To take a long story short, local connection to the ftpserver seems to be a different configuration then remote access.
I had changed the ServerIdent at /etc/proftpd.conf (ServerIdent on "FTP Server ready."). Login in local brings this message. Remote login brings up '220 ProFTPD 1.3.0 Server (Debian) [xx.xxx.xxx.IP]'

netstat -tap gives:
Code:
tcp        0      0 h123456.serverkomp:953 *:*                     LISTEN     27879/named         
tcp        0      0 *:smtp                  *:*                     LISTEN     27844/master        
tcp        0      0 *:https                 *:*                     LISTEN     27757/apache2       
tcp        0      0 *:44060                 *:*                     LISTEN     26536/rpc.statd     
tcp        0      0 *:imaps                 *:*                     LISTEN     26355/couriertcpd   
tcp        0      0 *:pop3s                 *:*                     LISTEN     26381/couriertcpd   
tcp        0      0 h123456.serverko:mysql *:*                     LISTEN     26268/mysqld        
tcp        0      0 *:pop3                  *:*                     LISTEN     26360/couriertcpd   
tcp        0      0 *:imap2                 *:*                     LISTEN     26337/couriertcpd   
tcp        0      0 *:sunrpc                *:*                     LISTEN     26041/portmap       
tcp        0      0 *:www                   *:*                     LISTEN     27757/apache2       
tcp        0      0 *:81                    *:*                     LISTEN     27727/ispconfig_htt 
tcp        0      0 *:auth                  *:*                     LISTEN     26392/inetd         
tcp        0      0 *:ftp                   *:*                     LISTEN     27900/proftpd: (acc 
tcp        0      0 DOMAIN.de:domain       *:*                     LISTEN     27879/named         
tcp        0      0 h123456.serverk:domain *:*                     LISTEN     27879/named         
tcp        0      0 *:ssh                   *:*                     LISTEN     26499/sshd          
tcp        0   1984 DOMAIN.de:ssh          xxxxxxxx-:62432 VERBUNDEN  27723/sshd: user
ps aux brings only one proftpd. Nothing, what seems to me for another hit than maybe inetd.
But i checked /etc/inetd.conf - but everything's commented out but of ident.

I can bring further info if it's needed, but actually haven't got a glue, where else to look at ...

Anybody an idea how to check this?
Thanks in advance.

greetz
skara
Reply With Quote
Sponsored Links
  #2  
Old 18th September 2007, 18:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Did you restart Proftpd?

Are you sure you're connecting to the right IP/hostname?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th September 2007, 21:40
skara skara is offline
Junior Member
 
Join Date: Apr 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

yes, it's the same server.

in any of your howtos regarding debian setup you mentioned a /etc/hosts-file like
Code:
127.0.0.1 localhost localhost.localdomain
123.456.789.12 example.net
trying 'telnet localhost 21' and 'telnet example.net 21' directly on the machine was the same - different banners.

it's not a problem at all - will use vsftpd. but being new to linux-setup i'm willing to learn. but i couldn't figure out, where's the problem so i asked here.

if i can provide any further information, i will do so.

greetz
skara
Reply With Quote
  #4  
Old 19th September 2007, 12:06
skara skara is offline
Junior Member
 
Join Date: Apr 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

One more try... complete serverreinstall from the scratch. Strato vServer - Debian 3.1 install -> RecoveryMode -> Debootstrap (v1.0.3) to Etch
Will post only things i suppose to be important [...config...] = configuration according Perfect Etch Setup:

Code:
aptitude install ssh fail2ban sudo
# above in recoverymode + chroot
# REBOOT to normal mode
aptitude -q --without-recommends -y install ~pstandard ~prequired ~pimportant
aptitude -y install binutils cpp fetchmail flex gcc libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev g++ quota screen ucf

cat > /etc/hosts <<EOF
127.0.0.1       localhost localhost.localdomain
85.214.x.x   h123456.serverkompetenz.net example.net h123456
EOF

aptitude install bind9 && /etc/init.d/bind9 stop [...config..]

aptitude -y install mysql-server mysql-client libmysqlclient15-dev [...config..]
aptitude install postfix libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail && dpkg-reconfigure postfix[...config..]

aptitude install courier-authdaemon courier-base courier-imap courier-imap-ssl courier-pop courier-pop-ssl courier-ssl gamin libgamin0 libglib2.0-0 [...config..]

aptitude install apache2 apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert [...config..]

aptitude install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl [...config..]

cp /etc/proftpd/proftpd.conf /etc/proftpd/proftpd.conf.orig
pico /etc/proftpd/proftpd.conf
## UseIPv6  'on' to 'off'
cat >> /etc/proftpd/proftpd.conf <<EOF
DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."
EOF
ln -s /etc/proftpd/proftpd.conf /etc/proftpd.conf

aptitude install webalizer ntp ntpdate libhtml-parser-perl libdb-file-lock-perl libnet-dns-perl 

[ISPC-Install as descriped - standard-mode]
ISPC seems to be installed ok.
telnet localhost 21 and telnet example.net 21 give same banner 'FTP Server Ready'

But restarting via ISPC brings above mentioned error - localhost='FTP Server ready' example.net='ProFTPD 1.3.0 Server (Debian) [85.214.xx.xx]'

Manual deleting 'DefaultAddress 127.0.0.1' in /etc/proftpd_ispconfig.conf and /etc/init.d/proftpd restarting brings:
Code:
Starting ftp server: proftpd - warning: "ProFTPD" address/port (85.214.xxx.xxx:21) already in use by "Debian"
But actually it brought identical banners - 'til ftp-restart via ISPC. That inserted DefaultAddress again.
Slowly it drives me mad - but at least, my ftpserver now works.

Deleting 'Include /etc/proftpd_ispconfig.conf' in /etc/proftpd.conf seems to work fine - restart via ispc and init.d worked. Why this include, if it doesn't work with but without?

greetz
skara

PS: did i mention? great work - your howtos and nevertheless ispconfig
Reply With Quote
  #5  
Old 19th September 2007, 15:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
 
Default

Quote:
Originally Posted by skara
Why this include
It's needed if you want to have anonymous FTP for a web site. But if you like, you can put a modified template of the proftpd_ispconfig.conf file in the /root/ispconfig/isp/conf/customized_templates folder (the original template is in /root/ispconfig/isp/conf). ISPConfig will then use the modified template.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Anyone figured out to integrate FuzzyOCR into ISPConfig on Ubuntu? friday Installation/Configuration 16 10th May 2007 16:25
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48
Im thinking about throwing proftpd to the trashcan danf.1979 Installation/Configuration 2 23rd December 2005 09:27


All times are GMT +2. The time now is 00:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.