#1  
Old 16th September 2007, 18:47
Tripple2 Tripple2 is offline
Member
 
Join Date: Aug 2007
Posts: 60
Thanks: 4
Thanked 1 Time in 1 Post
Default spamfilter doesn't work

Hello,

I get the feeling that the spamfilter on my ISPConfig box doesn't do anything.

I followed the Mandriva 2007 perfect setup.
On one domain, I put myself on the black list so the subject should be rewritten. However, nothing happens.

Any ideas?

------------------------------------------------------
Other faillures on that box without sollution yet:
- Autorespond doesn't work
- /etc/init.d/httpd graceful causes errors


Maybe it's time to say Mandriva goodbye
Reply With Quote
Sponsored Links
  #2  
Old 16th September 2007, 20:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

To debug the spam filtering process, you should start to look at the .procmailrc file in the home directory of the user and the files that are included there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th September 2007, 00:07
Tripple2 Tripple2 is offline
Member
 
Join Date: Aug 2007
Posts: 60
Thanks: 4
Thanked 1 Time in 1 Post
Default

Thanks for your reply.
There is no .procmailrc file.
When I run ISPConfig Webhosting Appliance, which is Debian 3.1, the user directory looks quite different. This is my users directory:

web13 1024 sep 16 21:04 ./
drwxr-xr-x 4 vs20113_user web13 1024 aug 30 16:40 ../
-rw-r--r-- 1 root root 103 sep 16 17:47 .antivirus.rc
-rw-r--r-- 1 root root 802 sep 16 17:47 .autoresponder.rc
-rw-r--r-- 1 root root 67866 sep 16 17:47 .html-trap.rc
-rw-r--r-- 1 root root 3889 sep 16 17:47 .local-rules.rc
-rw-r--r-- 1 root root 204 sep 16 17:47 .mailsize.rc
-rw-r--r-- 1 root root 656 sep 16 17:47 .quota.rc
drwx------ 2 vs20113_user web13 1024 aug 30 16:40 .spamassassin/
-rw-r--r-- 1 root root 1153 sep 16 17:47 .spamassassin.rc
-rw-r--r-- 1 root root 2036 sep 16 17:47 .user_prefs
-rw-r--r-- 1 root root 32 sep 16 17:47 .vacation.msg
drwxrwxr-x 2 vs20113_user web13 1024 aug 30 16:40 web/

This is the Debian directory:
web2_user web2 4096 Sep 15 22:33 .
drwxr-xr-x 3 www-data web2 4096 Sep 15 22:33 ..
-rw-r--r-- 1 root root 103 Sep 15 22:34 .antivirus.rc
-rw-r--r-- 1 root root 755 Sep 15 22:34 .autoresponder.rc
-rw-r--r-- 1 root root 22 Sep 15 22:34 .bounce-exceed-quota.txt
-rw------- 1 web2_user web2 24 Sep 15 22:34 .forward
-rw-r--r-- 1 root root 67866 Sep 15 22:34 .html-trap.rc
-rw-r--r-- 1 root root 3889 Sep 15 22:34 .local-rules.rc
-rw-r--r-- 1 root root 180 Sep 15 22:34 .mailsize.rc
-rw-r--r-- 1 root root 472 Sep 15 22:34 .procmailrc
-rw-r--r-- 1 root root 2667 Sep 15 22:34 .quota.rc
-rw-r--r-- 1 root root 1149 Sep 15 22:34 .spamassassin.rc
-rw-r--r-- 1 root root 1642 Sep 15 22:34 .user_prefs
-rw-r--r-- 1 root root 0 Sep 15 22:34 .vacation.msg
drwx------ 5 web2_user web2 4096 Sep 15 22:33 Maildir
drwxr-xr-x 2 root root 4096 Sep 15 22:33 bin
drwxr-xr-x 2 root root 4096 Sep 15 22:33 etc
drwxr-xr-x 3 root root 4096 Sep 15 22:33 lib
drwxr-xr-x 4 root root 4096 Sep 15 22:33 usr
drwxrwxr-x 2 web2_user web2 4096 Sep 15 22:33 web
Reply With Quote
  #4  
Old 17th September 2007, 00:21
Tripple2 Tripple2 is offline
Member
 
Join Date: Aug 2007
Posts: 60
Thanks: 4
Thanked 1 Time in 1 Post
Default

edit:

After removing myself and add a new account there is a .procmailrc file.
But the subject Rewrite still doesn't work.
Reply With Quote
  #5  
Old 17th September 2007, 11:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Please post the spamassassin headers from a email where the subject does not got rewritten.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 17th September 2007, 17:41
Tripple2 Tripple2 is offline
Member
 
Join Date: Aug 2007
Posts: 60
Thanks: 4
Thanked 1 Time in 1 Post
Default

This mail should be spam:

From xxx@xxx Mon Sep 17 16:33:34 2007
Return-Path: <xxx@xxx>
X-Original-To: spamtest@xxx
Delivered-To: vs20113_xxx@xxx
Received: from mailserver.xxx (xxx [xxx.xxx.xxx.xxx])
by xxx (Postfix) with ESMTP id 35F59429487
for <spamtest@xxx>; Mon, 17 Sep 2007 16:33:34 +0200 (CEST)
Received: from [192.168.1.100] (unknown [192.168.1.100])
by mailserver.xxx (Postfix) with ESMTP id A9BFC1798E2
for <spamtest@xxx>; Mon, 17 Sep 2007 16:28:39 +0200 (CEST)
Mime-Version: 1.0 (Apple Message framework v752.2)
Content-Transfer-Encoding: 7bit
Message-Id: <AEFC0095-C799-4CA3-A2C0-17E3FC2FCDC8@xxx>
Content-Type: text/plain; charset=US-ASCII; format=flowed
To: spamtest@xxx
From: xxx@xxx
Subject: SPAM Test
Date: Mon, 17 Sep 2007 16:34:57 +0200
X-Mailer: Apple Mail (2.752.2)
X-Virus-Status: Failed
X-Virus-Report: Internal error mktemp MSGTMP failed
X-Virus-Checker-Version:
Status: O
X-Status:
X-Keywords:
X-UID: 13
Reply With Quote
  #7  
Old 17th September 2007, 19:58
Tripple2 Tripple2 is offline
Member
 
Join Date: Aug 2007
Posts: 60
Thanks: 4
Thanked 1 Time in 1 Post
Default

I've been reading this:
http://lists.jameslick.com/pipermail...il/000030.html

TMPPATH is set to /root/tmp

#ls -la /root | grep tmp
drwx------ 2 root root 2048 sep 17 01:05 tmp/

Only root can write to it.

When I look at my ISPConfig appliance:
TMPPATH is set to /tmp
# ls -l / | grep tmp
drwxrwxrwt 4 root root 4096 Sep 17 18:55 tmp

My installation needs to write to /root/tmp I guess.
But why is there a difference?
Reply With Quote
  #8  
Old 20th September 2007, 01:26
Tripple2 Tripple2 is offline
Member
 
Join Date: Aug 2007
Posts: 60
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

I gave up. The Mandriva perfect setup doesn't seemed to be that perfect after all.

Now I'm tuning ISPconfig Appliance with Debian. So far all works fine. Spam, autorespond, ....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 17:05
ERROR: The PHP binary coming with ISPConfig does not work properly on your system W1SKCC Installation/Configuration 2 2nd February 2007 14:55
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 13:12
Cant get any messenger program to work SimplyMepis 6.0 gtoman Technical 1 13th November 2006 16:26
Ver nice work, but ftp didnt work deb1an Installation/Configuration 3 24th July 2006 12:05


All times are GMT +2. The time now is 14:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.