Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th September 2007, 18:08
Jazzperson Jazzperson is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Default Request entity too large

Hi!

I have installed the Perfect Setup - Debian Sarge, everything works perfectly - but when i try to upload large files, i get an error: "Request entity too large".

How do i solve this problem?

Thanks //Jazzperson
Reply With Quote
Sponsored Links
  #2  
Old 16th September 2007, 20:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

How do you upload the files? Large files should be always uploaded with FTP or sftp.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th September 2007, 20:49
Jazzperson Jazzperson is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I know - but i can't even install new templates or components in Joomla! CMS.. It's a major problem..
Reply With Quote
  #4  
Old 16th September 2007, 20:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Ok, you mean you can connect with FTP with the user which is the administrator of the website but you can not upload any files inside the "web" folder?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th September 2007, 20:59
Jazzperson Jazzperson is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Apparently it has something to do with "LimitRequestBody" in php.conf.. But where is php.conf located?
Reply With Quote
  #6  
Old 16th September 2007, 21:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

If you upload with FTP, it has nothing to do with a PHP setting. Please try to answer my questions above, otherwise I can not help you if you dont tell me how you upload the files.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 16th September 2007, 21:06
Jazzperson Jazzperson is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Default

No - it has nothing to do with FTP - The component and template installer in Joomla!CMS is based on php upload..

Request Entity Too Large
The requested resource
/inetservers/administrator/index2.php
does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at www.xxxx.eu Port 80

Last edited by Jazzperson; 16th September 2007 at 21:09.
Reply With Quote
  #8  
Old 16th September 2007, 21:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Ok, but then you should tell us in the first post that you have a problem with joomla and not with file uplodas in general or ISPConfig.

Please have a look at the php.ini file (/etc/php5/apache/php.ini or a similar path) andset the limits for post requests and file uploads to a higher limit and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 16th September 2007, 21:12
Jazzperson Jazzperson is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Oh - of cause.. My fault.. I'll try it..
Reply With Quote
  #10  
Old 16th September 2007, 21:20
Jazzperson Jazzperson is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

post_max_size = 8M

upload_max_filesize = 2M

File size = 812 kb

No change..

One with the same problem: http://forum.mamboserver.com/showthread.php?t=19892 - I need to change "LimitRequestBody", but i don't know where..

Last edited by Jazzperson; 16th September 2007 at 21:23.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38
Web-FTP Directory Protection jmroth General 6 27th March 2007 00:34
Problem generating SSL Request vogelor General 5 7th January 2007 20:08
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 21:02
SSL Request empty when create new SSL in ISPConfig steowimmy Installation/Configuration 10 13th July 2006 21:29


All times are GMT +2. The time now is 00:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.