Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th December 2005, 13:26
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default /usr/bin/ld gets error when compiling apache

Hi there,

during installation of ISPConfig I get the following errormessages:

Code:
gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208123 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` modules.c
gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208123 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` buildmark.c
gcc  -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208123 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` -L/root/ispconfig/openssl/lib  -rdynamic \
      -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a  -lm -lcrypt  -lssl -lcrypto -ldl
/usr/bin/ld: skipping incompatible /root/ispconfig/openssl/lib/libssl.a when searching for -lssl
/usr/bin/ld: skipping incompatible /root/ispconfig/openssl/lib/libcrypto.a when searching for -lcrypto
modules/ssl/libssl.a(ssl_engine_kernel.o)(.text+0x178e): In function `ssl_hook_Access':
: undefined reference to `X509_STORE_CTX_set_depth'
collect2: ld returned 1 exit status
make[2]: *** [target_static] Error 1
make[2]: Leaving directory `/var/www/entpackt/install_ispconfig/compile_aps/apache_1.3.33/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/var/www/entpackt/install_ispconfig/compile_aps/apache_1.3.33'
make: *** [build] Error 2
ERROR: Could not make Apache
We are using an AMD64 from Strato.de with debian.
with google and in this forum there was nothing that helped us. do you know something?
Reply With Quote
Sponsored Links
  #2  
Old 6th December 2005, 14:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=286
http://www.howtoforge.com/forums/sho...p?t=127&page=2

Did you follow any of the "Perfect Setup" tutorials to configure your system? Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th December 2005, 14:46
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no, we didn't follow these howto's because of the raid-system we implemented during install.

we're using Debian 3.1

regarding those two links: they are about php ... but our error occured during compilation of apache1.3
Reply With Quote
  #4  
Old 6th December 2005, 15:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Your error is during the apache compilation, but the reason is the same in the posts that falko posted. The SSL library that comes with ISPCOnfig is not for 64BIT systems.

Open the compile script and try to change the line:

./configure --with-apache=../${APACHE} --with-ssl=${INSTALL_ROOT}/openssl --prefix=${INSTALL_ROOT}/httpd --enable-module=so || error "Could not configure Apache"

To:

./configure --with-apache=../${APACHE} --with-ssl --prefix=${INSTALL_ROOT}/httpd --enable-module=so || error "Could not configure Apache"
Reply With Quote
  #5  
Old 6th December 2005, 15:43
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, changed this line in "setup" ... giving us another error:

Code:
Configuring mod_ssl/2.8.24 for Apache/1.3.33
+ Apache location: ../apache_1.3.33 (Version 1.3.33)
+ Auxiliary patch tool: ./etc/patch/patch (local)
+ Applying packages to Apache source tree:
o Extended API (EAPI)
o Distribution Documents
o SSL Module Source
o SSL Support
o SSL Configuration Additions
o SSL Module Documentation
o Addons

Done: source extension and patches successfully applied.

Now proceed with the following commands (Bourne-Shell syntax):
$ cd ../apache_1.3.33
$ SSL_BASE=/path/to/openssl ./configure ... --enable-module=ssl
$ make
$ make certificate
$ make install
make: *** No targets specified and no makefile found.  Stop.
ERROR: Could not make Apache
but: this error occures earlier than the first one
Reply With Quote
  #6  
Old 6th December 2005, 15:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Do you have openssl and the openssl dev packages installed on your server?

If you the openssl dev already installed, you may need to specify the path to the openssl sources if apache wont find it itself (--with-ssl=/......).
Reply With Quote
  #7  
Old 6th December 2005, 16:20
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

hey,

I tried this one too (--with-ssl=/usr/local/openssl) and now the setup -script runs straight to the first error:

Code:
<=== src/modules/ssl
<=== src/modules
gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208123 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` modules.c
gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208123 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` buildmark.c
gcc  -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208123 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` -L/usr/local/ssl/lib  -rdynamic \
      -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a  -lm -lcrypt  -lssl -lcrypto -ldl
      /usr/bin/ld: skipping incompatible /usr/local/ssl/lib/libssl.a when searching for -lssl
      /usr/bin/ld: skipping incompatible /usr/local/ssl/lib/libcrypto.a when searching for -lcrypto
      modules/ssl/libssl.a(ssl_engine_kernel.o)(.text+0x178e): In function `ssl_hook_Access':
      : undefined reference to `X509_STORE_CTX_set_depth'
      collect2: ld returned 1 exit status
      make[2]: *** [target_static] Error 1
      make[2]: Leaving directory `/root/install_ispconfig/compile_aps/apache_1.3.33/src'
      make[1]: *** [build-std] Error 2
      make[1]: Leaving directory `/root/install_ispconfig/compile_aps/apache_1.3.33'
      make: *** [build] Error 2
      ERROR: Could not make Apache
Reply With Quote
  #8  
Old 6th December 2005, 16:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I googled a bit:
http://mail-archives.apache.org/mod_....apache.org%3e
http://mail-archives.apache.org/mod_....apache.org%3e
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 6th December 2005, 16:59
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

ok, solved this problem:

it seems that the stable version of openssl (< 0.9.8) is not able to work with 64bit-systems properly.
so I fetched the packages

libc6_2.3.5-8_i386.deb
libssl0.9.8_0.9.8a-3_i386.deb
libssl-dev_0.9.8a-3_i386.deb
openssl_0.9.8a-3_i386.deb

from the testing-tree and installed them by hand (and in this order) after that the installation process ran through the apache and ssl compilation.

I would like to thank you very much for your help!

Last edited by ZyanKLee; 6th December 2005 at 17:01.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 14:01
Apache instal woes acilis2k Installation/Configuration 14 17th November 2005 12:42
Apache 1.3 Support SleeperZ General 3 9th November 2005 11:10
Moving Apache to another port DrAgOOn Installation/Configuration 2 16th September 2005 11:14
Apache + PHP lola Server Operation 1 25th April 2005 13:41


All times are GMT +2. The time now is 06:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.