Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 19th September 2007, 20:00
showe1966 showe1966 is offline
Member
 
Join Date: Jan 2007
Location: naples italy
Posts: 46
Thanks: 4
Thanked 2 Times in 2 Posts
Default another update

Phew doing dns setup via robots etc seems much more tricky than just doing everything yourself manually....

Well in any case my isp has some sort of dns registration robot that has generated some sort of primary zone file that I guess points to my IP.
I am not too clear on what domain name should appear in the line about "start of authority" in this file and how on earth it is ever going to know what I called my domain name anyway, but I will just press on regardless and check that file you mentioned catdude to see if mail will work...and i will do a dns report too
Reply With Quote
Sponsored Links
  #22  
Old 19th September 2007, 23:20
showe1966 showe1966 is offline
Member
 
Join Date: Jan 2007
Location: naples italy
Posts: 46
Thanks: 4
Thanked 2 Times in 2 Posts
 
Default I finally made it......

OK Guys I finally made it.
<RANT>
Can I just mention that I know everyone is always too busy to write any manuals, but the documentation you provide is very, very skimpy. Why write an app. if nobody will ever work out how to use it by themselves? Erm for money perhaps ?
<END RANT>

Soooo...

I had discovered that my ISP wouldn't let me host a .com domain for political reasons, so I had to remove my DNS setup as i was no longer running a nameserver locally.
I did this by :-
-login as admin
-dns manager

Then i just deleted all my dns settings in the dns tab !!

Okay so now all I had to do was work out how to set up my mail client to send and receive mail with the new mail server.
This is a 5 minute job if you have access to a decent manual, which (unfortunately) i didn't.
Anyway, here are the settings you need for the Ximian Evolution e-mail client which I've heard is pretty much the same as outlook (for you poor loosers still using windows):-
-supposing you create a mail account as follows:-
>ISP Manager
>click on mydomain.com in the directory tree
>click on "user and e-mail" tab
>click on "new"
enter real name
enter e-mail address
enter user name "example_username"
enter password.

Now, after you have saved this info you can set up your e-mail client with this same info.

RECEIVING MAIL SETTINGS
server: mail.mydomain.dom
username: example_username
security: use secure connection
SSL encryption
authenticatgion type: password

and , quite clearly, the password you entered above ( and hopefully got it right when you entered it just the once) is the same as the one you use when getting your mail.

SENTING MAIL SETTINGS
server: smtp.mydomain.dom
username: example_username
security: use secure connection
TLS encryption
authentication type: plain

and , quite clearly, the password you entered above ( and hopefully got it right when you entered it just the once) is the same as the one you use when sending your mail.

But wait, before we all walk away hand in hand with the sun setting slowly in the west, there are a couple of GOTCHAS as follows:-

1.You have to send a mail to yourself at your new mail address from somewheres else before you can send any mail from the new mailbox, because that apparently creates the mail directory for that mailbox.

2. Well then I could send mail okay, but when I tried to receive mail I was getting this error message in the /var/log/mail.log file :- "courierpop3login: chdir Maildir: No such file or directory".
You can fix this by changing a setting in ISPConfig.
Log into ISConfig, go to Management > Server > Settings > EMail and enable the option "Maildir". This will fix this error.
(Thanks a lot to this person for the above post at the bottom of the following page as i was going crazy by that point:-
http://www.howtoforge.com/perfect_setup_ubuntu704_p5
Submitted by Renko (Contact Author) (Forums) on Wed, 2007-09-05 18:19.).

BTW here is a copy of the primary zone file my ISP is using. Warning: Apparently the spf record is not right or so it says on dnsreport.com. :-

$TTL 1d
@ IN SOA ns1.first-ns.de. postmaster.robot.first-ns.de. (
2000091906 ; Serial
14400 ; Refresh
1800 ; Retry
604800 ; Expire
86400 ) ; Minimum

@ IN NS ns1.first-ns.de.
@ IN NS robotns2.second-ns.de.
@ IN NS robotns3.second-ns.com.

localhost IN A 127.0.0.1
@ IN A 88.198.xx.yy
www IN A 88.198.xx.yy
server1 IN A 88.198.xx.yy

loopback IN CNAME localhost
pop IN CNAME server1
smtp IN CNAME server1
relay IN CNAME server1
imap IN CNAME server1
ftp IN CNAME www
mail IN CNAME server1

@ IN MX 10 server1

mydomain.dom. IN TXT "v=spf1 a mx:server1.mydomain.dom ~all"

PS sorry if this sounds a bit hysterical, but it's been a long day.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
View Website Internally (How To) Broady General 4 8th June 2007 10:22
Apache not reading conf? /var/www directory displayed when visiting any ISPC website toodles Installation/Configuration 2 15th February 2007 23:06
Website Quota ? zephirus79 Installation/Configuration 1 29th November 2006 10:57
Mysql assignation to a new website jeanjacquesjeanjacques Installation/Configuration 4 30th January 2006 17:53
debianhelp new website - www.debianhelp.co.uk gg234 Installation/Configuration 0 5th November 2005 18:18


All times are GMT +2. The time now is 09:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.