#1  
Old 14th September 2007, 02:47
selfxp selfxp is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default Sending/Receiving mail issue

Hello! I've searched the internet for the last 2 days untill I finally decided to post a thread and hope for help.

I have three problems:
1. I can't access the url: http://www.domain.tld:81/webmail/
error: The requested URL /webmail was not found on this server.

3. I can't send or receive an email using a pop3 application (Outlook).
error: The connection to the server has failed. Account:'mail.selfxp.com', Server:'mail.selfxp.com' Protocol SMTP, Port. 25, Sercure(SSL); No, Sochet Error: 10060
There was a problem loggin onto your mail server. Your Password was rejected. Account: 'mail.selfxp.com' Servce:'mail.selfxp.com' Protocol: POP3, Server Response: 'ERR authorization failed' Port:110, Secure(SSL); No, Server Error:0x800CCC90

2. I can't access the url: http://www.domain.tld/stats/
error: 404 Error - File not found!

Facts:
- I don't use https.
- I'm behind a router but I have the ports 81, 25, 110 opened to the SuSE 10.2 machine.
- SMTP, POP3 Servers are Online
- Postfix is running and Maildir is checked.

Thanks in advance!
Cosmin
Reply With Quote
Sponsored Links
  #2  
Old 14th September 2007, 15:01
chuckl chuckl is offline
Senior Member
 
Join Date: May 2007
Location: Uxbridge, Middlesex, UK
Posts: 166
Thanks: 1
Thanked 20 Times in 20 Posts
Default

1. What is www.domain.tld? A website on the server, or the IspConfig install? Try http://domain.tld:81 or http://ip.addr.of.srv:81, or http://ip.addr.of.srv:81/webmail

2. Enable authentication in Outlook, or your logon is wrong. When logging in with outlook etc, you need to use the Username - e.g. web1_admin, not email adress?

3. Same as 1.
Reply With Quote
  #3  
Old 14th September 2007, 15:59
selfxp selfxp is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for answering so fast!

1. I can access the ISPConfig using internal and external Ip address. Ex. http://ip.addr.of.srv:81 works.
But http://ip.addr.of.srv:81/webmail/ doesn't.

2. Authentification is enabled. I use:
email: selfxp@mydomain.com
username: web3_selfxp
password: ****
pop3: mail.mydomain.com
smtp: mail.mysomain.com

And I have created an
-> A record
* IP-Adresse: ip.addr.of.srv
* Hostname: mail

-> MX record
* Hostname: [empty]
* Mailserver:mail.mydomain.com

Greetings,
Cosmin
Reply With Quote
  #4  
Old 14th September 2007, 16:13
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default Regarding item 2...

Quote:
Originally Posted by selfxp
2. Authentification is enabled. I use:
email: selfxp@mydomain.com
username: web3_selfxp
password: ****
pop3: mail.mydomain.com
smtp: mail.mysomain.com
The way that I've got my ISPConfig set up, the "username" field needs to be the same as the "email" field.

If that change to your mail client settings doesn't do it, I believe my first step would be to look in /etc/postfix/virtusertable and verify that my e-mail address was mapped there. I would expect you would find a line looking like:
selfxp@mydomain.com web3_selfxp
(this is assuming that User Prefix in your system settings is set to [WEBID]_).

If there is such a line, then you might want to verify POP authentication via telnet. If you execute "telnet <server IP address> 110", you should see something like:

Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
+OK Hello there.

In response to this, enter:
USER selfxp@mydomain.com

This should get you a response of:
+OK Password required.

In response to this, enter:
PASS <your password>

If the server responds with:
-ERR Login failed.
then your password is incorrect. If it responds with:
+OK logged in.
your login is correct.

Once you have the POP server responding with "logged in", the value you used after "USER" is what you want to enter in your email client's "login" field.
Reply With Quote
  #5  
Old 14th September 2007, 16:53
selfxp selfxp is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
If that change to your mail client settings doesn't do it, I believe my first step would be to look in /etc/postfix/virtusertable and verify that my e-mail address was mapped there. I would expect you would find a line looking like:
selfxp@mydomain.com web3_selfxp
True, I've found this info:
selfxp@www.mydomain.com web3_selfxp
web3_selfxp@www.mydomain.com web3_selfxp
selfxp@mydomain.com web3_selfxp
web3_selfxp@mydomain.com web3_selfxp

Quote:
Once you have the POP server responding with "logged in", the value you used after "USER" is what you want to enter in your email client's "login" field.
The username that logged in successfuly was "web3_selfxp"
Used it with my email client... but I received the same error
----
Again many thanks for the supper fast answer!
Cosmin
Reply With Quote
  #6  
Old 14th September 2007, 17:00
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default An alternative

Quote:
Originally Posted by selfxp
The username that logged in successfuly was "web3_selfxp"
Used it with my email client... but I received the same error
----
Again many thanks for the supper fast answer!
Cosmin
Some mail clients "help" you by auto-editing the user name field. Some of these brain-dead clients assume that if you enter a full e-mail address in the user name field, you really didn't mean to enter the domain portion and strip if off for you.

Just to see if that's what's happening, instead of using "selfxp@yourdomain.com", use "selfxp%yourdomain.com" (replace the "@" with "%").
Reply With Quote
  #7  
Old 14th September 2007, 17:49
chuckl chuckl is offline
Senior Member
 
Join Date: May 2007
Location: Uxbridge, Middlesex, UK
Posts: 166
Thanks: 1
Thanked 20 Times in 20 Posts
Default

On the Webmail side, I guess the obvious question is 'Have you installed the Webmail Addon? If you have, you will see it listed under Tools in the IspConfig Panel.
The mailuser login needs to be ticked in the website config as well I suspect.

On the Outlook side, the setup I have seen working is to obviously list the server mail incoming and outgoing, user is the ISPconfig user, not the email address, password, and My Server Requires Authentication ticked for both, but Secure Password not ticked.
For testing, I'd say you're safest using the IP address, or FQDN of the server. You can use cnames, additional A records etc when you have the basic functionality working.
Reply With Quote
  #8  
Old 18th September 2007, 22:42
selfxp selfxp is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default It's working! ;)

Hi and thanks to all for helping me solve the problem.
It was more complex than I thougt but now it works just fine:
In order to have my emails work with outlook I had to folow these steps:

a. Had to set into my goDadday account an
MX record:
Host: @
GoesTo: mail.mydomain.com

An A record:
Host: mail
Points To: MyIpAddress

b. I've used in order to install IPSConfig the http://www.howtoforge.com/perfect_setup_opensuse_10.2 but on the page six I had to set this variables without the server1 extension:

postconf -e 'mydomain = mydomain.com'
postconf -e 'myhostname = $mydomain'

Maybe there is an workaround but it didn't solve my problem untill I took the "server1" out.

c. On my outlook configuration I had to use:
email: selfxp@mydomain.com
mail: mydomain.com
smtp: mydomain.com
username: web3_selfxp

Now I can send and receive emails. Again thank you all for you help.

Greetings,
Cosmin
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 07:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.