Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th May 2007, 11:34
celtic celtic is offline
Member
 
Join Date: Jan 2007
Location: Oporto - PORTUGAL
Posts: 61
Thanks: 4
Thanked 0 Times in 0 Posts
Default DNS MX Record Problem

Following the 3 pictures attached we can see that:

1) MX Record is configured in ISPConfig
2) MX Record is configured in the zone file
3) MXLookup tool keeps saying no MX Record exists


4) Mail Server is a MS Exchange working properly
5) We are not receiving any e-mail on the jfo.pt domain

Help is very much appreciated.

Kind Regards and Thanks in advance
Attached Images
   
Reply With Quote
Sponsored Links
  #2  
Old 26th May 2007, 12:08
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

The MX record can not be an IP. It should point to the A record "afonso"

So: afonso MX 10 212.13.x.x. is wrong.
It should be like: afonso MX 10 afonso.jfo.pt.

In records, click on the IP nr thats under Mailserver.
Change the IP nr to: afonso (or if you like to: afonso.jfo.pt)
Change the Hostname to: @
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 26th May 2007 at 12:16.
Reply With Quote
  #3  
Old 26th May 2007, 12:23
celtic celtic is offline
Member
 
Join Date: Jan 2007
Location: Oporto - PORTUGAL
Posts: 61
Thanks: 4
Thanked 0 Times in 0 Posts
Default

So it should be like this?

$TTL 86400
@ IN SOA jfo.nortenet.pt. jfo.jfo.pt. (
2007052602 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS jfo.nortenet.pt. ; Inet Address of name server 1
NS ns1.twisted4life.com. ; Inet Address of name server 2
;

@ MX 10 afonso.jfo.pt.

jfo.pt. A 212.13.41.2
www A 212.13.41.2
afonso A 212.13.49.200

Last edited by celtic; 26th May 2007 at 12:27.
Reply With Quote
  #4  
Old 26th May 2007, 14:31
celtic celtic is offline
Member
 
Join Date: Jan 2007
Location: Oporto - PORTUGAL
Posts: 61
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Update:

1) MXlookup web site now reports the correct mail server.

2) All e-mail ending in @jfo.pt is rejected: 550: Recipient Address Rejected: user unknown in local recipient table.

Seems to me that inspite of the MX record the server keeps "owning" my jfo.pt e-mails.

Kind Regards and Thanks in advance
Reply With Quote
  #5  
Old 27th May 2007, 16:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by celtic
2) All e-mail ending in @jfo.pt is rejected: 550: Recipient Address Rejected: user unknown in local recipient table.
This means that the receiving server doesn't know that it's responsible for the mails, i.e., it isn't configured to receive emails for the domain.
What MTA do you use on the receiving server? Postfix?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 27th May 2007, 16:15
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

falko,

He is using MS Exchange
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #7  
Old 27th May 2007, 16:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by edge
He is using MS Exchange
Then I can't help him, I guess...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 27th May 2007, 20:32
celtic celtic is offline
Member
 
Join Date: Jan 2007
Location: Oporto - PORTUGAL
Posts: 61
Thanks: 4
Thanked 0 Times in 0 Posts
Default

The thing is if I decide to give Domain authority to may ISP all mail works well because I just ask for a MX record for mail server 212.13.49.200 and a host record for www.jfo.pt.

What I am trying to do is get independent of ISP's and take control of my domain.

The thing is that it seems that my Ubuntu server is not letting go of the mails to the mail server and is checking if the users exist instead of simply passing them to the proper server to check. Is there any place to check outside of ISPConfig to prevent such behavior?

PS1: I am a MS Exchange specialist and can assure you that the MS Exchange is in perfect condition.

PS2: my var/log/mail.log.* files reach more than 3Gb. Is that normal or should I check those files to find some wrong behavior.
Reply With Quote
  #9  
Old 27th May 2007, 21:56
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

The thing is that your MX record (that is for mail) is pointing to the MS Exchange server. (afonso.jfo.pt).
So theoretically the mail will (should) never go to the Ubuntu server!

Are you seeing anything in the logfiles from MS Exchange?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #10  
Old 27th May 2007, 22:00
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
 
Default

I've just done a DNS report on your domain again, and it looks like you have changed some things again.

You will need to set the MX record in both namserver (jfo.nortenet.pt, ns1.twisted4life.com)
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
Some problem with DNS Bicet Installation/Configuration 2 9th December 2006 17:23
DNS problem wrender Server Operation 2 25th November 2006 16:57
DNS issue and user's alias problem rosa hsiao General 3 2nd November 2005 10:03


All times are GMT +2. The time now is 07:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.