Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st September 2007, 12:01
qqwong qqwong is offline
Junior Member
 
Join Date: Aug 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Unhappy How do I configure my server to send email for all hosted domains?

My server's main domain is domainA.tld. One of my hosted site has domain domainB.tld. Using mail client, say Thunderbird, a user userB1 on domainB connects from a remote PC to the server. She receives her mails without problem.

The problem happens when she sends mail to any destination except the domains hosted in the server. No mail can be sent to any where.
The mail log is below:

Quote:
Sep 1 17:52:01 www postfix/smtpd[1155]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_destination" instead
Sep 1 17:52:01 www postfix/smtpd[1155]: NOQUEUE: reject: RCPT from unknown[220.232.XXX.XXX]: 554 5.7.1 <wai@gmail.com>: Recipient address rejected: Relay access denied; from=<userB1@domainB.tld> to=<wai@gmail.com> proto=SMTP
Sep 1 17:52:03 www postfix/smtpd[1155]: disconnect from unknown[220.232.XXX.XXX]
My question is how do I configure postfix to accept (authenticated) users of my hosted domains to send email via my server?

I've followed the perfect setup howto to install my server. I'm using SuSE 10.2.


Thanks in advance,
Wai
Reply With Quote
Sponsored Links
  #2  
Old 1st September 2007, 14:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

You must enable smtp autentication in thunderbird when sending emails.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st September 2007, 17:43
qqwong qqwong is offline
Junior Member
 
Join Date: Aug 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks, Till.
I've enabled authentication in Thunderbird. I still can't send mail.

I found in my mail.err log file the following message:

Quote:
Sep 1 23:36:26 www postfix/smtp[15479]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Should ISPConfig create the password_maps file and set the postfix config parameter? or where can I find this file? or how do I create it?

Wai
Reply With Quote
  #4  
Old 1st September 2007, 17:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Password maps is not used by ISPConfig.

Please reconfigure your mail system, especially SASL, as described in the perfect setup howto. All authentication is done against /etc/passwd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st September 2007, 18:54
qqwong qqwong is offline
Junior Member
 
Join Date: Aug 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have followed the perfect setup. I still get the fatal error shown above.

Here is my main.cf. Can you see anything wrong?

Quote:
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_alias_maps = hash:/etc/postfix/virtual
virtual_alias_domains = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = mail.$mydomain
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
mynetworks_style = subnet
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtp_sasl_auth_enable = yes
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = domainA.com
mynetworks = 127.0.0.0/8
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #6  
Old 2nd September 2007, 19:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,736 Times in 2,571 Posts
Default

Please try this:
Code:
postconf -e 'smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd'
Restart Postfix afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 3rd September 2007, 04:27
qqwong qqwong is offline
Junior Member
 
Join Date: Aug 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you, Falko.

I tried what you suggested. Restarted postfix and saslauthd.

No more fatal error message in my mail.err log file. But postfix still does not accept connection from a remote PC and not send mail to external destination.
I still get the message

554 Recipient address rejected: Relay access denied;

Can anyone help please?

Wai
Reply With Quote
  #8  
Old 3rd September 2007, 07:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Please enable smtp authentication in your email client.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 3rd September 2007, 16:20
qqwong qqwong is offline
Junior Member
 
Join Date: Aug 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I've checked the "Use name and password" box in Thunderbird. Does this enable smtp authentication?
Reply With Quote
  #10  
Old 3rd September 2007, 19:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
 
Default

Quote:
Originally Posted by qqwong
I've checked the "Use name and password" box in Thunderbird. Does this enable smtp authentication?
Yes, this enables the smtp authentication.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send out email johnnie Installation/Configuration 1 9th July 2007 08:40
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44
connect email server to a web server kzar Programming/Scripts 2 31st October 2006 17:37
Can't send email with attachments to another email nysprite Installation/Configuration 2 29th June 2006 18:09
Can the squirrelmail webserver different then email server? ejkeebler Server Operation 2 4th November 2005 19:28


All times are GMT +2. The time now is 10:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.