Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th August 2007, 18:36
AutootuA AutootuA is offline
Junior Member
 
Join Date: Aug 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ubuntu 6.06 and Zimbra Network Edition

I followed the instructions and everything installed fine. My domain is nunyad.biz. I can send emails fine but receiving them is an issue. My server is behind a firewall. Is there any way I can test to see if the firewall is configured correctly? HTTP, HTTPS,POP3 and STMP are all enabled and forwarded but emails get returned.

Here is some server info:

dig mx mail.nunyad.biz
Code:
; <<>> DiG 9.3.2 <<>> mx mail.nunyad.biz
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13560
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;mail.nunyad.biz.               IN      MX

;; ANSWER SECTION:
mail.nunyad.biz.        1249    IN      CNAME   nunyad.biz.
nunyad.biz.             3581    IN      MX      10 mailstore1.secureserver.net.
nunyad.biz.             3581    IN      MX      10 67.141.183.82.

;; AUTHORITY SECTION:
nunyad.biz.             1249    IN      NS      ns6.secureserver.net.
nunyad.biz.             1249    IN      NS      NS5.secureserver.net.

;; ADDITIONAL SECTION:
mailstore1.secureserver.net. 2043 IN    A       64.202.166.11
NS5.secureserver.net.   2673    IN      A       208.109.78.180
ns6.secureserver.net.   517     IN      A       208.109.80.75

;; Query time: 41 msec
;; SERVER: 166.102.165.11#53(166.102.165.11)
;; WHEN: Thu Aug 30 08:33:51 2007
;; MSG SIZE  rcvd: 203
host `hostname`

Code:
nunyad.biz has address 67.141.183.82
mail.nunyad.biz is an alias for nunyad.biz.
mail.nunyad.biz is an alias for nunyad.biz.
nunyad.biz mail is handled by 10 67.141.183.82.
nunyad.biz mail is handled by 10 mailstore1.secureserver.net.
Reply With Quote
Sponsored Links
  #2  
Old 31st August 2007, 17:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must check if there's an MX record for nunyad.biz, not for mail.nunyad.biz (or do your emails have the form user@mail.nunyad.biz?).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st August 2007, 18:07
AutootuA AutootuA is offline
Junior Member
 
Join Date: Aug 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've tried sending emails to my server both ways and neither works, but I want to go with the user@nunyad.biz format.

dig mx nunyad.biz

Code:
; <<>> DiG 9.3.2 <<>> mx nunyad.biz
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46318
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;nunyad.biz.                    IN      MX

;; ANSWER SECTION:
nunyad.biz.             3600    IN      MX      10 67.141.183.82.
nunyad.biz.             3600    IN      MX      10 mailstore1.secureserver.net.

;; AUTHORITY SECTION:
nunyad.biz.             18      IN      NS      ns6.secureserver.net.
nunyad.biz.             18      IN      NS      NS5.secureserver.net.

;; ADDITIONAL SECTION:
mailstore1.secureserver.net. 795 IN     A       64.202.166.11
NS5.secureserver.net.   1887    IN      A       208.109.78.180
ns6.secureserver.net.   1887    IN      A       208.109.80.75

;; Query time: 113 msec
;; SERVER: 166.102.165.11#53(166.102.165.11)
;; WHEN: Fri Aug 31 07:57:40 2007
;; MSG SIZE  rcvd: 184

Last edited by AutootuA; 31st August 2007 at 18:23.
Reply With Quote
  #4  
Old 1st September 2007, 03:04
AutootuA AutootuA is offline
Junior Member
 
Join Date: Aug 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm located behind a firewall - NAT device and I found the problem to be a DNS problem. There is some mention about it in the beginning of the" How To", but nothing in detail about MX records and such. I found some instructions on DNS in "The Perfect Ubuntu Server Setup ". I also looked in the Zimbra forums and found a thread on split-dns. Between the two, I was able to get it going. Thanks for the help...
Reply With Quote
  #5  
Old 5th September 2007, 23:02
Dijital Dijital is offline
Junior Member
 
Join Date: Aug 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please share how you got this working as I am having many problems with this part of the DNS, and would appreciate any assistance, other than that I'm good to go. I too am behind a NAT firewall but I have all ports forwarded to that IP, suggestions?

-Dijital
Reply With Quote
  #6  
Old 6th September 2007, 23:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

How does your MX record look?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 7th September 2007, 21:55
AutootuA AutootuA is offline
Junior Member
 
Join Date: Aug 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I found another tutorial that shows how to set up a split-dns. I still don't understand the whole DNS thing yet. The other tutorial has emails coming and going as user@mail.example.com. I really want emails as user@example.com. I followed your "How To Install Zimbra Collaboration Suite (ZCS) On Ubuntu" and right before installing zimbra did this:

1) apt-get install bind9

2) edit /etc/hosts
Code:
127.0.0.1       localhost.localdomain localhost
xxx.xxx.xxx.xxx  mail.MYDOMAIN.com mail
***configure bind for split DNS.***

3)edit /etc/bind/named.conf.options
Code:
       // forwarders {
      //      0.0.0.0;
      // };
Uncomment and change to reflect your own upstream DNS servers.


Code:
      forwarders { 
      xxx.xxx.xxx.xxx; xxx.xxx.xxx.xxx; 
      };
4) Append to /etc/bind/named.conf.local

Code:
      	// We are the master server for mail.MYDOMAIN.com
      	zone "mail.MYDOMAIN.com" {
      		type master;
      		file "db.mail.MYDOMAIN.com";
      };
5) Create the zone file: /var/cache/bind/db.mail.MYDOMAIN.com

Code:
      ;
      ;       Addresses and other host information.
      ;
      @       IN      SOA     mail.MYDOMAIN.com. hostmaster.mail.MYDOMAIN.com. (
                                     10118      ; Serial
                                     43200      ; Refresh
                                     3600       ; Retry
                                     3600000    ; Expire
                                     2592000 )  ; Minimum
      ;       Define the nameservers and the mail servers
                     IN      NS      xxx.xxx.xxx.xxx
                     IN      A       xxx.xxx.xxx.xxx
                     IN      MX      10 mail.MYDOMAIN.com.
6) Modify /etc/resolv.conf -- Change upstream name servers to your own IP:
Code:
nameserver xxx.xxx.xxx.xxx
7) /etc/init.d/bind9 reload

8) To test it, nslookup mail.MYDOMAIN.com should point to xxx.xxx.xxx.xxx


What would have to change or be added to get user@example.com to work?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zimbra on Ubuntu, please help me with 2 problem owl700 HOWTO-Related Questions 3 12th August 2007 13:56


All times are GMT +2. The time now is 16:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.