Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th December 2006, 19:49
jeanjacquesjeanjacques jeanjacquesjeanjacques is offline
Member
 
Join Date: Nov 2005
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default A trouble with .htaccess

Hi Guys,

I don't understand why but i'm trying to create an .htaccess file with the following content:

ptions -Indexes
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .+ ./index.php [L]

All i get in return is an error 500.

Do you have an idea of i'm doing wrong ?

Any help would be really appreciated.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 7th December 2006, 20:59
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

Replace

Code:
ptions -Indexes
with

Code:
Options -Indexes
But you can also check you apache error logs
Reply With Quote
  #3  
Old 7th December 2006, 21:28
jeanjacquesjeanjacques jeanjacquesjeanjacques is offline
Member
 
Join Date: Nov 2005
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Well sorry i've made a mistake when i copy/pasted, this is the real content of the .htaccess:

Options -Indexes
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .+ ./index.php [L]

I still get an error 500.

I don't really understand because the error is not in the error.log.

I tried cat /var/log/apache/error.log | grep mydomain.com

Any suggestion ?
Reply With Quote
  #4  
Old 7th December 2006, 21:43
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

I think in this case tail /var/log/apache/error.log is a better choice

Look if your AllowOverride Directive is allowing you to use this directives in this directory.

http://httpd.apache.org/docs/2.0/mod...#allowoverride
Reply With Quote
  #5  
Old 7th December 2006, 22:12
jeanjacquesjeanjacques jeanjacquesjeanjacques is offline
Member
 
Join Date: Nov 2005
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Jnsc,

Thanks for the advice.
I've changed my httpd.conf with this directive:

#
# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"
#
AllowOverride all

I restarted apache but i still get this error 400...

i really don't understand.
Reply With Quote
  #6  
Old 7th December 2006, 22:25
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

what is the output of
Code:
tail /var/log/apache/error.log
Reply With Quote
  #7  
Old 7th December 2006, 22:31
jeanjacquesjeanjacques jeanjacquesjeanjacques is offline
Member
 
Join Date: Nov 2005
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here it is:
HTML Code:
hulk:/home/www/web40/log# tail /var/log/apache/error.log
[Thu Dec  7 22:01:32 2006] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Dec  7 22:10:21 2006] [notice] SIGHUP received.  Attempting to restart
[Thu Dec  7 22:10:21 2006] [notice] Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-16 configured -- resuming normal operations
[Thu Dec  7 22:10:21 2006] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Dec  7 22:14:51 2006] [notice] SIGHUP received.  Attempting to restart
[Thu Dec  7 22:14:51 2006] [notice] Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-16 configured -- resuming normal operations
[Thu Dec  7 22:14:51 2006] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Dec  7 22:21:38 2006] [notice] SIGHUP received.  Attempting to restart
[Thu Dec  7 22:21:38 2006] [notice] Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-16 configured -- resuming normal operations
[Thu Dec  7 22:21:38 2006] [notice] Accept mutex: sysvsem (Default: sysvsem)
hulk:/home/www/web40/log# 
Reply With Quote
  #8  
Old 7th December 2006, 23:08
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

and
Code:
tail /home/www/web40/log/error.log
Reply With Quote
  #9  
Old 8th December 2006, 07:55
jeanjacquesjeanjacques jeanjacquesjeanjacques is offline
Member
 
Join Date: Nov 2005
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the output

Code:
hulk:~# tail /home/www/web40/log/error.log
[Thu Dec  7 21:40:01 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/golf-channel
[Thu Dec  7 21:40:02 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/favicon.ico
[Thu Dec  7 21:40:05 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/favicon.ico
[Thu Dec  7 21:42:43 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/favicon.ico
[Thu Dec  7 21:42:44 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/favicon.ico
[Thu Dec  7 21:42:50 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/favicon.ico
[Thu Dec  7 21:54:53 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/favicon.ico
[Thu Dec  7 21:54:55 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/golf-cart
[Thu Dec  7 21:57:51 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/golf-equipment
[Thu Dec  7 22:00:24 2006] [error] [client 88.160.48.159] File does not exist: /home/www/web40/web/golf-play
I don't understand i can't see the error 400 in there
Reply With Quote
  #10  
Old 8th December 2006, 09:16
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
 
Default

Is it now an error 400 or still 500, because it's a different one
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
ISPConfig and .htaccess ionut89 Feature Requests 1 17th October 2006 17:45
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09
.htaccess never executed galmiche Server Operation 2 4th June 2006 21:44
No .htaccess in automatic backup? tron Installation/Configuration 3 22nd March 2006 18:03


All times are GMT +2. The time now is 00:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.