Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th August 2007, 03:29
aranthorn aranthorn is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 7
Thanked 0 Times in 0 Posts
Unhappy subdomain and mail relay configuration

I used the perfect server for fedora 7 configuration following the step by step instructions here: http://www.howtoforge.com/perfect_server_fedora7

Thanks to Falco for putting that together, BTW!

But I have a couple issues.

#1
I can't get my subdomain to work (images.dancingmokey.com)
When I go to http://www.dancingmokey.com/images/ I get a 403 error
When I go to http://images.dancingmokey.com/ I get
Quote:
This IP address is shared. For access to the web site which you look for, enter its address instead of its IP
I'm at a loss.


#2
Also, when someone uses a contact link from the forum installed (vBulletin 3.6.8), I get the email just fine, but when I try to reply I get:
Quote:
Your message did not reach some or all of the intended recipients.

Subject: RE: Dancingmokey Contact Us Form - Site Feedback
Sent: 8/12/2007 11:37 PM

The following recipient(s) cannot be reached:

'Garn @ Dancingmokey' on 8/12/2007 11:37 PM
554 5.7.1 <removedbyme@yahoo.com>: Relay access denied
What can I do? I'll post any information asked for, but I went through that perfect server setup word for word. Everything else works fine.

Thanks in advance and yes, I did search these forums before posting
Reply With Quote
Sponsored Links
  #2  
Old 20th August 2007, 10:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

1) You get the shared IP error because you selected the wrong IP address for the website. If your server is behind a router, you must use the internal IP and not the external IP for the website.

2) Is your server hsoted at home on a dsl line with a dynamic IP address?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st August 2007, 16:51
aranthorn aranthorn is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 7
Thanked 0 Times in 0 Posts
Default

I have a server that is colocated, it's not on dynamic dns or at home. The colo facility gave me block of IPs:
xx.xx.xx.16/29:
xx.xx.xx.16 Subnet Address
xx.xx.xx.17 Router Address (as given by Colo)
xx.xx.xx.18 ISPConfig Install Address (server.dancingmokey.com)
xx.xx.xx.19 www.dancingmokey.com
xx.xx.xx.20 www.phoebesfriends.com
xx.xx.xx.21 not used
xx.xx.xx.22 not used
xx.xx.xx.23 Broadcast Address

So, .18:81 is running the ISPConfig interface with no problem.

.19 is running dancingmokey, no problem
.20 is running phoebesfriends, no problem

I try to setup another site (as has been suggested on this forum) for the subdomain and I get a "images.domain1.com" is already in use by another domain. Is this because I had at first set it up under the dancingmokey.com site and then removed it? ISPConfig shows no entries at all for images.dancingmokey.com and the DNS service has no entry for images.dancingmokey.com either, but when I do a lookup on it, it comes back as the .19 address. Oddly, the server.dancingmokey.com resolves to .19 as well.

Here are the only entries I have for my dns. I use mydomain.com:
Quote:
DNS Management help

dancingmokey.com MX mail.dancingmokey.com
dancingmokey.com A 69.65.22.19
Shoul I be adding CNAME or something else?


As far as the relay thing goes, I have no idea what to do. Email works just fine unless I'm replying to the "contact us" form, etc.
Reply With Quote
  #4  
Old 22nd August 2007, 18:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's in Vhosts_ispconfig.conf, and what's the output of
Code:
ifconfig
?
Quote:
Originally Posted by aranthorn

I try to setup another site (as has been suggested on this forum) for the subdomain and I get a "images.domain1.com" is already in use by another domain. Is this because I had at first set it up under the dancingmokey.com site and then removed it? ISPConfig shows no entries at all for images.dancingmokey.com and the DNS service has no entry for images.dancingmokey.com either
Please also check in ISPConfig's recycle bins. If you deleted that Co-Domain earlier, it's in a recycle bin now (unless you deleted it from there, too).

Quote:
Originally Posted by aranthorn
As far as the relay thing goes, I have no idea what to do. Email works just fine unless I'm replying to the "contact us" form, etc.
Did you enable "Server requires authentication" in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
aranthorn (22nd August 2007)
  #5  
Old 23rd August 2007, 04:26
aranthorn aranthorn is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 192.168.1.200:80
<VirtualHost 192.168.1.200:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 192.168.122.1:80
<VirtualHost 192.168.122.1:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 69.65.22.18:80
<VirtualHost 69.65.22.18:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 69.65.22.19:80
<VirtualHost 69.65.22.19:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 69.65.22.20:80
<VirtualHost 69.65.22.20:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 69.65.22.21:80
<VirtualHost 69.65.22.21:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.dancingmokey.com:80
######################################
#
#
<VirtualHost 69.65.22.19:80>
ServerName www.dancingmokey.com:80
ServerAdmin webmaster@dancingmokey.com
DocumentRoot /var/www/web1/web
ServerAlias www.dancingmokey.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#
######################################
# Vhost: www.phoebesfriends.com:80
######################################
#
#
<VirtualHost 69.65.22.20:80>
ServerName www.phoebesfriends.com:80
ServerAdmin webmaster@phoebesfriends.com
DocumentRoot /var/www/web2/web
ServerAlias phoebesfriends.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /var/www/web2/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web2/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /var/www/web2/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /var/www/web2/phptmp/
php_admin_value session.save_path /var/www/web2/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web2/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
</VirtualHost>
#
#
#
######################################
# Vhost: images.dancingmokey.com:80
######################################
#
#
<VirtualHost 69.65.22.19:80>
ServerName images.dancingmokey.com:80
ServerAdmin webmaster@dancingmokey.com
DocumentRoot /var/www/web12/web
ServerAlias dancingmokey.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web12/log/error.log
Alias /error/ "/var/www/web12/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web12/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web12/user/$1/web/$3
</VirtualHost>
#
#
#
It was a recycle bin problem. That's taken care of now.

Yes, the client is set up that way.
Reply With Quote
  #6  
Old 23rd August 2007, 19:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the output of
Code:
ifconfig
?

Do you use the correct username (something like web1_someuser) and password in the email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
AbannyvabVask (22nd December 2013)
  #7  
Old 24th August 2007, 06:20
aranthorn aranthorn is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Code:
[root@server ~]# ifconfig
eth1      Link encap:Ethernet  HWaddr 00:14:4F:20:AE:B9
          inet addr:69.65.22.18  Bcast:69.65.22.23  Mask:255.255.255.248
          inet6 addr: fe80::214:4fff:fe20:aeb9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:63503470 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69338693 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:23303709948 (21.7 GiB)  TX bytes:41014863153 (38.1 GiB)
          Base address:0x9800 Memory:fbfc0000-fbfe0000

eth1:0    Link encap:Ethernet  HWaddr 00:14:4F:20:AE:B9
          inet addr:69.65.22.19  Bcast:69.65.22.23  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0x9800 Memory:fbfc0000-fbfe0000

eth1:1    Link encap:Ethernet  HWaddr 00:14:4F:20:AE:B9
          inet addr:69.65.22.20  Bcast:69.65.22.23  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0x9800 Memory:fbfc0000-fbfe0000

eth1:2    Link encap:Ethernet  HWaddr 00:14:4F:20:AE:B9
          inet addr:69.65.22.21  Bcast:69.65.22.23  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0x9800 Memory:fbfc0000-fbfe0000

eth3      Link encap:Ethernet  HWaddr 00:14:4F:20:AE:BF
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Base address:0x9000 Memory:fbf80000-fbfa0000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:190531 errors:0 dropped:0 overruns:0 frame:0
          TX packets:190531 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:132238009 (126.1 MiB)  TX bytes:132238009 (126.1 MiB)

peth0     Link encap:Ethernet  HWaddr 00:14:4F:20:AE:B8
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Base address:0x9c00 Memory:fbfe0000-fc000000

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:8954 (8.7 KiB)

[root@server ~]#
I removed the prefix. Logging in is no problem. I can recieve email without issue, it's the sending that's an issue. Like when I try to send to me gmail account:
Code:
Your message did not reach some or all of the intended recipients.

      Subject:	test
      Sent:	8/23/2007 11:14 PM

The following recipient(s) cannot be reached:

      'aranthorn@gmail.com' on 8/23/2007 11:14 PM
            554 5.7.1 <aranthorn@gmail.com>: Relay access denied
So, the subdomain is straightened out thanks to the recycle bin (feeling very smart). It's the sending email that's got me stumped now.

Thanks for your efforts, BTW
Reply With Quote
  #8  
Old 24th August 2007, 22:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 25th August 2007, 04:44
aranthorn aranthorn is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Here it is, in all it's glory, with all commented items removed:
Code:
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.4.3/samples
readme_directory = /usr/share/doc/postfix-2.4.3/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
mynetworks = 127.0.0.0/8
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtpd_sasl_authenticated_header = yes
myhostname = server.dancingmokey.com

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #10  
Old 26th August 2007, 16:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Looks ok. Are there any errors in your mail log when you try to send a mail?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS zones for mail exchange, subdomain, smtp and pop3 nabuk Installation/Configuration 5 7th November 2006 15:56
Using a subdomain as mail server roberto8080 Installation/Configuration 7 21st June 2006 01:50
Mail address at subdomain dlikar Installation/Configuration 1 7th June 2006 10:42
Can't figure out how to use subdomain for mail. SkIRmiS Installation/Configuration 1 20th September 2005 21:31


All times are GMT +2. The time now is 13:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.