#1  
Old 30th August 2007, 08:49
amgat amgat is offline
Junior Member
 
Join Date: Aug 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default php disabled on sites

OS : Ubuntu Server 7.04

I've had some sites created by ISPconfig running perfectly for some time.

This morning i created a new ISPConfig site, and discovered that PHP no longer is enabled on any of my sites. Tried disable and re enable PHP for the sites but still not activated.

I took a look at the "Vhosts_ispconfig.conf" file and discovered that the following line was missing:
AddType application/x-httpd-php .php .php3 .php4 .php5
If i add this line and restart apache, it works again. But as soon as i do any changes to my site in ISPConfig, PHP becomes disabled and the line is missing from vhosts_ispconfig.conf file again.

This problem is getting on my nerves as this is a production server Hope someone is able to help me with this problem.
Reply With Quote
Sponsored Links
  #2  
Old 30th August 2007, 13:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

What is the value of the variable $go_info["server"]["apache2_php"] in the file /home/admispconfig/ispconfig/lib/config.inc.php ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th August 2007, 19:51
amgat amgat is offline
Junior Member
 
Join Date: Aug 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This was changed to addtype earlier, but changed it back to "both". still no change
Reply With Quote
  #4  
Old 30th August 2007, 20:14
amgat amgat is offline
Junior Member
 
Join Date: Aug 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

ah! i found out what was causing the problem. For some reason, I had commented out the line $go_info["server"]["apache2_php"] because i read in a forum somewhere that this was causing PHP log errors.

I removed the comment and set type to "suphp". Works like a charm now. Thankyou for helping me out.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
php eating cpu shajazzi Server Operation 15 15th August 2007 01:19
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 09:54
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 22:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.