Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th August 2007, 17:22
rjamesd rjamesd is offline
Member
 
Join Date: Aug 2007
Posts: 35
Thanks: 3
Thanked 4 Times in 3 Posts
Question How to get localhost/cgi-bin/bugzilla/ to execute/display output of index.cgi ?

Hi, I'm using webmin on Apache 2.2.3 on Debian 4.0.

http://localhost/cgi-bin/bugzilla/index.cgi works and runs a script index.cgi in /usr/lib/cgi-bin/bugzilla/index.cgi

but I want http://localhost/cgi-bin/bugzilla/ to do the same but instead I get

Forbidden

You don't have permission to access /cgi-bin/bugzilla/ on this server.
Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/4.4.4-8+etch4 mod_perl/2.0.2 Perl/v5.8.8 Server at rockstar Port 80

The /var/log/apache2/error.log shows:
[Tue Aug 28 15:20:26 2007] [error] [client 127.0.1.1] attempt to invoke directory as script: /usr/lib/cgi-bin/bugzilla/

My settings in webmin are:
Directives
For Directory /usr/lib/cgi-bin/ on *
Options ExecCGI Indexes /etc/apache2/apache2.conf (679)
DirectoryIndex index.cgi /etc/apache2/apache2.conf (680)

Please advise.

Last edited by rjamesd; 28th August 2007 at 17:23. Reason: Adding (?) symbol
Reply With Quote
Sponsored Links
  #2  
Old 4th September 2007, 17:20
rjamesd rjamesd is offline
Member
 
Join Date: Aug 2007
Posts: 35
Thanks: 3
Thanked 4 Times in 3 Posts
Question

Surely someone else must have wanted a solution to this problem?
Reply With Quote
  #3  
Old 10th October 2007, 16:56
rjamesd rjamesd is offline
Member
 
Join Date: Aug 2007
Posts: 35
Thanks: 3
Thanked 4 Times in 3 Posts
 
Lightbulb Fixed it, no thanks to you guys - solution within

I've fixed it - solution:

my cgi-bin directory is /usr/lib/cgi-bin so:

instead of using:

ScriptAlias /cgi-bin /usr/lib/cgi-bin

- which gave me the problems, I use this instead

Alias /cgi-bin /usr/lib/cgi-bin
<Directory /usr/lib/cgi-bin>
AddHandler cgi-script cgi pl
Options ExecCGI
</Directory>

I got this solution from: http://wiki.apache.org/httpd/DirectoryAsScript

- took a lot of searching in google to find this.

I'm using webmin to paste in the above script fragment in manually.

I hope this puts others out of the misery I had to go through. I'm so pleased!

http://www.howtoforge.com/forums/showthread.php?t=15042
( 403 Forbidden (trying to exec dir as script) but apache config file seems OK)
Reply With Quote
The Following 2 Users Say Thank You to rjamesd For This Useful Post:
falko (11th October 2007), gaelle3182 (28th November 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firewall script ColdDoT Server Operation 1 9th May 2006 00:50
SuseFirewall expert pls help zacch Installation/Configuration 11 17th March 2006 05:24


All times are GMT +2. The time now is 20:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.