Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th August 2007, 13:26
dogar dogar is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default squid problem on RHEL Release 5

hi all

i have installed RHEL Release 5. when i configure the squid 2.6 on it as well as my requirement is that
1- configure individual cache on /cache (which has isolated mount point)
mean to say.
# cache_dir /var/spool/squid 100 16 256
cache_dir /cache 10000 16 256

2- squid configure on port 80 (listening port 80 either 3128)


but when i try to start the service of squid
i got a error page
cache_dir permission deny
squid cant listen port 80

note; i can change ownership of /cache directory from root to squid
also crating swap directories by squid -z

but again i can start the service of squid
i got the same error

plz help me for both cases.
Reply With Quote
Sponsored Links
  #2  
Old 28th August 2007, 13:44
dogar dogar is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

hi all

as i mentiond in above post i have two problems.the first one i have solved.the second one about port.when i change port from 3128 to 80 following error is generatd.

"can not bind Socket FD 12 to *:80: (13) Permission denid.
FATAL: can not open HTTP port"

plz help me..
Reply With Quote
  #3  
Old 28th August 2007, 19:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by dogar
hi all

as i mentiond in above post i have two problems.the first one i have solved.the second one about port.when i change port from 3128 to 80 following error is generatd.

"can not bind Socket FD 12 to *:80: (13) Permission denid.
FATAL: can not open HTTP port"

plz help me..
Ports <= 1024 are privileged, and you need root permissions to use them. Try another port (maybe 8080).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 29th August 2007, 06:59
dogar dogar is offline
Junior Member
 
Join Date: Jul 2007
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

hi falko

i login as root.
Our network is consist of more then 4000 nodes and its very diffecult to change proxy settings on every machine.
is there any other solaution ????

bilal
Reply With Quote
  #5  
Old 29th August 2007, 14:53
alexillsley alexillsley is offline
Senior Member
 
Join Date: Dec 2006
Posts: 396
Thanks: 27
Thanked 4 Times in 4 Posts
 
Smile

----- expired ----

Last edited by alexillsley; 15th November 2010 at 13:15.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Squid Problem tommyboy180 HOWTO-Related Questions 10 21st May 2007 15:32
Debian Sarge memory release problem luxpops Installation/Configuration 7 22nd April 2006 16:50
Debian Sarge 3.1 memory release problem luxpops Technical 1 19th April 2006 15:41
Squid Problem.....Access Denied tbaker HOWTO-Related Questions 3 4th February 2006 14:46


All times are GMT +2. The time now is 00:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.