Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 7th December 2005, 13:11
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok i am using kmail. And i put in all the information you said the message is being sent (it goes into my sent items, but then i can't receive the message. I created a email account in ispconfig like you guys said. But When i go to test it i don't get any messages. it says that there is no new mail in imap. Is it ok that i am sending the test message to my self is that ok??? Like i created james@netlab.com and to test i send a message to james@netlab.com.

Well so far so good i just need to get this to work. if you need any more infor i will provide it.
Reply With Quote
Sponsored Links
  #22  
Old 7th December 2005, 13:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Have you set mbox / maildir delivery in ispconfig corresponding to your pop3 and imap daemon? If you use courier, it must be maildir. Did you get any errors in your mail log?
Reply With Quote
  #23  
Old 7th December 2005, 15:01
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok well i followed this to set up my email account http://www.ispconfig.org/downloads/m..._src.htm#4_2_2
Do i have to set up the mbox / maildir in the website or client side of ispconfig or is it in the email account set up.


And it didnt tell me how to set the mbox / maildir delivery in ispconfig. And the type of imap is the one that the perfect guide to madrake told me to use.

looking at my mail log i dont get any errors but i might be doing it wrong, so can you tell me the way to do it and that will make sure i am checking the right thing.
Reply With Quote
  #24  
Old 7th December 2005, 15:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

You must enable/disable Maildir in ISPConfig under Management -> Server -> Settings -> Email.

If you've followed the Mandrake tutorial, then Maildir should be disabled.

What's in your mail log when you send an email to james@netlab.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 7th December 2005, 18:57
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So you are saying i need to disable maildir for it to work. Well i check the mailq and all the messages sitting there are saying host or domain name not found name service erro for name=netlan.com type mx: host not found try again. Were all do i need to check the host name and domain name?? i mad sure that everything says net lab. I am just not understanding this error. Does it mean that the computers domian name / host is wrong or is my configuration in ispconf is wrong??

Ok what is the command to check the log file??
This is the one i am using tail -f /var/log/syslog
Reply With Quote
  #26  
Old 7th December 2005, 19:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

The error message sais, that you do not have an mx DNS record for your domain netlan.com pointing to your mailserver.
Reply With Quote
  #27  
Old 7th December 2005, 19:42
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok i changed that i went into dns manager and changed the settings
server: server 1
Domain (SOA): netlan.com
IP:192.168.1.1

I left the options tab allone.

I edited the records tab:
I scrolled down to mx records and i clicked on made new one
hostname:www (not sure what to put here but i left it the same as i put in the i think server setup or client host name)
mailserver:netlan.com (not sure if this needs to be IP address)

then i ran the command tail -f /var/log/syslog
and i got this.

Dec 7 13:31:58 localhost postfix/smtpd[24959]: connect from netlan.com[192.168.1.1]
Dec 7 13:31:58 localhost postfix/smtpd[24959]: AFF559055A: client=netlan.com[192.168.1.1], sasl_method=PLAIN, sasl_username=web1_james
Dec 7 13:31:58 localhost postfix/cleanup[24982]: AFF559055A: message-id=<43972A9E.9080804@netlan.com>
Dec 7 13:31:58 localhost postfix/smtpd[24959]: disconnect from netlan.com[192.168.1.1]
Dec 7 13:31:58 localhost postfix/qmgr[23045]: AFF559055A: from=<james@netlan.com>, size=546, nrcpt=1 (queue active)
Dec 7 13:31:59 localhost postfix/smtp[24985]: AFF559055A: to=<james@netlan.com>, relay=none, delay=1, status=bounced (mail for netlan.com loops back to myself)
Dec 7 13:31:59 localhost postfix/cleanup[24982]: 6454A9055F: message-id=<20051207183159.6454A9055F@james.mylan.com>
Dec 7 13:31:59 localhost postfix/qmgr[23045]: 6454A9055F: from=<>, size=2196, nrcpt=1 (queue active)
Dec 7 13:31:59 localhost postfix/qmgr[23045]: AFF559055A: removed
Dec 7 13:31:59 localhost postfix/smtp[24985]: 6454A9055F: to=<james@netlan.com>, relay=none, delay=0, status=bounced (mail for netlan.com loops back to myself)
Dec 7 13:31:59 localhost postfix/qmgr[23045]: 6454A9055F: removed
Reply With Quote
  #28  
Old 7th December 2005, 19:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Please have a look here:

http://www.howtoforge.com/forums/showthread.php?t=1230
Reply With Quote
  #29  
Old 7th December 2005, 21:20
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok i did what that link said to do and it work to some extent now i get this when i send a message. It seems that postfix is removing the message before i can get in my email client. I am using mozilla thunderbird

dec 7 14:58:07 localhost postfix/smtpd[5911]: connect from unknown[192.168.1.2]
Dec 7 14:58:07 localhost postfix/smtpd[5911]: D70A3904C5: client=unknown[192.168.1.2], sasl_method=PLAIN, sasl_username=web1_rick
Dec 7 14:58:07 localhost postfix/cleanup[6122]: D70A3904C5: message-id=<43973EA7.5030203@netlan.com>
Dec 7 14:58:07 localhost postfix/smtpd[5911]: disconnect from unknown[192.168.1.2]
Dec 7 14:58:08 localhost postfix/qmgr[4877]: D70A3904C5: from=<rick@netlan.com>, size=542, nrcpt=1 (queue active)
Dec 7 14:58:08 localhost postfix/local[6123]: D70A3904C5: to=<james@netlan.com>, relay=local, delay=1, status=sent (delivered to mailbox)
Dec 7 14:58:08 localhost postfix/qmgr[4877]: D70A3904C5: removed
Dec 7 14:58:50 localhost imapd[6247]: imap service init from 192.168.1.1
Dec 7 14:59:02 localhost imapd[6247]: Authenticated user=web1_james host=netlan.com [192.168.1.1]

This is when i send it from another computer. i cant get the email then.
So i thought i needed to make a new user so i made rick@netlan.com under the email tab under the website. and this is what i get when i try to send to rick@netlan.com


Dec 7 15:00:07 localhost postfix/smtpd[6396]: NOQUEUE: reject: RCPT from netlan.com[192.168.1.1]: 450 <rick@netlan.com>: Recipient address rejected: User unknown in local recipient table; from=<james@netlan.com> to=<rick@netlan.com> proto=ESMTP helo=<[192.168.1.1]>
Dec 7 15:01:01 localhost CROND[6551]: (root) CMD (nice -n 19 run-parts /etc/cron.hourly)

The authentication is working as far as i can see i am not getting any errors.

Last edited by snake911; 8th December 2005 at 00:44.
Reply With Quote
  #30  
Old 8th December 2005, 00:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by snake911
Dec 7 14:58:08 localhost postfix/local[6123]: D70A3904C5: to=<james@netlan.com>, relay=local, delay=1, status=sent (delivered to mailbox)
Looks good!

Quote:
Originally Posted by snake911
Dec 7 15:00:07 localhost postfix/smtpd[6396]: NOQUEUE: reject: RCPT from netlan.com[192.168.1.1]: 450 <rick@netlan.com>: Recipient address rejected: User unknown in local recipient table; from=<james@netlan.com> to=<rick@netlan.com> proto=ESMTP helo=<[192.168.1.1]>
Does rick@netlan.com exist in /etc/postfix/virtusertable?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig installation on redhat 9 arya6000 Installation/Configuration 4 27th November 2005 16:10
Manual ISPConfig installation Jan Installation/Configuration 6 29th October 2005 11:56
ISPConfig Installation kisong Installation/Configuration 6 14th October 2005 14:48
Please Help me. Error ISPconfig installation firm2547 Installation/Configuration 2 22nd September 2005 18:09
Changing values on ISPConfig installation Luciano Installation/Configuration 4 16th August 2005 23:32


All times are GMT +2. The time now is 08:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.