Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st December 2005, 01:36
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Installation Of Ispconfig

Alright guys i have mandriva 10.2 install!! i have all the software installed that is needed for the installation of ispconfig but i am getting this error:

tar: /root/ispconfig/install_ispconfig/compile_aps/../binaries/aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
./compile: line 111: 5230 Broken pipe tar -pczf ${COMPILE_DIR}/../binaries/aps.tar.gz ${APPLICATION_NAME}_tmp
ERROR: Could not create aps.tar.gz
./compile: line 55: cd: /root/ispconfig/install_ispconfig/compile_aps: No such file or directory



I have no idea what is going on?? Need any kind of help possible. My main goal is to get imap up and running and i was told ispconfig was the way to go. If that is wrong please let me know.

Any help would be kindly appreciated!!!!
Reply With Quote
Sponsored Links
  #2  
Old 1st December 2005, 10:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=1335
http://www.howtoforge.com/forums/showthread.php?t=182
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st December 2005, 18:52
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i redid it like the howtos said and i still get that error!!!!!!! I am at a loss on this one!!!!! it seems to be looking for a file that is not there!
Reply With Quote
  #4  
Old 1st December 2005, 23:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Hm, I think the problem is that you're trying to install from /root/ispconfig. Choose another directory, e.g. /tmp, then unpack the ISPConfig sources there, go to install_ispconfig and run
Code:
./setup
.

Make sure you delete /root/ispconfig and /home/admispconfig before if they exist.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 2nd December 2005, 02:59
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well i just did what you suggested and i got to same place but with different error here is the error this time:

Installing build environment: /root/ispconfig/php/lib/php/build/
Installing header files: /root/ispconfig/php/include/php/
Installing helper programs: /root/ispconfig/php/bin/
program: phpize
program: php-config
program: phpextdist
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
creating target.h - canonical system defines
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... configure: error: newly created file is older than distributed files!
Check your system clock
ERROR: Could not configure ClamAV


I did what you said and unzipped it in the /tmp and the above error is what i got. i dont understand why do i have to look at system clock. i just gues this wants to give me a hard time????
Reply With Quote
  #6  
Old 2nd December 2005, 10:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by snake911
well i just did what you suggested and i got to same place but with different error here is the error this time:

Installing build environment: /root/ispconfig/php/lib/php/build/
Installing header files: /root/ispconfig/php/include/php/
Installing helper programs: /root/ispconfig/php/bin/
program: phpize
program: php-config
program: phpextdist
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
creating target.h - canonical system defines
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... configure: error: newly created file is older than distributed files!
Check your system clock
ERROR: Could not configure ClamAV


I did what you said and unzipped it in the /tmp and the above error is what i got. i dont understand why do i have to look at system clock. i just gues this wants to give me a hard time????
You have to update your system time! Run
Code:
date
to find out your current system time. If the ClamAV sources are from a newer date than your system time then ClamAV complains... ClamAV is very finicky about this...
On http://www.howtoforge.com/perfect_se...ndrake_10_2_p6 I describe how to update your system time.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 2nd December 2005, 13:12
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well i got a little further this morning!!! Thank you so much for the help!!! But right now i have another error:

########## QUOTA ##########

Checking for package quota...
which: no quota in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
ERROR: quota not found!

I remember seeing this on the forums somewhere but i cant find it any more.
so any more help would be appreciated.

All other advice has worked so far!!! thank you thank you!!!
Reply With Quote
  #8  
Old 2nd December 2005, 14:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

ISPConfig needs the quota package. Install the quota package from mandriva, delete the rests of the failed install as described in the installation manual, unpack the installer tar.gz again and rerun the setup.
Reply With Quote
  #9  
Old 2nd December 2005, 20:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I recommend that you have a look at this tutorial: http://www.howtoforge.com/perfect_setup_mandrake_10_2

It prepares a Mandrake 10.2 system for the installation of ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 2nd December 2005, 20:42
snake911 snake911 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I am looking at it now and installing the stuff right in a row!!! I should of done this first!!!! I will let you know if it works!!!! I am working on it right now!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig installation on redhat 9 arya6000 Installation/Configuration 4 27th November 2005 16:10
Manual ISPConfig installation Jan Installation/Configuration 6 29th October 2005 11:56
ISPConfig Installation kisong Installation/Configuration 6 14th October 2005 14:48
Please Help me. Error ISPconfig installation firm2547 Installation/Configuration 2 22nd September 2005 18:09
Changing values on ISPConfig installation Luciano Installation/Configuration 4 16th August 2005 23:32


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.