#1  
Old 16th August 2007, 18:06
Sidi Sidi is offline
Junior Member
 
Join Date: Aug 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig kills system user?

Hi,

I thing I have found a litte bug in ISPConfig 2.3.12 (yes, I know it isn't
the latest, but I havn't seen this in the changelog):

If a reseller add a new (email-) user, ISPConfig doesn't seem to check if
this name already exists as an systemuser in /etc/passwd.

I had for example a user "martin" with UID 1000, ISPConfig uses UID's > 10000. A reseller had add an email-user "martin" which was added with UID 10318 and my old "martin" was deleted in the /etc/passwd.

Haven't checked yet if you also can delete such users as "uucp", "www-data" or even "root" this way.

regards,
martin
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2007, 18:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,533 Times in 4,351 Posts
Default

ISPConfig does not delete or modify any users that had been there before ISPConfig was installed and you should not add any users manually after you installed ISPConfig.

ISPConfig uses for this a user blacklist: /home/admispconfig/ispconfig/users

You will not be able to create a user in ISPConfig that is listed on this blacklist.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th August 2007, 18:49
Sidi Sidi is offline
Junior Member
 
Join Date: Aug 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Oops, I have forgoten about the blacklist.
Hmm, strange the user "martin" isn't in there but he was definitely on the system before ISPConfig was installed, because it was the one user-account Debian always ask you to generate during the install (and therefor got UID 1000).

regards,
martin
Reply With Quote
  #4  
Old 16th August 2007, 21:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,533 Times in 4,351 Posts
 
Default

I have no Idea why it is missing then in the users file. I added this to the bugtracker and we will check if there is some bug in the installer.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
admispconfig invalid user johann Installation/Configuration 4 15th January 2009 19:51
The PHP binary coming with ISPConfig does not work properly on your system! DreamState Installation/Configuration 15 22nd October 2006 07:31
Can't access ISPConfig on 2 month old system. digerata Installation/Configuration 3 21st August 2006 17:30
Restarted Perfect System and Lost ISPConfig! iratik Installation/Configuration 2 16th August 2006 10:05


All times are GMT +2. The time now is 08:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.