#1  
Old 14th August 2007, 17:05
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default SMTP SASL Auth Erro

Hi,

I have tried to follow the Postfix / Courier / MySQL installation howto, and although i can recieve emails via my new server, i do not seem to be able to send!!!

I have tried to follow the instructions as closely as i could, making the alteration for my IP and DNS info, but i still can't send any emails!

in the /var/log/mail.log file i get...

Code:
Aug 14 15:02:15 starfleet pop3d-ssl: Connection, ip=[::ffff:81.133.139.108]
Aug 14 15:02:17 starfleet pop3d-ssl: LOGIN, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108]
Aug 14 15:02:23 starfleet postfix/smtpd[4799]: warning: 81.133.139.108: hostname host81 verification failed: No address associated with hostname
Aug 14 15:02:23 starfleet postfix/smtpd[4799]: connect from unknown[81.133.139.108]
Aug 14 15:02:24 starfleet postfix/smtpd[4799]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Aug 14 15:02:24 starfleet postfix/smtpd[4799]: warning: unknown[81.133.139.108]: SASL LOGIN authentication failed: generic failure
Aug 14 15:02:25 starfleet postfix/smtpd[4799]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Aug 14 15:02:25 starfleet postfix/smtpd[4799]: warning: unknown[81.133.139.108]: SASL LOGIN authentication failed: generic failure
Aug 14 15:02:25 starfleet postfix/smtpd[4799]: disconnect from unknown[81.133.139.108]
Aug 14 15:02:26 starfleet pop3d-ssl: LOGOUT, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108], top=0, retr=0, rcvd=18, sent=177, time=9
can anyone shed any light on this?

Thanks in advance for any ideas anyone may have!
Reply With Quote
Sponsored Links
  #2  
Old 15th August 2007, 19:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Do you get any errors when you restart saslauthd?
What's in /etc/default/saslauthd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th August 2007, 11:01
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,

Thanks for your reply, When i stop and start SASLAUTHD i get nothing, so i assume thats telling me there is no error as such.

/etc/default/saslauthd contains the following settings

Code:
START=yes
PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
PIDFILE="/var/spool/postfix/var/run/${NAME}/saslauthd.pid"
MECHANISMS="pam"
MECH_OPTIONS=""
THREADS=5
OPTIONS="-c"
Intersetingly there is absolutely no problem when i receive mails, so authorisation does work to some degree.

I am using POP3 to connect to the server. Although IMAP is available i am not currently using it.


EDIT:
as an interesting side note, i tried logging in to the SMTP server via telnet. This allowed me to send emails to anywhere!

EDIT2:

If i remove authentication in my mail client, i appear to be able to send mails, but i get a message telling me that the message had an invalid message recipient.

When i check /var/log/mail.log again i get

Code:
Aug 16 11:22:11 starfleet pop3d-ssl: Connection, ip=[::ffff:81.133.139.108]
Aug 16 11:22:12 starfleet pop3d-ssl: LOGIN, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108]
Aug 16 11:22:14 starfleet postfix/smtpd[21647]: connect from host81-133-139-108.in-addr.btopenworld.com[81.133.139.108]
Aug 16 11:22:16 starfleet postfix/smtpd[21647]: NOQUEUE: reject: RCPT from host81-133-139-108.in-addr.btopenworld.com[81.133.139.108]: 554 5.7.1 <Sean_Bowle$
Aug 16 11:22:16 starfleet postfix/smtpd[21647]: disconnect from host81-133-139-108.in-addr.btopenworld.com[81.133.139.108]
Aug 16 11:22:22 starfleet pop3d-ssl: LOGOUT, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108], top=3291, retr=39100, rcvd=92, sent=4389$


Now i guess this is happening because you don't want unauthorised users (i.e. spammers) to be using the server as a mail relay, but on the other hand the log does say i had authenticated via pop3, so now i'm confused as to the exact process of whats happening here!!!


I am also getting log messages in mail.info stating...

Code:
Aug 16 09:00:09 starfleet postfix/proxymap[4865]: warning: connect to mysql server 127.0.0.1: Access denied for user 'mail_admin'@'localhost' (using password: YES)
Aug 16 09:00:09 starfleet postfix/proxymap[4865]: warning: connect to mysql server 127.0.0.1: Access denied for user 'mail_admin'@'localhost' (using password: YES)
They always come in pairs, and always from postfix/proxymap

i guess this could mean i have a password entered incorrectly somewhere, but i can't seem to find it.

Also, i can log in to MySql as mail_admin, but not as mail_admin@localhost. Does that matter?

Last edited by barney.parker; 16th August 2007 at 13:29.
Reply With Quote
  #4  
Old 16th August 2007, 16:01
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Done It!!!!

Falko,

I searched the forum and found the answer!!!

In the HowTo it seems to miss a single line (maybe not everyone needs it....)

in /etc/default/saslauthd i had the line

Code:
OPTIONS="-c"
It should in fact read

Code:
OPTIONS="-c -m  /var/spool/postfix/var/run/saslauthd -r"
To be honest i an mot sure why, but i am still learning!!!!!

I restarted saslauthd (stop then start) with no error messages.

All seems to work perfectly now!!!!

Thanks for your help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
SASL AUTH with postfix on Sarge keulu Server Operation 6 31st August 2006 23:49
postfix smtp sasl auth problem hammer Installation/Configuration 1 13th July 2006 19:19
SMTP Auth doesnt work maxx Installation/Configuration 5 29th June 2006 23:51


All times are GMT +2. The time now is 04:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.