Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #101  
Old 8th April 2008, 23:50
grandpagenocide grandpagenocide is offline
Senior Member
 
Join Date: Jun 2007
Location: Brooklyn, NY
Posts: 308
Thanks: 13
Thanked 43 Times in 29 Posts
Send a message via AIM to grandpagenocide Send a message via MSN to grandpagenocide
Default

ispconfig_kunde.lib.php isnt needed anymore, first change the path to soap, eliminate the /web keep the signup.php in the same folder. second have you tried the test script? try it and see if it gives you any feed back. and is your error log giving anything of value?
__________________
Hosting for the Masses
http://rhwebhosting.com
Reply With Quote
The Following User Says Thank You to grandpagenocide For This Useful Post:
EWNOC (9th April 2008)
Sponsored Links
  #102  
Old 8th April 2008, 23:54
EWNOC EWNOC is offline
HowtoForge Supporter
 
Join Date: Apr 2008
Posts: 12
Thanks: 3
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by grandpagenocide
ispconfig_kunde.lib.php isnt needed anymore, first change the path to soap, eliminate the /web keep the signup.php in the same folder. second have you tried the test script? try it and see if it gives you any feed back. and is your error log giving anything of value?
where is the test script ? and what error log do you need to see I am still a linux noob
Reply With Quote
  #103  
Old 9th April 2008, 00:43
EWNOC EWNOC is offline
HowtoForge Supporter
 
Join Date: Apr 2008
Posts: 12
Thanks: 3
Thanked 1 Time in 1 Post
Default

I gott it working to everyone make sure you do not use any speacial charecters in the remoting username **OR** password it will fail it!!!!!


Thanks for all the support
Reply With Quote
  #104  
Old 9th April 2008, 01:16
grandpagenocide grandpagenocide is offline
Senior Member
 
Join Date: Jun 2007
Location: Brooklyn, NY
Posts: 308
Thanks: 13
Thanked 43 Times in 29 Posts
Send a message via AIM to grandpagenocide Send a message via MSN to grandpagenocide
Default

EWNOC,
Just a follow up, if you go to your web folder, where you have the autosignup, go to the web root, log, and open your error log. It gives you most errors, and leads you to solutions.
__________________
Hosting for the Masses
http://rhwebhosting.com
Reply With Quote
  #105  
Old 11th April 2008, 13:27
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default What's wrong?

Oke... I've installed the remote framework on a clean install of debian Etch with ISPConfig + PHP5.2 with xml enabled. I created the remote user and uploaded the script, after editing it and changing the server/username/password.

I tried http and https as the server URL. Also the soap1.lib.php didn't work and I got the error code:
Fatal error: Cannot redeclare class soapclient in /var/www/web1/web/reseller/soap1.lib.php on line 4101

I got another version, which didn't gave me this problem, but gave me the problem beneith after pressing Submit in the webform.

Warning: SoapClient::SoapClient(https://192.168.247.128:81/remote/index.php) [function.SoapClient-SoapClient]: failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error in /var/www/web1/web/reseller/reseller.php on line 120

Warning: SoapClient::SoapClient() [function.SoapClient-SoapClient]: I/O warning : failed to load external entity "https://192.168.247.128:81/remote/index.php" in /var/www/web1/web/reseller/reseller.php on line 120

Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://192.168.247.128:81/remote/index.php' in /var/www/web1/web/reseller/reseller.php:120 Stack trace: #0 /var/www/web1/web/reseller/reseller.php(120): SoapClient->SoapClient('https://192.168...') #1 {main} thrown in /var/www/web1/web/reseller/reseller.php on line 120

Last edited by rvarkevisser; 11th April 2008 at 13:39.
Reply With Quote
  #106  
Old 11th April 2008, 13:31
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,224 Times in 4,094 Posts
Default

Please try to install the latest beta of the remoting framework:

http://www.howtoforge.com/forums/showthread.php?t=22087
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #107  
Old 11th April 2008, 13:44
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default found the problem

Till, I installed the latest framework 2 times.

Oke found the solution for the second problem.
In the reseller.php I renamed soapclient to soap_client.
Now I get the message:

registration is complete please login and created your email address and ftp login. When you login, click your website name, and you will find this under users and email.

But nothing is changed. No user is added in the reseller list and no error is created. hmm...
Reply With Quote
  #108  
Old 11th April 2008, 13:46
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,224 Times in 4,094 Posts
Default

And you installed the latest framework (the beta 4) and not the one linked on the ispconfog.org page?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #109  
Old 11th April 2008, 13:49
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default secret

Till,

Are you gonna tell me a secret now about Beta4 and where I can download it?

So no, I used the version 3 on the ispconfig.org.

Greets,
Remon

Last edited by rvarkevisser; 11th April 2008 at 13:54.
Reply With Quote
  #110  
Old 11th April 2008, 13:56
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,224 Times in 4,094 Posts
 
Default

Quote:
Originally Posted by rvarkevisser
Till,

Are you gonna tell me a secret now about Beta4 and where I can download it?

So no, I used the version 3 on the ispconfig.org.

Greets,
Remon
Please read this thread, I posted the information above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
admispconfig invalid user johann Installation/Configuration 4 15th January 2009 18:51
Anything I can do against illegal login-requests? schmidtedv Installation/Configuration 17 7th November 2008 09:25
Can't get fail2ban to work. boast Server Operation 2 26th June 2007 00:55
log files cruz Technical 3 15th May 2007 14:35


All times are GMT +2. The time now is 20:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.