#1  
Old 10th August 2007, 06:23
hooligan hooligan is offline
Junior Member
 
Join Date: Aug 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Chane proftpd default directory

Hey all

I just recently re-setup my testing web server on my local network and I'm currently setting up Proftpd. Currently it seems to be uploading to the users home directory. Its weird though my ftp client shows a whole heap of weird directory's that I cant see on linux e.g. .gconf .gnome .gnome2. Now my question is how do I configure it so that the default directory is the server root. Or even /var/www/html. I've tried a few things but I cant seem to get it right. I've even got webmin installed to help but any settings I seem to change keep it in the users directory.

Anyone set this up before?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 10th August 2007, 08:16
geekman geekman is offline
Member
 
Join Date: Sep 2006
Location: Sydney, Australia
Posts: 56
Thanks: 1
Thanked 10 Times in 10 Posts
Send a message via ICQ to geekman Send a message via MSN to geekman
Default

The reason you cannot see these files in your home directory is because they are "hidden" files, that is, they begin with a dot. Try doing ls -la in that directory and you will see them. By default proftpd is setup to rely on the system users you have for accounts, and each account you login straight to the home directory set in /etc/password. You can always change their home directory to something else (my website users have the home directory /home/websites/<user>). Other that that you could change your DefaultRoot directive to NOT jail that users group then allow them to own that directory...though I wouldn't recommend it.

Thanks.
Reply With Quote
  #3  
Old 11th August 2007, 11:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by hooligan
Its weird though my ftp client shows a whole heap of weird directory's that I cant see on linux e.g. .gconf .gnome .gnome2.
Put
Code:
LsDefaultOptions                "-l"
into your proftpd.conf, and you won't see files beginning with a dot anymore.

Quote:
Originally Posted by hooligan
Now my question is how do I configure it so that the default directory is the server root. Or even /var/www/html. I've tried a few things but I cant seem to get it right. I've even got webmin installed to help but any settings I seem to change keep it in the users directory.
Put something like
Code:
DefaultRoot /
or
Code:
DefaultRoot /var/www/html
into your proftpd.conf. Restart Proftpd afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exim MTA dazblade Server Operation 4 16th July 2007 18:42
directories in /home/admispconfig/ispconfig renamed? Spudchat General 10 12th April 2007 19:37
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
Mysterious Install Problem tgansert Installation/Configuration 5 9th May 2006 15:35
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42


All times are GMT +2. The time now is 09:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.