Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th September 2006, 11:25
resnostyle resnostyle is offline
Member
 
Join Date: Aug 2006
Posts: 50
Thanks: 0
Thanked 2 Times in 1 Post
Default ISP Config web-ftp

Hello all,

I was in the process of uploading my site using > Web-FTP/Password Protection of Directories (.htaccess/.htpasswd). When I went to do that it said "Could not connect to localhost". I know there is a problem in one of the config files.

Thanks for your assistance.
Reply With Quote
Sponsored Links
  #2  
Old 13th September 2006, 19:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Your FTP daemon must listen on localhost to if you want to be able to use the webftp in ISPConfig. Please post the output of:

netstat -tap
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th September 2006, 19:33
resnostyle resnostyle is offline
Member
 
Join Date: Aug 2006
Posts: 50
Thanks: 0
Thanked 2 Times in 1 Post
Default

(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:mysql *:* LISTEN -
tcp 0 0 *:10000 *:* LISTEN -
tcp 0 0 *:81 *:* LISTEN -
tcp 0 0 *:smtp *:* LISTEN -
tcp 1 0 localhost.localdom:smtp localhost.localdom:4839 CLOSE_WAIT -
tcp6 0 0 *:imaps *:* LISTEN -
tcp6 0 0 *op3s *:* LISTEN -
tcp6 0 0 *op3 *:* LISTEN -
tcp6 0 0 *:imap2 *:* LISTEN -
tcp6 0 0 *:www *:* LISTEN -
tcp6 0 0 *:ssh *:* LISTEN -
tcp6 0 0 *:https *:* LISTEN -
Reply With Quote
  #4  
Old 13th September 2006, 19:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

There is no ftp daemon started. Plese execute:

/etc/init.d/proftpd start
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 13th September 2006, 20:27
resnostyle resnostyle is offline
Member
 
Join Date: Aug 2006
Posts: 50
Thanks: 0
Thanked 2 Times in 1 Post
Default

okay we have arrived at the root of the problem.

after issusing that command i recieved the following error message.

Starting Proftpd ftp daemon: - Fatal: serverIdent: wrong number of parameters on line 26 of '/etc/proftpd.conf'
Reply With Quote
  #6  
Old 14th September 2006, 09:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Please post your /etc/proftpd.conf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 14th September 2006, 16:55
resnostyle resnostyle is offline
Member
 
Join Date: Aug 2006
Posts: 50
Thanks: 0
Thanked 2 Times in 1 Post
Default

Thank you very much till for your helping me.

/etc/proftpd.conf
Code:
#
# /etc/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes reload proftpd after modifications.
#

ServerName                      "Debian"
ServerType                      standalone
DeferWelcome                    off

MultilineRFC2228                on
DefaultServer                   on
ShowSymlinks                    on

TimeoutNoTransfer               600
TimeoutStalled                  600
TimeoutIdle                     1200

DisplayLogin                    welcome.msg
DisplayFirstChdir               .message
ListOptions                     "-l"

DenyFilter                      \*.*/

DefaultRoot ~
IdentLookups off
ServerIdent on"FTP Server ready."

# Uncomment this if you are using NIS or LDAP to retrieve passwords:
#PersistentPasswd               off

# Uncomment this if you would use TLS module:
#TLSEngine                      on

# Uncomment this if you would use quota module:
#Quotas                         on

# Uncomment this if you would use ratio module:
#Ratios                         on

# Port 21 is the standard FTP port.
Port                            21

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances                    30

# Set the user and group that the server normally runs at.
User                            nobody
Group                           nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask                           022  022
# Normally, we want files to be overwriteable.
/etc/init.d/proftpd
Code:
#!/bin/sh

# Start the proftpd FTP daemon.

PATH=/bin:/usr/bin:/sbin:/usr/sbin
DAEMON=/usr/sbin/proftpd
NAME=proftpd

# Defaults
RUN="no"
OPTIONS=""

PIDFILE=`grep -i 'pidfile' /etc/proftpd.conf | sed -e 's/pidfile[\t ]\+//i'`
if [ "x$PIDFILE" = "x" ];
then
        PIDFILE=/var/run/proftpd.pid
fi

# Read config (will override defaults)
[ -r /etc/default/proftpd ] && . /etc/default/proftpd

trap "" 1
trap "" 15
thanks falko. corrected.

Last edited by resnostyle; 14th September 2006 at 20:34.
Reply With Quote
  #8  
Old 14th September 2006, 19:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You only posted a part of your proftpd.conf. Please post the whole file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th September 2006, 20:54
resnostyle resnostyle is offline
Member
 
Join Date: Aug 2006
Posts: 50
Thanks: 0
Thanked 2 Times in 1 Post
Default

Fixed above.
Reply With Quote
  #10  
Old 15th September 2006, 09:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

It must be
Code:
ServerIdent on "FTP Server ready."
instead of
Code:
ServerIdent on"FTP Server ready."
in /etc/proftpd.conf. Fix it and restart ProFTPd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48
some question about "Manage DNS" vs "DNS Manager" (ISP Config) fandi2000x Installation/Configuration 1 14th February 2006 09:13
The config of webmail/pop3 make me crazy!!! :( Spektro Installation/Configuration 7 14th December 2005 14:33
Can't access System config / Settings section Spektro Installation/Configuration 1 9th December 2005 15:31
Config file templates till Developers' Forum 0 30th July 2005 23:10


All times are GMT +2. The time now is 01:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.