Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 3rd August 2005, 14:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by morphinex
This is all I get in mail.log:

Aug 3 12:28:32 localhost ipop3d[6185]: pop3 service init from 193.214.121.102
Aug 3 12:28:32 localhost ipop3d[6185]: Logout user=??? host=[193.214.121.102]

Debugging info from UebiMiau (via POP):

<- +OK POP3 localhost.localdomain v2003.83 server ready
-> USER opplev.no_even
<- -ERR Unknown AUTHORIZATION state command

And, yeah - I've tried sending to users outside the system. The email is delivered successfully nontheless...
Can you try and send yourself an email? My guess is that the mailbox hasn't been created yet, and I think it will be created when the first email arrives.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 3rd August 2005, 14:43
morphinex morphinex is offline
Junior Member
 
Join Date: Aug 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I searched around a bit and found something about Sarge final not accepting plain logins in pop... Added a line in /etc/c-client.cf and boom! it worked like a charm...


Now all that remains is the smtp problem... I've tried both without authenticating and with authenticating with the wrong credentials. Both works - also with external recipients...

Any clues?
Reply With Quote
  #13  
Old 3rd August 2005, 15:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by morphinex
I searched around a bit and found something about Sarge final not accepting plain logins in pop... Added a line in /etc/c-client.cf and boom! it worked like a charm...


Now all that remains is the smtp problem... I've tried both without authenticating and with authenticating with the wrong credentials. Both works - also with external recipients...

Any clues?
Can you run
Code:
telnet localhost 25
and then type
Code:
ehlo localhost
(to leave the prompt type quit)? Can you post the output here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 3rd August 2005, 15:46
morphinex morphinex is offline
Junior Member
 
Join Date: Aug 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 localhost ESMTP Postfix (Debian/GNU)
ehlo localhost
250-localhost
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
I tried to go a bit further, by using AUTH PLAIN encryptedpass with a password from perl -MMIME::Base64 -e 'print encode_base64(.....);' and it can successfully authenticate only if the password matches.

So it seems I haven't disabled unauthenticated logins? In that case - how can I fix it?
Reply With Quote
  #15  
Old 3rd August 2005, 16:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

So SMTP-AUTH is working. One question: when you tried to send emails over that server, were the recipient addresses on the same server, or are that external email addresses?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 3rd August 2005, 16:13
morphinex morphinex is offline
Junior Member
 
Join Date: Aug 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've tried both sending to users on my machine, and mailadresses on other computers (without any connection to my system). Both works...

BTW: Here's my postfix config:

Code:
 See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = localhost
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #17  
Old 3rd August 2005, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

And you're sure that the domains of the external email addresses are not in /etc/postfix/local-host-names?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 3rd August 2005, 20:07
morphinex morphinex is offline
Junior Member
 
Join Date: Aug 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Cool

Heh... Dunno what's changed - but now it seems to work

Thanks so much for the great suggestions - and for making such a beauuutiful guide to installing the system...


Keep up the good work!
Reply With Quote
  #19  
Old 21st October 2005, 02:35
fastcooler fastcooler is offline
Junior Member
 
Join Date: Oct 2005
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Default

Dear Staff,

I also have same problem as Morphinex...I can't access webmail (installed through Tools), because I get user name or pw wrong (I created a user, with email, ftp, webspace, etc).

This is Telnet test:

Code:
Trying 127.0.0.1...
Connected to x-174-30-41.vps.virtuo.it.
Escape character is '^]'.
220 x-174-30-41.vps.virtuo.it ESMTP Postfix (Debian/GNU)
ehlo localhost
250-x-174-30-41.vps.virtuo.it
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
quit
221 Bye
I also tried to send and email from an external link to new address.

PS: FTP works fine!

Thanks
Mark

Last edited by fastcooler; 21st October 2005 at 02:39.
Reply With Quote
  #20  
Old 21st October 2005, 03:33
fastcooler fastcooler is offline
Junior Member
 
Join Date: Oct 2005
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Solved!

I haven't selected this option:

Server>Settings>email:

Maildir

Now it works fine!

Mark
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.