Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th January 2006, 19:38
A|fie A|fie is offline
Junior Member
 
Join Date: Jan 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Problems with vsftpd

Hi,

I have problems with vsftpd installing ISPconfig with debian sarge 3.1
the installation was correct but web-ftp don´t works

when i put user and pass the ispconfig display this message:

" Ha ocurrido el siguiente error:

Could not connect as user web1_admin

Next >> "

and when i release this "next" it returns to login page.
I try a lot of times but unfortunely each one, with other users, other passwords... not work´s

can you help me please?

thanks a lot !!
Reply With Quote
Sponsored Links
  #2  
Old 29th January 2006, 00:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Did you enable FTP on the "Basis" tab of this web site?

Does the login work if you use an FTP client like SmartFTP or WS_FTP?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th January 2006, 10:50
A|fie A|fie is offline
Junior Member
 
Join Date: Jan 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I enable it.

I try to login by one ftp client type SmartFTP DeluxeFTP or trought console, but don´t work.
in console the message is :

ftp> open 62.14.109.xxx
Connected to 62.14.109.xxx
220 (vsFTPd 2.0.3)
Name (62.14.109.xxx:tete): web1_admin
530 This FTP server is anonymous only.
Login failed.
ftp> close
221 Goodbye.
ftp> open 62.14.109.xxx
Connected to 62.14.109.xxx.
220 (vsFTPd 2.0.3)
Name (62.14.109.xxx:tete): anonymous
331 Please specify the password.
Password:
500 OOPS: cannot change directory:/home/ftp
Login failed.
ftp>

and yes, the directory /home/ftp not exists
maybe i have to create it? in my config of ispconfig i choose /var/www for apache, i don´t know if i have to create this directory or not.

thank you very very much and please excuse-me for my bad english
Reply With Quote
  #4  
Old 29th January 2006, 12:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

FTP users in ISPConfig where normally chrooted to their home directory, so a user web1_admin can not change to /home/ftp. The home directory of the user web1_admin is /home/www/web1/ or /var/www/web1/ if you checked the administrator checkbox for this user. Why do you want to change to /home/ftp? This directory is not used by an ISPConfig hosting server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th January 2006, 18:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Quote:
Originally Posted by A|fie
530 This FTP server is anonymous only.
Your FTP server seems to support anonymous FTP only. Please post /etc/vsftpd.conf here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 1st February 2006, 12:41
A|fie A|fie is offline
Junior Member
 
Join Date: Jan 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, th ISPConfig has created 4 .conf for vsftpd

vsftpd_127.0.0.1.conf
vsftpd_172.26.0.xxx.conf
vsftpd_62.14.109.xxx.conf

and the vsftpd.conf here is :

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone? vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
#local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
#write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories. See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
#
# Debian customization
#
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default. These settings are more Debian-friendly.
#
# This option should be the name of a directory which is empty. Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/vsftpd.pem



well, if you want I paste the other tree... thank you a lot
Reply With Quote
  #7  
Old 1st February 2006, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Quote:
Originally Posted by A|fie
# Uncomment this to allow local users to log in.
#local_enable=YES
That's the crucial part. Remove the # sign in front of
Code:
local_enable=YES
and restart vsftpd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 2nd February 2006, 09:43
A|fie A|fie is offline
Junior Member
 
Join Date: Jan 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did it .... and It works !!

thx a lot for your help !
Reply With Quote
  #9  
Old 17th July 2006, 17:46
garfabian garfabian is offline
Junior Member
 
Join Date: Mar 2006
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default Can't connect using VSFTP

I installed vsftpd and seems to be running, when I try to connect using SFTP I get an error not able to connect that the server doesnt respond if I do regular FTP it connects fine is there something I can look at I see that I have port 20 in the config of vsftpd using ISPCONFIG control panel I open this port and still no luck. Does anyone have an idea in what could be the problem? Thank you in advance.
Reply With Quote
  #10  
Old 17th July 2006, 17:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
 
Default

Quote:
Originally Posted by garfabian
I installed vsftpd and seems to be running, when I try to connect using SFTP I get an error not able to connect that the server doesnt respond if I do regular FTP it connects fine is there something I can look at I see that I have port 20 in the config of vsftpd using ISPCONFIG control panel I open this port and still no luck. Does anyone have an idea in what could be the problem? Thank you in advance.
SFTP is handled by your SSH daemon and not by vsftpd.

You will have to enable shell access for users that shall use sftp, but I dont recommend that unless you use chrooted SSH accounts.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
problems mysql rayit General 15 1st April 2006 04:57
Problems with postfix-mysql Pelle Installation/Configuration 39 13th November 2005 23:25
Problems getting through the installation klausagnoletti Installation/Configuration 4 26th September 2005 12:23
chroot / vsftpd andre Server Operation 1 3rd May 2005 12:18


All times are GMT +2. The time now is 06:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.