Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th November 2005, 10:00
sc0ut sc0ut is offline
Junior Member
 
Join Date: Oct 2005
Location: Bosnia and Herzegovina
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default default page for shared IP

Hi,
I've been using ISPConfig v. 2.1.0, and have upgraded to 2.1.1, server is a VPS running SuSE 9.2, with 2 IPs.
When I enter any of those two IPs as URL I get Error 403, instead of index.html page from /var/www/sharedip/
Apache2 error log says:

[Tue Nov 29 03:08:28 2005] [error] [client 70.84.59.xx] client denied by server configuration: /var/www/sharedip/

Here's the part of /etc/apache2/vhosts/Vhosts_ispconfig.conf with shared IP config (as set by ISPConfig):


###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 207.210.77.xx:80
<VirtualHost 207.210.77.xx:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 207.210.77.xx:80
<VirtualHost 207.210.77.xx:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>


What could be wrong?
Reply With Quote
Sponsored Links
  #2  
Old 29th November 2005, 10:03
Tribal-Dolphin Tribal-Dolphin is offline
Member
 
Join Date: Jul 2005
Location: Rives - Isčre - FRANCE
Posts: 50
Thanks: 0
Thanked 1 Time in 1 Post
Default

Have you an .htaccess file in the directory ?
What's your Apache's Default Root ?
__________________
Tribal-Dolphin
www.tribal-dolphin.net
Reply With Quote
  #3  
Old 29th November 2005, 10:13
sc0ut sc0ut is offline
Junior Member
 
Join Date: Oct 2005
Location: Bosnia and Herzegovina
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default

There's no .htaccess in /var/www/sharedip/
and default root is as it was set during installation:

DocumentRoot "/srv/www/htdocs"

(in /etc/apache2/default-server.conf)

Just came to it, could someting like:

<Directory "/var/www/sharedip">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>

in Vhosts_ispconfig.conf solve the problem? And will that be overwritten by ISPConfig?
Reply With Quote
  #4  
Old 29th November 2005, 10:19
Tribal-Dolphin Tribal-Dolphin is offline
Member
 
Join Date: Jul 2005
Location: Rives - Isčre - FRANCE
Posts: 50
Thanks: 0
Thanked 1 Time in 1 Post
Default

Try to modify /var/www/sharedip/ by /srv/www/htdocs/sharedip and move the old foder to the new location.
__________________
Tribal-Dolphin
www.tribal-dolphin.net
Reply With Quote
  #5  
Old 29th November 2005, 10:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Everything in Vhosts_ispconfig.conf will be overwritten by ISPConfig.

But does ISPCOnfig not write a vhost for the sharedIP in your Vhosts_ispconfig.conf?

<VirtualHost [IP-ADDRESS:PORT]>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
Reply With Quote
  #6  
Old 29th November 2005, 14:15
sc0ut sc0ut is offline
Junior Member
 
Join Date: Oct 2005
Location: Bosnia and Herzegovina
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default

Well, I wrote that ISPConfig added:
NameVirtualHost 207.210.77.xx:80
<VirtualHost 207.210.77.xx:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 207.210.77.xx:80
<VirtualHost 207.210.77.xx:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>

in Vhosts_ispconfig.conf, but somehow that page / directory was forbidden (got error 403 when tried to load it).
I added:

<Directory "/var/www/sharedip">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>

in /etc/apache2/default-server.conf, and now that page is accessible, and works fine.
I think ISPConfig should not alter that file, so the change will be permanent.

(just for the record, if someone else get the same error, I'm using SuSE 9.2 & apache 2.0.55, ISPConfig 2.1.1)
Reply With Quote
  #7  
Old 29th November 2005, 14:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

ISPCOnfig does not cahnge the file: /etc/apache2/default-server.conf
Reply With Quote
  #8  
Old 29th November 2005, 14:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I've just experienced the same behaviour on Mandriva 2006, therefore I added

Code:
<Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
to /etc/httpd/conf/httpd.conf.

I've also modified the ISPConfig installer so that it will write this section to the httpd.conf in future versions automatically.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 29th November 2005, 21:16
bccisp01 bccisp01 is offline
Junior Member
 
Join Date: Sep 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Sharedip

Quote:
Originally Posted by falko
I've just experienced the same behaviour on Mandriva 2006, therefore I added

Code:
<Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
to /etc/httpd/conf/httpd.conf.

I've also modified the ISPConfig installer so that it will write this section to the httpd.conf in future versions automatically.
Where in the httpd.conf file does this go?

Thanks,
Reply With Quote
  #10  
Old 29th November 2005, 21:31
bccisp01 bccisp01 is offline
Junior Member
 
Join Date: Sep 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Re: Main Default Site?

Hey guys,

I don't mean to ask a silly question but I am stumped. I have the domain ispconfig.homelinux.net point to my server which is a Fedora Core 4 install with latest and greatest. ISPConfig installed fine. However when I goto this url http://ispconfig.homelinux.net I get a sharedip page. Needless to say I am cornfused by this. How do I create the main site so that when someone goes to that url it shows the main default site which should be my pages.

Thanks,
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Easy One - ISPConfig Default Holding Page mphayesuk General 1 27th November 2005 18:30
Default ISPconfig Page AngelDrago Installation/Configuration 15 28th October 2005 16:45
Default Welcome Page bigger_travis General 1 26th October 2005 22:56
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
WHere is the default domain's web page? Bedevere Installation/Configuration 4 28th August 2005 20:14


All times are GMT +2. The time now is 06:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.